%global _empty_manifest_terminate_build 0
Name:		python-b2handle
Version:	1.1.2
Release:	1
Summary:	Library for management of handles in the EUDAT project.
License:	Apache License 2.0
URL:		http://eudat-b2safe.github.io/B2HANDLE
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/7e/72/7a8f394d4dcdf9cd075bdb06371b4a5d651e46a1d9b1f9d33f8b6739a879/b2handle-1.1.2.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-datetime
Requires:	python3-future
Requires:	python3-six

%description
The b2handle Python library is a client library for interaction with a
`Handle System <https://handle.net>`__ server, using the native REST
interface introduced in Handle System 8. The library offers methods to
create, update and delete Handles as well as advanced functionality such
as searching over Handles using an additional search servlet and
managing multiple location entries per Handle.
The library currently supports Python 2.6, 2.7, 3.5, 3.6 and 3.7, and
requires at least a Handle System server 8.1. The library requires
OpenSSL v1.0.1 or higher.

%package -n python3-b2handle
Summary:	Library for management of handles in the EUDAT project.
Provides:	python-b2handle
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-b2handle
The b2handle Python library is a client library for interaction with a
`Handle System <https://handle.net>`__ server, using the native REST
interface introduced in Handle System 8. The library offers methods to
create, update and delete Handles as well as advanced functionality such
as searching over Handles using an additional search servlet and
managing multiple location entries per Handle.
The library currently supports Python 2.6, 2.7, 3.5, 3.6 and 3.7, and
requires at least a Handle System server 8.1. The library requires
OpenSSL v1.0.1 or higher.

%package help
Summary:	Development documents and examples for b2handle
Provides:	python3-b2handle-doc
%description help
The b2handle Python library is a client library for interaction with a
`Handle System <https://handle.net>`__ server, using the native REST
interface introduced in Handle System 8. The library offers methods to
create, update and delete Handles as well as advanced functionality such
as searching over Handles using an additional search servlet and
managing multiple location entries per Handle.
The library currently supports Python 2.6, 2.7, 3.5, 3.6 and 3.7, and
requires at least a Handle System server 8.1. The library requires
OpenSSL v1.0.1 or higher.

%prep
%autosetup -n b2handle-1.1.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-b2handle -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.2-1
- Package Spec generated