%global _empty_manifest_terminate_build 0
Name:		python-BBSpider
Version:	0.2.8
Release:	1
Summary:	a web spider
License:	MIT License
URL:		https://www.dailyrecords.xyz/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f6/40/f5fe7cfa30304866d7ca82a1c50f069f304febefa29ceff7b280deb96d4b/BBSpider-0.2.8.tar.gz
BuildArch:	noarch

Requires:	python3-pandas
Requires:	python3-bs4
Requires:	python3-requests
Requires:	python3-jieba
Requires:	python3-pyecharts

%description
# 概述

只是一个简单的B站相关的爬虫



%package -n python3-BBSpider
Summary:	a web spider
Provides:	python-BBSpider
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-BBSpider
# 概述

只是一个简单的B站相关的爬虫



%package help
Summary:	Development documents and examples for BBSpider
Provides:	python3-BBSpider-doc
%description help
# 概述

只是一个简单的B站相关的爬虫



%prep
%autosetup -n BBSpider-0.2.8

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-BBSpider -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.8-1
- Package Spec generated