%global _empty_manifest_terminate_build 0
Name:		python-recur7down
Version:	0.2.2.3
Release:	1
Summary:	recursive web scraper code for work related project
License:	MIT
URL:		https://github.com/shichaoji/recur7down
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f3/17/0e73171d7205fd2d660eb25f5e574ea6b28705b298125d34ae51575cc1ed/recur7down-0.2.2.3.tar.gz
BuildArch:	noarch

Requires:	python3-Pandas
Requires:	python3-json2df

%description
Work related tasks to scrape website recursively.




%package -n python3-recur7down
Summary:	recursive web scraper code for work related project
Provides:	python-recur7down
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-recur7down
Work related tasks to scrape website recursively.




%package help
Summary:	Development documents and examples for recur7down
Provides:	python3-recur7down-doc
%description help
Work related tasks to scrape website recursively.




%prep
%autosetup -n recur7down-0.2.2.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-recur7down -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.2.3-1
- Package Spec generated