%global _empty_manifest_terminate_build 0
Name: python-hrobot
Version: 0.7.0
Release: 1
Summary: Hybrid Robot
License: Apache
URL: https://github.com/qualitysphere/hrobot
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8a/2c/3a1877769eca96d2fe50c7b9828510335dfa82b0326bf90a5ba6a0cf1939/hrobot-0.7.0.tar.gz
BuildArch: noarch
Requires: python3-openpyxl
Requires: python3-robotframework
Requires: python3-allure-robotframework
Requires: python3-requests
Requires: python3-selenium
Requires: python3-paramiko
Requires: python3-PyYAML
%description
1 |用例标题|标签|用例描述|关键字库|关键字|参数|
2 |SSH远程后再调用 HTTP 接口 |
|
| 远程 | 执行 | root | password | whoami
3 |
|
|
|接口| GET | https://xxx/api/info | {"Content-Type":"application/json"}
4 |HTTP 接口请求后断言 |
|
| 接口 | POST | https://xxx/api/products | {"Content-Type":"application/json | {"project_owner":"jing"}
5 |
|
|
| 接口 | 响应.断言 | status_code | 等于 | 200
6 |
|
|
| 接口| 响应.断言 | body.data.0.name | 等于 | hrobot
7 |HTTP 返回值获取 |
|
| 接口 | POST | https://xxx/api/login | {"Content-Type":"application/json"} | {"username":"jing"}
8 |
|
|
| 接口| 响应.取值 | body.token | AUTH
9 |
|
|
| 接口| GET | https://xxx/api/info | {"Content-Type":"application/json","Authorization":"${AUTH}"}
10|
|
|
| 接口| 响应.断言 | status_code | 等于 | 200
11|
|
|
| 接口 | 响应.断言 | body.username | 等于 | jing
#### 执行用例
```bash
cd
hrobot run
```
#### 生成报告
```bash
hrobot report
```
## 定义变量
变量有三个级别:用例、用例集、全局,均可以在测试用例的 Excel 编写中通过关键字定义。
除此之外,也可以在用例集的 Excel 的 "变量" Sheet 中提前定义好用例集级别的变量。
全局变量还可以在 variables 目录下的 Excel 中定义,该处定义的全局变量会在报告的环境信息段落中展现。
## 自定义关键字
- 待设计
%package -n python3-hrobot
Summary: Hybrid Robot
Provides: python-hrobot
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-hrobot
1 |用例标题|标签|用例描述|关键字库|关键字|参数|
2 |SSH远程后再调用 HTTP 接口 |
|
| 远程 | 执行 | root | password | whoami
3 |
|
|
|接口| GET | https://xxx/api/info | {"Content-Type":"application/json"}
4 |HTTP 接口请求后断言 |
|
| 接口 | POST | https://xxx/api/products | {"Content-Type":"application/json | {"project_owner":"jing"}
5 |
|
|
| 接口 | 响应.断言 | status_code | 等于 | 200
6 |
|
|
| 接口| 响应.断言 | body.data.0.name | 等于 | hrobot
7 |HTTP 返回值获取 |
|
| 接口 | POST | https://xxx/api/login | {"Content-Type":"application/json"} | {"username":"jing"}
8 |
|
|
| 接口| 响应.取值 | body.token | AUTH
9 |
|
|
| 接口| GET | https://xxx/api/info | {"Content-Type":"application/json","Authorization":"${AUTH}"}
10|
|
|
| 接口| 响应.断言 | status_code | 等于 | 200
11|
|
|
| 接口 | 响应.断言 | body.username | 等于 | jing
#### 执行用例
```bash
cd
hrobot run
```
#### 生成报告
```bash
hrobot report
```
## 定义变量
变量有三个级别:用例、用例集、全局,均可以在测试用例的 Excel 编写中通过关键字定义。
除此之外,也可以在用例集的 Excel 的 "变量" Sheet 中提前定义好用例集级别的变量。
全局变量还可以在 variables 目录下的 Excel 中定义,该处定义的全局变量会在报告的环境信息段落中展现。
## 自定义关键字
- 待设计
%package help
Summary: Development documents and examples for hrobot
Provides: python3-hrobot-doc
%description help
1 |用例标题|标签|用例描述|关键字库|关键字|参数|
2 |SSH远程后再调用 HTTP 接口 |
|
| 远程 | 执行 | root | password | whoami
3 |
|
|
|接口| GET | https://xxx/api/info | {"Content-Type":"application/json"}
4 |HTTP 接口请求后断言 |
|
| 接口 | POST | https://xxx/api/products | {"Content-Type":"application/json | {"project_owner":"jing"}
5 |
|
|
| 接口 | 响应.断言 | status_code | 等于 | 200
6 |
|
|
| 接口| 响应.断言 | body.data.0.name | 等于 | hrobot
7 |HTTP 返回值获取 |
|
| 接口 | POST | https://xxx/api/login | {"Content-Type":"application/json"} | {"username":"jing"}
8 |
|
|
| 接口| 响应.取值 | body.token | AUTH
9 |
|
|
| 接口| GET | https://xxx/api/info | {"Content-Type":"application/json","Authorization":"${AUTH}"}
10|
|
|
| 接口| 响应.断言 | status_code | 等于 | 200
11|
|
|
| 接口 | 响应.断言 | body.username | 等于 | jing
#### 执行用例
```bash
cd
hrobot run
```
#### 生成报告
```bash
hrobot report
```
## 定义变量
变量有三个级别:用例、用例集、全局,均可以在测试用例的 Excel 编写中通过关键字定义。
除此之外,也可以在用例集的 Excel 的 "变量" Sheet 中提前定义好用例集级别的变量。
全局变量还可以在 variables 目录下的 Excel 中定义,该处定义的全局变量会在报告的环境信息段落中展现。
## 自定义关键字
- 待设计
%prep
%autosetup -n hrobot-0.7.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-hrobot -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.7.0-1
- Package Spec generated