%global _empty_manifest_terminate_build 0
Name:		python-pythemis
Version:	0.14.10
Release:	1
Summary:	please add a summary manually as the author left a blank one
License:	Apache 2.0
URL:		https://cossacklabs.com
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b4/84/c416f06967e20f063703929fe52519023be0d6004fc1b0cd9a32ba6da8a7/pythemis-0.14.10.tar.gz
BuildArch:	noarch


%description
# PyThemis

_Python_ wrapper for [Themis] crypto library.

Themis is an open-source high-level cryptographic services library that provides secure data exchange, authentication, and storage protection.
Themis provides ready-made building components, which simplifies the usage of core cryptographic security operations.

[Themis]: https://github.com/cossacklabs/themis

## Getting started

PyThemis requires native Themis library to be installed.
Please refer to the [installation instructions][install].

In-depth documentation can be found on our [Documentation Server].     
Make sure to check out the [Examples].
<!--

TODO: refer to simulators, code samples, and tests here

-->

[install]: https://docs.cossacklabs.com/themis/languages/python/installation/
[Documentation Server]: https://docs.cossacklabs.com/themis/
[Examples]: /docs/examples/python


## Licensing

The code is distributed under [Apache 2.0 license].

[Apache 2.0 license]: /src/wrappers/themis/python/LICENSE


%package -n python3-pythemis
Summary:	please add a summary manually as the author left a blank one
Provides:	python-pythemis
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pythemis
# PyThemis

_Python_ wrapper for [Themis] crypto library.

Themis is an open-source high-level cryptographic services library that provides secure data exchange, authentication, and storage protection.
Themis provides ready-made building components, which simplifies the usage of core cryptographic security operations.

[Themis]: https://github.com/cossacklabs/themis

## Getting started

PyThemis requires native Themis library to be installed.
Please refer to the [installation instructions][install].

In-depth documentation can be found on our [Documentation Server].     
Make sure to check out the [Examples].
<!--

TODO: refer to simulators, code samples, and tests here

-->

[install]: https://docs.cossacklabs.com/themis/languages/python/installation/
[Documentation Server]: https://docs.cossacklabs.com/themis/
[Examples]: /docs/examples/python


## Licensing

The code is distributed under [Apache 2.0 license].

[Apache 2.0 license]: /src/wrappers/themis/python/LICENSE


%package help
Summary:	Development documents and examples for pythemis
Provides:	python3-pythemis-doc
%description help
# PyThemis

_Python_ wrapper for [Themis] crypto library.

Themis is an open-source high-level cryptographic services library that provides secure data exchange, authentication, and storage protection.
Themis provides ready-made building components, which simplifies the usage of core cryptographic security operations.

[Themis]: https://github.com/cossacklabs/themis

## Getting started

PyThemis requires native Themis library to be installed.
Please refer to the [installation instructions][install].

In-depth documentation can be found on our [Documentation Server].     
Make sure to check out the [Examples].
<!--

TODO: refer to simulators, code samples, and tests here

-->

[install]: https://docs.cossacklabs.com/themis/languages/python/installation/
[Documentation Server]: https://docs.cossacklabs.com/themis/
[Examples]: /docs/examples/python


## Licensing

The code is distributed under [Apache 2.0 license].

[Apache 2.0 license]: /src/wrappers/themis/python/LICENSE


%prep
%autosetup -n pythemis-0.14.10

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pythemis -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.14.10-1
- Package Spec generated