%global _empty_manifest_terminate_build 0
Name: python-smhi-pkg
Version: 1.0.16
Release: 1
Summary: Gets the weather forecast data from Swedish weather institute
License: MIT
URL: https://github.com/joysoftware/pypi_smhi
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3f/20/2cf3222077adfcd79d1d3e37d94ea0a0db225d7d34cc713ee34fa171a594/smhi_pkg-1.0.16.tar.gz
BuildArch: noarch
%description
# SMHI Swedish weather institute package
Python library for accessing SMHI open forecast data
Please visit http://opendata.smhi.se/apidocs/metfcst/parameters.html for more information
If you want to contribute you can use devcontainers in vscode for easiest setup. Please see [instructions here](.devcontainer/README.md)
If you like what I do and want to buy me a cup of coffee. It is always appreciated :)
%package -n python3-smhi-pkg
Summary: Gets the weather forecast data from Swedish weather institute
Provides: python-smhi-pkg
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-smhi-pkg
# SMHI Swedish weather institute package
Python library for accessing SMHI open forecast data
Please visit http://opendata.smhi.se/apidocs/metfcst/parameters.html for more information
If you want to contribute you can use devcontainers in vscode for easiest setup. Please see [instructions here](.devcontainer/README.md)
If you like what I do and want to buy me a cup of coffee. It is always appreciated :)
%package help
Summary: Development documents and examples for smhi-pkg
Provides: python3-smhi-pkg-doc
%description help
# SMHI Swedish weather institute package
Python library for accessing SMHI open forecast data
Please visit http://opendata.smhi.se/apidocs/metfcst/parameters.html for more information
If you want to contribute you can use devcontainers in vscode for easiest setup. Please see [instructions here](.devcontainer/README.md)
If you like what I do and want to buy me a cup of coffee. It is always appreciated :)
%prep
%autosetup -n smhi-pkg-1.0.16
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-smhi-pkg -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.0.16-1
- Package Spec generated