%global _empty_manifest_terminate_build 0
Name: python-ismartgate
Version: 5.0.0
Release: 1
Summary: iSmartGate and GogoGate2 API
License: MIT license
URL: https://github.com/bdraco/ismartgate
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ae/93/a2e5423a4d30254882ae51aed574a76723a4ad24f934062abaeb200047dd/ismartgate-5.0.0.tar.gz
BuildArch: noarch
Requires: python3-dicttoxml
Requires: python3-defusedxml
Requires: python3-pycryptodome
Requires: python3-httpx
Requires: python3-dicttoxml
Requires: python3-defusedxml
Requires: python3-pycryptodome
Requires: python3-httpx
Requires: python3-pytest-runner
Requires: python3-typing-extensions
Requires: python3-respx
Requires: python3-pytest-asyncio
Requires: python3-black
Requires: python3-codecov
Requires: python3-flake8
Requires: python3-flake8-debugger
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-raises
Requires: python3-bump2version
Requires: python3-coverage
Requires: python3-ipython
Requires: python3-m2r2
Requires: python3-Sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-tox
Requires: python3-twine
Requires: python3-wheel
Requires: python3-pytest-runner
Requires: python3-typing-extensions
Requires: python3-respx
Requires: python3-pytest-asyncio
Requires: python3-black
Requires: python3-codecov
Requires: python3-flake8
Requires: python3-flake8-debugger
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-raises
Requires: python3-bump2version
Requires: python3-coverage
Requires: python3-ipython
Requires: python3-m2r2
Requires: python3-Sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-tox
Requires: python3-twine
Requires: python3-wheel
Requires: python3-pytest-runner
Requires: python3-typing-extensions
Requires: python3-respx
Requires: python3-pytest-asyncio
Requires: python3-black
Requires: python3-codecov
Requires: python3-flake8
Requires: python3-flake8-debugger
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-raises
%description
## About
This is a fork of vangorra's excellent `python_gogogate2_api` library from https://github.com/vangorra/python_gogogate2_api
## Installation
**Stable Release:** `pip install ismartgate`
**Development Head:** `pip install git+https://github.com/bdraco/ismartgate.git`
## Usage in Commands
```shell script
$ gogogate2 --help
Usage: gogogate2 [OPTIONS] COMMAND [ARGS]...
Interact with the device API.
Options:
--host TEXT [required]
--username TEXT [required]
--password TEXT Omit for interactive prompt. Use '-' to read from stdin.
--version Show the version and exit.
--help Show this message and exit.
Commands:
close Close the door.
info Get info from device.
open Open the door.
$ ismartgate --help
Usage: ismartgate [OPTIONS] COMMAND [ARGS]...
Interact with the device API.
Options:
--host TEXT [required]
--username TEXT [required]
--password TEXT Omit for interactive prompt. Use '-' to read from stdin.
--version Show the version and exit.
--help Show this message and exit.
Commands:
close Close the door.
info Get info from device.
open Open the door.
```
## Usage in Code
```python
from ismartgate import GogoGate2Api, ISmartGateApi
# GogoGate2 API
gogogate2_api = GogoGate2Api("10.10.0.23", "admin", "password")
# Get info about device and all doors.
await gogogate2_api.async_info()
# Open/close door.
await gogogate2_api.async_open_door(1)
await gogogate2_api.async_close_door(1)
# iSmartGate API
ismartgate_api = ISmartGateApi("10.10.0.24", "admin", "password")
# Get info about device and all doors.
await ismartgate_api.async_info()
# Open/close door.
await ismartgate_api.async_open_door(1)
await ismartgate_api.async_close_door(1)
```
## Documentation
For full package documentation please visit [bdraco.github.io/ismartgate](https://bdraco.github.io/ismartgate).
## Development
See [CONTRIBUTING.md](CONTRIBUTING.md) for information related to developing the code.
## The Four Commands You Need To Know
1. `pip install -e .[dev]`
This will install your package in editable mode with all the required development
dependencies (i.e. `tox`).
2. `make build`
This will run `tox` which will run all your tests in both Python 3.7
and Python 3.8 as well as linting your code.
3. `make clean`
This will clean up various Python and build generated files so that you can ensure
that you are working in a clean environment.
4. `make docs`
This will generate and launch a web browser to view the most up-to-date
documentation for your Python package.
#### Additional Optional Setup Steps:
- Turn your project into a GitHub repository:
- Make an account on [github.com](https://github.com)
- Go to [make a new repository](https://github.com/new)
- _Recommendations:_
- _It is strongly recommended to make the repository name the same as the Python
package name_
- _A lot of the following optional steps are *free* if the repository is Public,
plus open source is cool_
- After a GitHub repo has been created, run the commands listed under:
"...or push an existing repository from the command line"
- Register your project with Codecov:
- Make an account on [codecov.io](https://codecov.io)(Recommended to sign in with GitHub)
everything else will be handled for you.
- Ensure that you have set GitHub pages to build the `gh-pages` branch by selecting the
`gh-pages` branch in the dropdown in the "GitHub Pages" section of the repository settings.
([Repo Settings](https://github.com/bdraco/ismartgate/settings))
- Register your project with PyPI:
- Make an account on [pypi.org](https://pypi.org)
- Go to your GitHub repository's settings and under the
[Secrets tab](https://github.com/bdraco/ismartgate/settings/secrets/actions),
add a secret called `PYPI_TOKEN` with your password for your PyPI account.
Don't worry, no one will see this password because it will be encrypted.
- Next time you push to the branch `main` after using `bump2version`, GitHub
actions will build and deploy your Python package to PyPI.
#### Suggested Git Branch Strategy
1. `main` is for the most up-to-date development, very rarely should you directly
commit to this branch. GitHub Actions will run on every push and on a CRON to this
branch but still recommended to commit to your development branches and make pull
requests to main. If you push a tagged commit with bumpversion, this will also release to PyPI.
2. Your day-to-day work should exist on branches separate from `main`. Even if it is
just yourself working on the repository, make a PR from your working branch to `main`
so that you can ensure your commits don't break the development head. GitHub Actions
will run on every push to any branch or any pull request from any branch to any other
branch.
3. It is recommended to use "Squash and Merge" commits when committing PR's. It makes
each set of changes to `main` atomic and as a side effect naturally encourages small
well defined PR's.
**MIT license**
%package -n python3-ismartgate
Summary: iSmartGate and GogoGate2 API
Provides: python-ismartgate
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ismartgate
## About
This is a fork of vangorra's excellent `python_gogogate2_api` library from https://github.com/vangorra/python_gogogate2_api
## Installation
**Stable Release:** `pip install ismartgate`
**Development Head:** `pip install git+https://github.com/bdraco/ismartgate.git`
## Usage in Commands
```shell script
$ gogogate2 --help
Usage: gogogate2 [OPTIONS] COMMAND [ARGS]...
Interact with the device API.
Options:
--host TEXT [required]
--username TEXT [required]
--password TEXT Omit for interactive prompt. Use '-' to read from stdin.
--version Show the version and exit.
--help Show this message and exit.
Commands:
close Close the door.
info Get info from device.
open Open the door.
$ ismartgate --help
Usage: ismartgate [OPTIONS] COMMAND [ARGS]...
Interact with the device API.
Options:
--host TEXT [required]
--username TEXT [required]
--password TEXT Omit for interactive prompt. Use '-' to read from stdin.
--version Show the version and exit.
--help Show this message and exit.
Commands:
close Close the door.
info Get info from device.
open Open the door.
```
## Usage in Code
```python
from ismartgate import GogoGate2Api, ISmartGateApi
# GogoGate2 API
gogogate2_api = GogoGate2Api("10.10.0.23", "admin", "password")
# Get info about device and all doors.
await gogogate2_api.async_info()
# Open/close door.
await gogogate2_api.async_open_door(1)
await gogogate2_api.async_close_door(1)
# iSmartGate API
ismartgate_api = ISmartGateApi("10.10.0.24", "admin", "password")
# Get info about device and all doors.
await ismartgate_api.async_info()
# Open/close door.
await ismartgate_api.async_open_door(1)
await ismartgate_api.async_close_door(1)
```
## Documentation
For full package documentation please visit [bdraco.github.io/ismartgate](https://bdraco.github.io/ismartgate).
## Development
See [CONTRIBUTING.md](CONTRIBUTING.md) for information related to developing the code.
## The Four Commands You Need To Know
1. `pip install -e .[dev]`
This will install your package in editable mode with all the required development
dependencies (i.e. `tox`).
2. `make build`
This will run `tox` which will run all your tests in both Python 3.7
and Python 3.8 as well as linting your code.
3. `make clean`
This will clean up various Python and build generated files so that you can ensure
that you are working in a clean environment.
4. `make docs`
This will generate and launch a web browser to view the most up-to-date
documentation for your Python package.
#### Additional Optional Setup Steps:
- Turn your project into a GitHub repository:
- Make an account on [github.com](https://github.com)
- Go to [make a new repository](https://github.com/new)
- _Recommendations:_
- _It is strongly recommended to make the repository name the same as the Python
package name_
- _A lot of the following optional steps are *free* if the repository is Public,
plus open source is cool_
- After a GitHub repo has been created, run the commands listed under:
"...or push an existing repository from the command line"
- Register your project with Codecov:
- Make an account on [codecov.io](https://codecov.io)(Recommended to sign in with GitHub)
everything else will be handled for you.
- Ensure that you have set GitHub pages to build the `gh-pages` branch by selecting the
`gh-pages` branch in the dropdown in the "GitHub Pages" section of the repository settings.
([Repo Settings](https://github.com/bdraco/ismartgate/settings))
- Register your project with PyPI:
- Make an account on [pypi.org](https://pypi.org)
- Go to your GitHub repository's settings and under the
[Secrets tab](https://github.com/bdraco/ismartgate/settings/secrets/actions),
add a secret called `PYPI_TOKEN` with your password for your PyPI account.
Don't worry, no one will see this password because it will be encrypted.
- Next time you push to the branch `main` after using `bump2version`, GitHub
actions will build and deploy your Python package to PyPI.
#### Suggested Git Branch Strategy
1. `main` is for the most up-to-date development, very rarely should you directly
commit to this branch. GitHub Actions will run on every push and on a CRON to this
branch but still recommended to commit to your development branches and make pull
requests to main. If you push a tagged commit with bumpversion, this will also release to PyPI.
2. Your day-to-day work should exist on branches separate from `main`. Even if it is
just yourself working on the repository, make a PR from your working branch to `main`
so that you can ensure your commits don't break the development head. GitHub Actions
will run on every push to any branch or any pull request from any branch to any other
branch.
3. It is recommended to use "Squash and Merge" commits when committing PR's. It makes
each set of changes to `main` atomic and as a side effect naturally encourages small
well defined PR's.
**MIT license**
%package help
Summary: Development documents and examples for ismartgate
Provides: python3-ismartgate-doc
%description help
## About
This is a fork of vangorra's excellent `python_gogogate2_api` library from https://github.com/vangorra/python_gogogate2_api
## Installation
**Stable Release:** `pip install ismartgate`
**Development Head:** `pip install git+https://github.com/bdraco/ismartgate.git`
## Usage in Commands
```shell script
$ gogogate2 --help
Usage: gogogate2 [OPTIONS] COMMAND [ARGS]...
Interact with the device API.
Options:
--host TEXT [required]
--username TEXT [required]
--password TEXT Omit for interactive prompt. Use '-' to read from stdin.
--version Show the version and exit.
--help Show this message and exit.
Commands:
close Close the door.
info Get info from device.
open Open the door.
$ ismartgate --help
Usage: ismartgate [OPTIONS] COMMAND [ARGS]...
Interact with the device API.
Options:
--host TEXT [required]
--username TEXT [required]
--password TEXT Omit for interactive prompt. Use '-' to read from stdin.
--version Show the version and exit.
--help Show this message and exit.
Commands:
close Close the door.
info Get info from device.
open Open the door.
```
## Usage in Code
```python
from ismartgate import GogoGate2Api, ISmartGateApi
# GogoGate2 API
gogogate2_api = GogoGate2Api("10.10.0.23", "admin", "password")
# Get info about device and all doors.
await gogogate2_api.async_info()
# Open/close door.
await gogogate2_api.async_open_door(1)
await gogogate2_api.async_close_door(1)
# iSmartGate API
ismartgate_api = ISmartGateApi("10.10.0.24", "admin", "password")
# Get info about device and all doors.
await ismartgate_api.async_info()
# Open/close door.
await ismartgate_api.async_open_door(1)
await ismartgate_api.async_close_door(1)
```
## Documentation
For full package documentation please visit [bdraco.github.io/ismartgate](https://bdraco.github.io/ismartgate).
## Development
See [CONTRIBUTING.md](CONTRIBUTING.md) for information related to developing the code.
## The Four Commands You Need To Know
1. `pip install -e .[dev]`
This will install your package in editable mode with all the required development
dependencies (i.e. `tox`).
2. `make build`
This will run `tox` which will run all your tests in both Python 3.7
and Python 3.8 as well as linting your code.
3. `make clean`
This will clean up various Python and build generated files so that you can ensure
that you are working in a clean environment.
4. `make docs`
This will generate and launch a web browser to view the most up-to-date
documentation for your Python package.
#### Additional Optional Setup Steps:
- Turn your project into a GitHub repository:
- Make an account on [github.com](https://github.com)
- Go to [make a new repository](https://github.com/new)
- _Recommendations:_
- _It is strongly recommended to make the repository name the same as the Python
package name_
- _A lot of the following optional steps are *free* if the repository is Public,
plus open source is cool_
- After a GitHub repo has been created, run the commands listed under:
"...or push an existing repository from the command line"
- Register your project with Codecov:
- Make an account on [codecov.io](https://codecov.io)(Recommended to sign in with GitHub)
everything else will be handled for you.
- Ensure that you have set GitHub pages to build the `gh-pages` branch by selecting the
`gh-pages` branch in the dropdown in the "GitHub Pages" section of the repository settings.
([Repo Settings](https://github.com/bdraco/ismartgate/settings))
- Register your project with PyPI:
- Make an account on [pypi.org](https://pypi.org)
- Go to your GitHub repository's settings and under the
[Secrets tab](https://github.com/bdraco/ismartgate/settings/secrets/actions),
add a secret called `PYPI_TOKEN` with your password for your PyPI account.
Don't worry, no one will see this password because it will be encrypted.
- Next time you push to the branch `main` after using `bump2version`, GitHub
actions will build and deploy your Python package to PyPI.
#### Suggested Git Branch Strategy
1. `main` is for the most up-to-date development, very rarely should you directly
commit to this branch. GitHub Actions will run on every push and on a CRON to this
branch but still recommended to commit to your development branches and make pull
requests to main. If you push a tagged commit with bumpversion, this will also release to PyPI.
2. Your day-to-day work should exist on branches separate from `main`. Even if it is
just yourself working on the repository, make a PR from your working branch to `main`
so that you can ensure your commits don't break the development head. GitHub Actions
will run on every push to any branch or any pull request from any branch to any other
branch.
3. It is recommended to use "Squash and Merge" commits when committing PR's. It makes
each set of changes to `main` atomic and as a side effect naturally encourages small
well defined PR's.
**MIT license**
%prep
%autosetup -n ismartgate-5.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ismartgate -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 5.0.0-1
- Package Spec generated