%global _empty_manifest_terminate_build 0
Name:		python-sqlalchemy-pyodbc-mssql
Version:	0.1.1
Release:	1
Summary:	SA dialect for MSSQL using PyODBC which handles MSSQL-specific limitations
License:	BSD License
URL:		https://github.com/level12/sqlalchemy_pyodbc_mssql
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/3b/18/b8c6c5752ce82484e6f78bc214d93f6b239c464847db521e289e0c231bab/sqlalchemy_pyodbc_mssql-0.1.1.tar.gz
BuildArch:	noarch

Requires:	python3-pyodbc
Requires:	python3-sqlalchemy
Requires:	python3-blazeform
Requires:	python3-flake8
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-tox

%description


%package -n python3-sqlalchemy-pyodbc-mssql
Summary:	SA dialect for MSSQL using PyODBC which handles MSSQL-specific limitations
Provides:	python-sqlalchemy-pyodbc-mssql
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sqlalchemy-pyodbc-mssql


%package help
Summary:	Development documents and examples for sqlalchemy-pyodbc-mssql
Provides:	python3-sqlalchemy-pyodbc-mssql-doc
%description help


%prep
%autosetup -n sqlalchemy-pyodbc-mssql-0.1.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sqlalchemy-pyodbc-mssql -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.1-1
- Package Spec generated