%global _empty_manifest_terminate_build 0
Name: python-fastybird-triggers-module
Version: 0.46.0
Release: 1
Summary: FastyBird metadata for modules.
License: Apache Software License (Apache Software License 2.0)
URL: https://github.com/FastyBird/triggers-module
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b6/e8/9bf8b04f28899f5128e3b20566b328b1ab11ac9349501e8e94f87d6ee415/fastybird-triggers-module-0.46.0.tar.gz
BuildArch: noarch
Requires: python3-fastnumbers
Requires: python3-fastybird-metadata
Requires: python3-kink
Requires: python3-mysqlclient
Requires: python3-setuptools
Requires: python3-sqlalchemy
Requires: python3-pymysql
%description
# FastyBird IoT triggers module
[](https://github.com/FastyBird/triggers-module/actions)
[](https://github.com/FastyBird/triggers-module/blob/main/LICENSE.md)

[](https://coveralls.io/r/FastyBird/triggers-module)
[](https://packagist.org/packages/FastyBird/triggers-module)
[](https://packagist.org/packages/FastyBird/triggers-module)
[](https://github.com/phpstan/phpstan)
[](https://www.npmjs.com/package/@fastybird/triggers-module)
[](https://www.npmjs.com/package/@fastybird/triggers-module)


[](https://pypi.org/project/fastybird-triggers-module/)
[](https://pypi.org/project/fastybird-triggers-module/)
[](https://github.com/psf/black)
[](http://mypy-lang.org)
## What is FastyBird IoT triggers module?
Triggers module is a combined [Nette framework](https://nette.org) extension, [Vuex ORM](https://vuex-orm.org) plugin
and also [Python](https://python.org) module for managing application automation & notifications.
[FastyBird](https://www.fastybird.com) [IoT](https://en.wikipedia.org/wiki/Internet_of_things) triggers module is
an [Apache2 licensed](http://www.apache.org/licenses/LICENSE-2.0) distributed extension, developed
in [PHP](https://www.php.net) with [Nette framework](https://nette.org), in [Typescript](https://www.typescriptlang.org)
and also in [Python](https://python.org).
### Features:
- Triggers and their actions and conditions management
- Support for data [exchange bus](https://github.com/FastyBird/exchange)
- [{JSON:API}](https://jsonapi.org/) schemas for full api access
- User access check & validation
- Multilingual
- JS integration via [Vuex ORM](https://vuex-orm.org) plugin
- Python integration via [SQLAlchemy](https://www.sqlalchemy.org)
- Integrated connector worker for Python based connectors & PHP based connectors
## Requirements
PHP part of [FastyBird](https://www.fastybird.com) triggers module is tested against PHP 7.4
and [ReactPHP http](https://github.com/reactphp/http) 0.8 event-driven, streaming plaintext HTTP server
and [Nette framework](https://nette.org/en/) 3.0 PHP framework for real programmers
JavaScript part of [FastyBird](https://www.fastybird.com) triggers module is tested
against [ECMAScript 6](https://www.w3schools.com/JS/js_es6.asp)
Python part of [FastyBird](https://www.fastybird.com) triggers module is tested against [Python 3.7](http://python.org)
## Installation
#### Application backend in PHP
The best way to install **fastybird/triggers-module** is using [Composer](http://getcomposer.org/):
```sh
composer require fastybird/triggers-module
```
#### Application frontend in JS
The best way to install **@fastybird/triggers-module** is using [Yarn](https://yarnpkg.com/):
```sh
yarn add @fastybird/triggers-module
```
or if you prefer npm:
```sh
npm install @fastybird/triggers-module
```
#### Application workers in Python
The best way to install **fastybird-triggers-module** is using [pip](https://pip.pypa.io/):
```sh
pip install fastybird-triggers-module
```
## Documentation
Learn how to use triggers module and manage your triggers
in [documentation](https://github.com/FastyBird/triggers-module/blob/main/.docs/en/index.md).
## Feedback
Use the [issue tracker](https://github.com/FastyBird/triggers-module/issues) for bugs
or [mail](mailto:code@fastybird.com) or [Tweet](https://twitter.com/fastybird) us for any idea that can improve the
project.
Thank you for testing, reporting and contributing.
## Changelog
For release info check [release page](https://github.com/FastyBird/triggers-module/releases)
## Maintainers
***
Homepage [https://www.fastybird.com](https://www.fastybird.com) and
repository [https://github.com/fastybird/triggers-module](https://github.com/fastybird/triggers-module).
%package -n python3-fastybird-triggers-module
Summary: FastyBird metadata for modules.
Provides: python-fastybird-triggers-module
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fastybird-triggers-module
# FastyBird IoT triggers module
[](https://github.com/FastyBird/triggers-module/actions)
[](https://github.com/FastyBird/triggers-module/blob/main/LICENSE.md)

[](https://coveralls.io/r/FastyBird/triggers-module)
[](https://packagist.org/packages/FastyBird/triggers-module)
[](https://packagist.org/packages/FastyBird/triggers-module)
[](https://github.com/phpstan/phpstan)
[](https://www.npmjs.com/package/@fastybird/triggers-module)
[](https://www.npmjs.com/package/@fastybird/triggers-module)


[](https://pypi.org/project/fastybird-triggers-module/)
[](https://pypi.org/project/fastybird-triggers-module/)
[](https://github.com/psf/black)
[](http://mypy-lang.org)
## What is FastyBird IoT triggers module?
Triggers module is a combined [Nette framework](https://nette.org) extension, [Vuex ORM](https://vuex-orm.org) plugin
and also [Python](https://python.org) module for managing application automation & notifications.
[FastyBird](https://www.fastybird.com) [IoT](https://en.wikipedia.org/wiki/Internet_of_things) triggers module is
an [Apache2 licensed](http://www.apache.org/licenses/LICENSE-2.0) distributed extension, developed
in [PHP](https://www.php.net) with [Nette framework](https://nette.org), in [Typescript](https://www.typescriptlang.org)
and also in [Python](https://python.org).
### Features:
- Triggers and their actions and conditions management
- Support for data [exchange bus](https://github.com/FastyBird/exchange)
- [{JSON:API}](https://jsonapi.org/) schemas for full api access
- User access check & validation
- Multilingual
- JS integration via [Vuex ORM](https://vuex-orm.org) plugin
- Python integration via [SQLAlchemy](https://www.sqlalchemy.org)
- Integrated connector worker for Python based connectors & PHP based connectors
## Requirements
PHP part of [FastyBird](https://www.fastybird.com) triggers module is tested against PHP 7.4
and [ReactPHP http](https://github.com/reactphp/http) 0.8 event-driven, streaming plaintext HTTP server
and [Nette framework](https://nette.org/en/) 3.0 PHP framework for real programmers
JavaScript part of [FastyBird](https://www.fastybird.com) triggers module is tested
against [ECMAScript 6](https://www.w3schools.com/JS/js_es6.asp)
Python part of [FastyBird](https://www.fastybird.com) triggers module is tested against [Python 3.7](http://python.org)
## Installation
#### Application backend in PHP
The best way to install **fastybird/triggers-module** is using [Composer](http://getcomposer.org/):
```sh
composer require fastybird/triggers-module
```
#### Application frontend in JS
The best way to install **@fastybird/triggers-module** is using [Yarn](https://yarnpkg.com/):
```sh
yarn add @fastybird/triggers-module
```
or if you prefer npm:
```sh
npm install @fastybird/triggers-module
```
#### Application workers in Python
The best way to install **fastybird-triggers-module** is using [pip](https://pip.pypa.io/):
```sh
pip install fastybird-triggers-module
```
## Documentation
Learn how to use triggers module and manage your triggers
in [documentation](https://github.com/FastyBird/triggers-module/blob/main/.docs/en/index.md).
## Feedback
Use the [issue tracker](https://github.com/FastyBird/triggers-module/issues) for bugs
or [mail](mailto:code@fastybird.com) or [Tweet](https://twitter.com/fastybird) us for any idea that can improve the
project.
Thank you for testing, reporting and contributing.
## Changelog
For release info check [release page](https://github.com/FastyBird/triggers-module/releases)
## Maintainers
***
Homepage [https://www.fastybird.com](https://www.fastybird.com) and
repository [https://github.com/fastybird/triggers-module](https://github.com/fastybird/triggers-module).
%package help
Summary: Development documents and examples for fastybird-triggers-module
Provides: python3-fastybird-triggers-module-doc
%description help
# FastyBird IoT triggers module
[](https://github.com/FastyBird/triggers-module/actions)
[](https://github.com/FastyBird/triggers-module/blob/main/LICENSE.md)

[](https://coveralls.io/r/FastyBird/triggers-module)
[](https://packagist.org/packages/FastyBird/triggers-module)
[](https://packagist.org/packages/FastyBird/triggers-module)
[](https://github.com/phpstan/phpstan)
[](https://www.npmjs.com/package/@fastybird/triggers-module)
[](https://www.npmjs.com/package/@fastybird/triggers-module)


[](https://pypi.org/project/fastybird-triggers-module/)
[](https://pypi.org/project/fastybird-triggers-module/)
[](https://github.com/psf/black)
[](http://mypy-lang.org)
## What is FastyBird IoT triggers module?
Triggers module is a combined [Nette framework](https://nette.org) extension, [Vuex ORM](https://vuex-orm.org) plugin
and also [Python](https://python.org) module for managing application automation & notifications.
[FastyBird](https://www.fastybird.com) [IoT](https://en.wikipedia.org/wiki/Internet_of_things) triggers module is
an [Apache2 licensed](http://www.apache.org/licenses/LICENSE-2.0) distributed extension, developed
in [PHP](https://www.php.net) with [Nette framework](https://nette.org), in [Typescript](https://www.typescriptlang.org)
and also in [Python](https://python.org).
### Features:
- Triggers and their actions and conditions management
- Support for data [exchange bus](https://github.com/FastyBird/exchange)
- [{JSON:API}](https://jsonapi.org/) schemas for full api access
- User access check & validation
- Multilingual
- JS integration via [Vuex ORM](https://vuex-orm.org) plugin
- Python integration via [SQLAlchemy](https://www.sqlalchemy.org)
- Integrated connector worker for Python based connectors & PHP based connectors
## Requirements
PHP part of [FastyBird](https://www.fastybird.com) triggers module is tested against PHP 7.4
and [ReactPHP http](https://github.com/reactphp/http) 0.8 event-driven, streaming plaintext HTTP server
and [Nette framework](https://nette.org/en/) 3.0 PHP framework for real programmers
JavaScript part of [FastyBird](https://www.fastybird.com) triggers module is tested
against [ECMAScript 6](https://www.w3schools.com/JS/js_es6.asp)
Python part of [FastyBird](https://www.fastybird.com) triggers module is tested against [Python 3.7](http://python.org)
## Installation
#### Application backend in PHP
The best way to install **fastybird/triggers-module** is using [Composer](http://getcomposer.org/):
```sh
composer require fastybird/triggers-module
```
#### Application frontend in JS
The best way to install **@fastybird/triggers-module** is using [Yarn](https://yarnpkg.com/):
```sh
yarn add @fastybird/triggers-module
```
or if you prefer npm:
```sh
npm install @fastybird/triggers-module
```
#### Application workers in Python
The best way to install **fastybird-triggers-module** is using [pip](https://pip.pypa.io/):
```sh
pip install fastybird-triggers-module
```
## Documentation
Learn how to use triggers module and manage your triggers
in [documentation](https://github.com/FastyBird/triggers-module/blob/main/.docs/en/index.md).
## Feedback
Use the [issue tracker](https://github.com/FastyBird/triggers-module/issues) for bugs
or [mail](mailto:code@fastybird.com) or [Tweet](https://twitter.com/fastybird) us for any idea that can improve the
project.
Thank you for testing, reporting and contributing.
## Changelog
For release info check [release page](https://github.com/FastyBird/triggers-module/releases)
## Maintainers
***
Homepage [https://www.fastybird.com](https://www.fastybird.com) and
repository [https://github.com/fastybird/triggers-module](https://github.com/fastybird/triggers-module).
%prep
%autosetup -n fastybird-triggers-module-0.46.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fastybird-triggers-module -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.46.0-1
- Package Spec generated