%global _empty_manifest_terminate_build 0
Name:		python-arnoldpaperboy
Version:	0.1.9
Release:	1
Summary:	Deliver to stackdriver
License:	Apache-2.0
URL:		https://gitlab.com/satelligence/arnoldpaperboy
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/29/66/8405bebc17e528c7c7ad519ef7d4736025be0ea6cd1d95c262c6f9eceb0d/arnoldpaperboy-0.1.9.tar.gz
BuildArch:	noarch

Requires:	python3-dealer
Requires:	python3-google-api-core
Requires:	python3-google-auth
Requires:	python3-google-cloud-core
Requires:	python3-google-cloud-logging
Requires:	python3-google-cloud-monitoring
Requires:	python3-googleapis-common-protos
Requires:	python3-grpc-google-iam-v1
Requires:	python3-grpcio

%description
Delivers the Daily Slab. As a python package, it also facilitates
logging from python in kubernetes to stackdriver.
Arnoldpaperboy is developed by Satelligence ("S11") to aid proper logging to Stackdriver from python
processes running in Kubernetes. With as little influence on existing code as possible.

%package -n python3-arnoldpaperboy
Summary:	Deliver to stackdriver
Provides:	python-arnoldpaperboy
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-arnoldpaperboy
Delivers the Daily Slab. As a python package, it also facilitates
logging from python in kubernetes to stackdriver.
Arnoldpaperboy is developed by Satelligence ("S11") to aid proper logging to Stackdriver from python
processes running in Kubernetes. With as little influence on existing code as possible.

%package help
Summary:	Development documents and examples for arnoldpaperboy
Provides:	python3-arnoldpaperboy-doc
%description help
Delivers the Daily Slab. As a python package, it also facilitates
logging from python in kubernetes to stackdriver.
Arnoldpaperboy is developed by Satelligence ("S11") to aid proper logging to Stackdriver from python
processes running in Kubernetes. With as little influence on existing code as possible.

%prep
%autosetup -n arnoldpaperboy-0.1.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-arnoldpaperboy -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.9-1
- Package Spec generated