%global _empty_manifest_terminate_build 0
Name:		python-airflow-run
Version:	0.4.9
Release:	1
Summary:	Simplified Airflow CLI Tool for Lauching CeleryExecutor Deployment
License:	MIT
URL:		https://github.com/paulokuong/airflow-run
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/43/02/25e3fd96986f630c4e9e1b25bb7e41182bac022d53368b9407fc44bb0cc4/airflow-run-0.4.9.tar.gz
BuildArch:	noarch

Requires:	python3-docker
Requires:	python3-pyyaml
Requires:	python3-sqlalchemy
Requires:	python3-pika
Requires:	python3-psycopg2-binary
Requires:	python3-cryptography

%description
Python tool for deploying Airflow Multi-Node Cluster.

%package -n python3-airflow-run
Summary:	Simplified Airflow CLI Tool for Lauching CeleryExecutor Deployment
Provides:	python-airflow-run
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-airflow-run
Python tool for deploying Airflow Multi-Node Cluster.

%package help
Summary:	Development documents and examples for airflow-run
Provides:	python3-airflow-run-doc
%description help
Python tool for deploying Airflow Multi-Node Cluster.

%prep
%autosetup -n airflow-run-0.4.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-airflow-run -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.9-1
- Package Spec generated