%global _empty_manifest_terminate_build 0
Name:		python-multithreading
Version:	0.2.0
Release:	1
Summary:	MultiThreading: Thread + Queue
License:	MIT License
URL:		https://github.com/aztecrabbit/multithreading
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ff/1b/ac73d57918d36ec132f9b1f7942c69ebee392fa339713d979d9e294e815e/multithreading-0.2.0.tar.gz
BuildArch:	noarch


%description
```python
import multithreading
class Demo(multithreading.MultiThread):
    def task(self, task):
        print(task)
```

%package -n python3-multithreading
Summary:	MultiThreading: Thread + Queue
Provides:	python-multithreading
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-multithreading
```python
import multithreading
class Demo(multithreading.MultiThread):
    def task(self, task):
        print(task)
```

%package help
Summary:	Development documents and examples for multithreading
Provides:	python3-multithreading-doc
%description help
```python
import multithreading
class Demo(multithreading.MultiThread):
    def task(self, task):
        print(task)
```

%prep
%autosetup -n multithreading-0.2.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-multithreading -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.0-1
- Package Spec generated