%global _empty_manifest_terminate_build 0
Name:		python-smsframework-clickatell
Version:	0.0.3.post0
Release:	1
Summary:	SMS framework: Clickatell provider
License:	BSD
URL:		https://github.com/kolypto/py-smsframework-clickatell
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c5/65/b220327494228b11715126023782a410078044d6128767083568c252e1d9/smsframework-clickatell-0.0.3.post0.tar.gz
BuildArch:	noarch

Requires:	python3-smsframework
Requires:	python3-flask

%description
[Clickatell](https://www.clickatell.com/) Provider for [smsframework](https://pypi.python.org/pypi/smsframework/).
You need a "Developers' Central" Clickatell account with an HTTP API set up.
From the API, you need: api_id, username, password.

%package -n python3-smsframework-clickatell
Summary:	SMS framework: Clickatell provider
Provides:	python-smsframework-clickatell
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-smsframework-clickatell
[Clickatell](https://www.clickatell.com/) Provider for [smsframework](https://pypi.python.org/pypi/smsframework/).
You need a "Developers' Central" Clickatell account with an HTTP API set up.
From the API, you need: api_id, username, password.

%package help
Summary:	Development documents and examples for smsframework-clickatell
Provides:	python3-smsframework-clickatell-doc
%description help
[Clickatell](https://www.clickatell.com/) Provider for [smsframework](https://pypi.python.org/pypi/smsframework/).
You need a "Developers' Central" Clickatell account with an HTTP API set up.
From the API, you need: api_id, username, password.

%prep
%autosetup -n smsframework-clickatell-0.0.3.post0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-smsframework-clickatell -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.3.post0-1
- Package Spec generated