%global _empty_manifest_terminate_build 0
Name: python-CommcareTranslationChecker
Version: 0.9.7
Release: 1
Summary: Command line tool to check that Bulk Translation files for CommCare apps have consistent tags across translations.
License: MIT
URL: https://github.com/dimagi/CommcareTranslationChecker
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/df/3c/1ee7617ddfde695d836ea395fe74f3087964926c17bfcd78287cff5e31ae/CommcareTranslationChecker-0.9.7.tar.gz
BuildArch: noarch
%description
https://github.com/dimagi/CommcareTranslationChecker
A command-line tool to check multiple columns of a [Bulk Translation File](https://confluence.dimagi.com/display/commcarepublic/Form+Bulk+Translation) against each other, to ensure that output value tags are being used consistently between columns.
%package -n python3-CommcareTranslationChecker
Summary: Command line tool to check that Bulk Translation files for CommCare apps have consistent tags across translations.
Provides: python-CommcareTranslationChecker
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-CommcareTranslationChecker
https://github.com/dimagi/CommcareTranslationChecker
A command-line tool to check multiple columns of a [Bulk Translation File](https://confluence.dimagi.com/display/commcarepublic/Form+Bulk+Translation) against each other, to ensure that output value tags are being used consistently between columns.
%package help
Summary: Development documents and examples for CommcareTranslationChecker
Provides: python3-CommcareTranslationChecker-doc
%description help
https://github.com/dimagi/CommcareTranslationChecker
A command-line tool to check multiple columns of a [Bulk Translation File](https://confluence.dimagi.com/display/commcarepublic/Form+Bulk+Translation) against each other, to ensure that output value tags are being used consistently between columns.
%prep
%autosetup -n CommcareTranslationChecker-0.9.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-CommcareTranslationChecker -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.9.7-1
- Package Spec generated