%global _empty_manifest_terminate_build 0
Name:		python-moneywagon
Version:	1.22.3
Release:	1
Summary:	Next Generation Cryptocurrency Platform
License:	LICENSE
URL:		https://github.com/priestc/moneywagon
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/12/d4/6d134ea1367dc07e4ea700bc5d715e854dfa490a745fba45381fe3f8f080/moneywagon-1.22.3.tar.gz
BuildArch:	noarch


%description
![Imgur](http://i.imgur.com/kLJqwqs.png)

# moneywagon


Moneywagon is a an implementation of a Blockchain Kernel. It is a tool that can be used
to built lightweight cryptocurrency wallets. Blockchain Kernels provide an
alternative to the outdated "SPV" method of building lightweight cryptocurrency
services.


## Features
* Lightweight wallet functionality - Use Moneywagon to build a bitcoin enabled device
Works on all cryptocurrencies, including BTC, LTC, PPC, DOGE, VTC, MYR.
    1. Get current crypto/fiat exchange rate
    2. Get crypto balance for address
    3. Get historical transactions for crypto address
    4. Get unspent outputs
    5. Get historical crypto/fiat price.
    6. Get optimal transaction fee (BTC only)
    7. Generate new crypto private/pubic keys supporting both 'WIF' and 'compressed' encodings.

General Cryptocurrency Features:
* Bip38 support
* Multi-sig support - coming soon
* HD-wallet support - coming soon

##  Prerequisites modules (for BIP38 & installation of module via pip)

```
$ pip install scrypt
$ pip install pycrypto
```

# Installation

```
$ pip install moneywagon
```

# Documentation

* [Supported Services](https://github.com/priestc/moneywagon/wiki/Supported-Services)
* [Exchange Operations](https://github.com/priestc/moneywagon/wiki/Exchange-Operations)
  * [Service Support List](https://github.com/priestc/moneywagon/wiki/Exchange-Service-Support-Table)
* [Blockchain Operations](https://github.com/priestc/moneywagon/wiki/Blockchain-Operations)
* [Command Line Interface](https://github.com/priestc/moneywagon/wiki/Command-Line-Interface)
* [Python Interface](https://github.com/priestc/moneywagon/wiki/Python-Interface)
* [Creating Transactions](https://github.com/priestc/moneywagon/wiki/Creating-Transactions)
* [Service Modes](https://github.com/priestc/moneywagon/wiki/Service-Modes)
* [Tools](https://github.com/priestc/moneywagon/wiki/Tools)


# Contributing


If you would like to add a new service, feel free to make a pull request.
If you discover a service is no longer working feel free to create a github issue and some will fix it shortly.


# Donations


If you would like to send a donation to support development, please send BTC here: 1HWpyFJ7N6rvFkq3ZCMiFnqM6hviNFmG5X

%package -n python3-moneywagon
Summary:	Next Generation Cryptocurrency Platform
Provides:	python-moneywagon
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-moneywagon
![Imgur](http://i.imgur.com/kLJqwqs.png)

# moneywagon


Moneywagon is a an implementation of a Blockchain Kernel. It is a tool that can be used
to built lightweight cryptocurrency wallets. Blockchain Kernels provide an
alternative to the outdated "SPV" method of building lightweight cryptocurrency
services.


## Features
* Lightweight wallet functionality - Use Moneywagon to build a bitcoin enabled device
Works on all cryptocurrencies, including BTC, LTC, PPC, DOGE, VTC, MYR.
    1. Get current crypto/fiat exchange rate
    2. Get crypto balance for address
    3. Get historical transactions for crypto address
    4. Get unspent outputs
    5. Get historical crypto/fiat price.
    6. Get optimal transaction fee (BTC only)
    7. Generate new crypto private/pubic keys supporting both 'WIF' and 'compressed' encodings.

General Cryptocurrency Features:
* Bip38 support
* Multi-sig support - coming soon
* HD-wallet support - coming soon

##  Prerequisites modules (for BIP38 & installation of module via pip)

```
$ pip install scrypt
$ pip install pycrypto
```

# Installation

```
$ pip install moneywagon
```

# Documentation

* [Supported Services](https://github.com/priestc/moneywagon/wiki/Supported-Services)
* [Exchange Operations](https://github.com/priestc/moneywagon/wiki/Exchange-Operations)
  * [Service Support List](https://github.com/priestc/moneywagon/wiki/Exchange-Service-Support-Table)
* [Blockchain Operations](https://github.com/priestc/moneywagon/wiki/Blockchain-Operations)
* [Command Line Interface](https://github.com/priestc/moneywagon/wiki/Command-Line-Interface)
* [Python Interface](https://github.com/priestc/moneywagon/wiki/Python-Interface)
* [Creating Transactions](https://github.com/priestc/moneywagon/wiki/Creating-Transactions)
* [Service Modes](https://github.com/priestc/moneywagon/wiki/Service-Modes)
* [Tools](https://github.com/priestc/moneywagon/wiki/Tools)


# Contributing


If you would like to add a new service, feel free to make a pull request.
If you discover a service is no longer working feel free to create a github issue and some will fix it shortly.


# Donations


If you would like to send a donation to support development, please send BTC here: 1HWpyFJ7N6rvFkq3ZCMiFnqM6hviNFmG5X

%package help
Summary:	Development documents and examples for moneywagon
Provides:	python3-moneywagon-doc
%description help
![Imgur](http://i.imgur.com/kLJqwqs.png)

# moneywagon


Moneywagon is a an implementation of a Blockchain Kernel. It is a tool that can be used
to built lightweight cryptocurrency wallets. Blockchain Kernels provide an
alternative to the outdated "SPV" method of building lightweight cryptocurrency
services.


## Features
* Lightweight wallet functionality - Use Moneywagon to build a bitcoin enabled device
Works on all cryptocurrencies, including BTC, LTC, PPC, DOGE, VTC, MYR.
    1. Get current crypto/fiat exchange rate
    2. Get crypto balance for address
    3. Get historical transactions for crypto address
    4. Get unspent outputs
    5. Get historical crypto/fiat price.
    6. Get optimal transaction fee (BTC only)
    7. Generate new crypto private/pubic keys supporting both 'WIF' and 'compressed' encodings.

General Cryptocurrency Features:
* Bip38 support
* Multi-sig support - coming soon
* HD-wallet support - coming soon

##  Prerequisites modules (for BIP38 & installation of module via pip)

```
$ pip install scrypt
$ pip install pycrypto
```

# Installation

```
$ pip install moneywagon
```

# Documentation

* [Supported Services](https://github.com/priestc/moneywagon/wiki/Supported-Services)
* [Exchange Operations](https://github.com/priestc/moneywagon/wiki/Exchange-Operations)
  * [Service Support List](https://github.com/priestc/moneywagon/wiki/Exchange-Service-Support-Table)
* [Blockchain Operations](https://github.com/priestc/moneywagon/wiki/Blockchain-Operations)
* [Command Line Interface](https://github.com/priestc/moneywagon/wiki/Command-Line-Interface)
* [Python Interface](https://github.com/priestc/moneywagon/wiki/Python-Interface)
* [Creating Transactions](https://github.com/priestc/moneywagon/wiki/Creating-Transactions)
* [Service Modes](https://github.com/priestc/moneywagon/wiki/Service-Modes)
* [Tools](https://github.com/priestc/moneywagon/wiki/Tools)


# Contributing


If you would like to add a new service, feel free to make a pull request.
If you discover a service is no longer working feel free to create a github issue and some will fix it shortly.


# Donations


If you would like to send a donation to support development, please send BTC here: 1HWpyFJ7N6rvFkq3ZCMiFnqM6hviNFmG5X

%prep
%autosetup -n moneywagon-1.22.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-moneywagon -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.22.3-1
- Package Spec generated