%global _empty_manifest_terminate_build 0
Name: python-JT-Gmail
Version: 0.0.24
Release: 1
Summary: My Gmail API Wrapper
License: MIT License
URL: https://github.com/Gothingbop/JT_Gmail
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a6/97/2cdbdfa5ca2990413f6d9e7cd956485aa7769b73bedfe545b4b3d45671a1/JT_Gmail-0.0.24.tar.gz
BuildArch: noarch
Requires: python3-google-api-python-client
Requires: python3-google-auth-httplib2
Requires: python3-google-auth-oauthlib
%description
# JT_Gmail
This is a simple interface for programmatically sending emails using the Gmail API.
```
pip install JT_Gmail
```
To get started you must create a project
and enable the Gmail API, create OAuth2 credentials and download them in a json file.
Before you can use this module for the first time, you must run:
```python
import JT_Gmail as gmail
gmail.GetToken(scopes=['scope1', 'scope2'], email_address='user@gmail.com', cred_path="path_to_your_credentials.json")
```
Supply the scopes you plan on using as *args. A list of all the scopes can be found
here. Each function also includes the required scopes
in its docstring.
This will prompt for authentication and generate the proper token to use the scopes you supplied. The token and
credentials are saved for later use, so you might only have to run that line once. As you perform actions, if they need
new permissions, they will be requested. Authentication will be required for each gmail user you wish to use.
To send emails, it's as easy as:
```python
import JT_Gmail as gmail
with open("email.html") as file:
gmail.SendHTMLEmail(
sender='sender@gmail.com',
to="recipient@some.website",
subject="Example Email",
message_html=file.read()
)
```
This was base heavily on code snippets supplied by
Google.
%package -n python3-JT-Gmail
Summary: My Gmail API Wrapper
Provides: python-JT-Gmail
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-JT-Gmail
# JT_Gmail
This is a simple interface for programmatically sending emails using the Gmail API.
```
pip install JT_Gmail
```
To get started you must create a project
and enable the Gmail API, create OAuth2 credentials and download them in a json file.
Before you can use this module for the first time, you must run:
```python
import JT_Gmail as gmail
gmail.GetToken(scopes=['scope1', 'scope2'], email_address='user@gmail.com', cred_path="path_to_your_credentials.json")
```
Supply the scopes you plan on using as *args. A list of all the scopes can be found
here. Each function also includes the required scopes
in its docstring.
This will prompt for authentication and generate the proper token to use the scopes you supplied. The token and
credentials are saved for later use, so you might only have to run that line once. As you perform actions, if they need
new permissions, they will be requested. Authentication will be required for each gmail user you wish to use.
To send emails, it's as easy as:
```python
import JT_Gmail as gmail
with open("email.html") as file:
gmail.SendHTMLEmail(
sender='sender@gmail.com',
to="recipient@some.website",
subject="Example Email",
message_html=file.read()
)
```
This was base heavily on code snippets supplied by
Google.
%package help
Summary: Development documents and examples for JT-Gmail
Provides: python3-JT-Gmail-doc
%description help
# JT_Gmail
This is a simple interface for programmatically sending emails using the Gmail API.
```
pip install JT_Gmail
```
To get started you must create a project
and enable the Gmail API, create OAuth2 credentials and download them in a json file.
Before you can use this module for the first time, you must run:
```python
import JT_Gmail as gmail
gmail.GetToken(scopes=['scope1', 'scope2'], email_address='user@gmail.com', cred_path="path_to_your_credentials.json")
```
Supply the scopes you plan on using as *args. A list of all the scopes can be found
here. Each function also includes the required scopes
in its docstring.
This will prompt for authentication and generate the proper token to use the scopes you supplied. The token and
credentials are saved for later use, so you might only have to run that line once. As you perform actions, if they need
new permissions, they will be requested. Authentication will be required for each gmail user you wish to use.
To send emails, it's as easy as:
```python
import JT_Gmail as gmail
with open("email.html") as file:
gmail.SendHTMLEmail(
sender='sender@gmail.com',
to="recipient@some.website",
subject="Example Email",
message_html=file.read()
)
```
This was base heavily on code snippets supplied by
Google.
%prep
%autosetup -n JT-Gmail-0.0.24
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-JT-Gmail -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.0.24-1
- Package Spec generated