%global _empty_manifest_terminate_build 0
Name: python-unmanic
Version: 0.2.4
Release: 1
Summary: A simple tool for optimising your video library to a single format
License: GPLv3
URL: https://github.com/Josh5/unmanic
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e9/dc/6758eb8986fb33f0ae1a9f54fbfa5c728b3c6a6bab8287d499d4f9598284/unmanic-0.2.4.tar.gz
BuildArch: noarch
Requires: python3-schedule
Requires: python3-tornado
Requires: python3-marshmallow
Requires: python3-peewee
Requires: python3-peewee-migrate
Requires: python3-psutil
Requires: python3-requests
Requires: python3-requests-toolbelt
Requires: python3-py-cpuinfo
Requires: python3-watchdog
Requires: python3-inquirer
Requires: python3-swagger-ui-py
Requires: python3-flake8
Requires: python3-pycodestyle
Requires: python3-pytest
Requires: python3-wheel
Requires: python3-setuptools
Requires: python3-apispec
Requires: python3-apispec-webframeworks
Requires: python3-pyyaml
%description

[](https://github.com/unmanic/unmanic/releases)
[](https://github.com/unmanic/unmanic/issues?q=is%3Aopen+is%3Aissue)
[](https://github.com/unmanic/unmanic/issues?q=is%3Aissue+is%3Aclosed)
[](https://github.com/unmanic/unmanic/pulls?q=is%3Aopen+is%3Apr)
[](https://github.com/unmanic/unmanic/pulls?q=is%3Apr+is%3Aclosed)
[](https://hub.docker.com/r/josh5/unmanic)
[](https://hub.docker.com/r/josh5/unmanic)
[](https://hub.docker.com/r/josh5/unmanic)
[](https://github.com/unmanic/unmanic/actions?query=workflow%3A%22Python+Lint+%26+Run+Unit+Tests%22+branch%3Amaster)
[](https://github.com/unmanic/unmanic/actions?query=workflow%3A%22Build+All+Packages+CI%22+branch%3Amaster)
%package -n python3-unmanic
Summary: A simple tool for optimising your video library to a single format
Provides: python-unmanic
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-unmanic

[](https://github.com/unmanic/unmanic/releases)
[](https://github.com/unmanic/unmanic/issues?q=is%3Aopen+is%3Aissue)
[](https://github.com/unmanic/unmanic/issues?q=is%3Aissue+is%3Aclosed)
[](https://github.com/unmanic/unmanic/pulls?q=is%3Aopen+is%3Apr)
[](https://github.com/unmanic/unmanic/pulls?q=is%3Apr+is%3Aclosed)
[](https://hub.docker.com/r/josh5/unmanic)
[](https://hub.docker.com/r/josh5/unmanic)
[](https://hub.docker.com/r/josh5/unmanic)
[](https://github.com/unmanic/unmanic/actions?query=workflow%3A%22Python+Lint+%26+Run+Unit+Tests%22+branch%3Amaster)
[](https://github.com/unmanic/unmanic/actions?query=workflow%3A%22Build+All+Packages+CI%22+branch%3Amaster)
%package help
Summary: Development documents and examples for unmanic
Provides: python3-unmanic-doc
%description help

[](https://github.com/unmanic/unmanic/releases)
[](https://github.com/unmanic/unmanic/issues?q=is%3Aopen+is%3Aissue)
[](https://github.com/unmanic/unmanic/issues?q=is%3Aissue+is%3Aclosed)
[](https://github.com/unmanic/unmanic/pulls?q=is%3Aopen+is%3Apr)
[](https://github.com/unmanic/unmanic/pulls?q=is%3Apr+is%3Aclosed)
[](https://hub.docker.com/r/josh5/unmanic)
[](https://hub.docker.com/r/josh5/unmanic)
[](https://hub.docker.com/r/josh5/unmanic)
[](https://github.com/unmanic/unmanic/actions?query=workflow%3A%22Python+Lint+%26+Run+Unit+Tests%22+branch%3Amaster)
[](https://github.com/unmanic/unmanic/actions?query=workflow%3A%22Build+All+Packages+CI%22+branch%3Amaster)
%prep
%autosetup -n unmanic-0.2.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-unmanic -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.2.4-1
- Package Spec generated