%global _empty_manifest_terminate_build 0
Name: python-replacy
Version: 3.7.2
Release: 1
Summary: ReplaCy = spaCy Matcher + pyInflect. Create rules, correct sentences.
License: MIT
URL: https://pypi.org/project/replacy/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b2/3a/652fc5853e6e14d6dc7433ec9643bc327d82c9e277b1297380544a68f72a/replacy-3.7.2.tar.gz
BuildArch: noarch
Requires: python3-jsonschema
Requires: python3-lemminflect
Requires: python3-pyfunctional
%description
# replaCy: match & replace with spaCy
We found that in multiple projects we had duplicate code for using spaCy’s blazing fast matcher to do the same thing: Match-Replace-Grammaticalize. So we wrote replaCy!
- Match - spaCy’s matcher is great, and lets you match on text, shape, POS, dependency parse, and other features. We extended this with “match hooks”, predicates that get used in the callback function to further refine a match.
- Replace - Not built into spaCy’s matcher syntax, but easily added. You often want to replace a matched word with some other term.
- Grammaticalize - If you match on ”LEMMA”: “dance”, and replace with suggestions: ["sing"], but the actual match is danced, you need to conjugate “sing” appropriately. This is the “killer feature” of replaCy
[](https://spacy.io)
[](https://pypi.org/project/replacy/)
[](https://github.com/ambv/black)
## Requirements
- `spacy >= 2.0` (not installed by default, but replaCy needs to be instantiated with an `nlp` object)
## Installation
`pip install replacy`
## Quick start
```python
from replacy import ReplaceMatcher
from replacy.db import load_json
import spacy
match_dict = load_json('/path/to/your/match/dict.json')
# load nlp spacy model of your choice
nlp = spacy.load("en_core_web_sm")
rmatcher = ReplaceMatcher(nlp, match_dict=match_dict)
# get inflected suggestions
# look up the first suggestion
span = rmatcher("She extracts revenge.")[0]
span._.suggestions
# >>> ['exacts']
```
## Input
ReplaceMatcher accepts both text and spaCy doc.
```python
# text is ok
span = r_matcher("She extracts revenge.")[0]
# doc is ok too
doc = nlp("She extracts revenge.")
span = r_matcher(doc)[0]
```
## match_dict.json format
Here is a minimal `match_dict.json`:
```json
{
"extract-revenge": {
"patterns": [
{
"LEMMA": "extract",
"TEMPLATE_ID": 1
}
],
"suggestions": [
[
{
"TEXT": "exact",
"FROM_TEMPLATE_ID": 1
}
]
],
"match_hook": [
{
"name": "succeeded_by_phrase",
"args": "revenge",
"match_if_predicate_is": true
}
],
"test": {
"positive": [
"And at the same time extract revenge on those he so despises?",
"Watch as Tampa Bay extracts revenge against his former Los Angeles Rams team."
],
"negative": ["Mother flavours her custards with lemon extract."]
}
}
}
```
For more information how to compose `match_dict` see our [wiki](https://github.com/Qordobacode/replaCy/wiki/match_dict.json-format):
# Citing
If you use replaCy in your research, please cite with the following BibText
```bibtext
@misc{havens2019replacy,
title = {SpaCy match and replace, maintaining conjugation},
author = {Sam Havens, Aneta Stal, and Manhal Daaboul},
url = {https://github.com/Qordobacode/replaCy},
year = {2019}
}
%package -n python3-replacy
Summary: ReplaCy = spaCy Matcher + pyInflect. Create rules, correct sentences.
Provides: python-replacy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-replacy
# replaCy: match & replace with spaCy
We found that in multiple projects we had duplicate code for using spaCy’s blazing fast matcher to do the same thing: Match-Replace-Grammaticalize. So we wrote replaCy!
- Match - spaCy’s matcher is great, and lets you match on text, shape, POS, dependency parse, and other features. We extended this with “match hooks”, predicates that get used in the callback function to further refine a match.
- Replace - Not built into spaCy’s matcher syntax, but easily added. You often want to replace a matched word with some other term.
- Grammaticalize - If you match on ”LEMMA”: “dance”, and replace with suggestions: ["sing"], but the actual match is danced, you need to conjugate “sing” appropriately. This is the “killer feature” of replaCy
[](https://spacy.io)
[](https://pypi.org/project/replacy/)
[](https://github.com/ambv/black)
## Requirements
- `spacy >= 2.0` (not installed by default, but replaCy needs to be instantiated with an `nlp` object)
## Installation
`pip install replacy`
## Quick start
```python
from replacy import ReplaceMatcher
from replacy.db import load_json
import spacy
match_dict = load_json('/path/to/your/match/dict.json')
# load nlp spacy model of your choice
nlp = spacy.load("en_core_web_sm")
rmatcher = ReplaceMatcher(nlp, match_dict=match_dict)
# get inflected suggestions
# look up the first suggestion
span = rmatcher("She extracts revenge.")[0]
span._.suggestions
# >>> ['exacts']
```
## Input
ReplaceMatcher accepts both text and spaCy doc.
```python
# text is ok
span = r_matcher("She extracts revenge.")[0]
# doc is ok too
doc = nlp("She extracts revenge.")
span = r_matcher(doc)[0]
```
## match_dict.json format
Here is a minimal `match_dict.json`:
```json
{
"extract-revenge": {
"patterns": [
{
"LEMMA": "extract",
"TEMPLATE_ID": 1
}
],
"suggestions": [
[
{
"TEXT": "exact",
"FROM_TEMPLATE_ID": 1
}
]
],
"match_hook": [
{
"name": "succeeded_by_phrase",
"args": "revenge",
"match_if_predicate_is": true
}
],
"test": {
"positive": [
"And at the same time extract revenge on those he so despises?",
"Watch as Tampa Bay extracts revenge against his former Los Angeles Rams team."
],
"negative": ["Mother flavours her custards with lemon extract."]
}
}
}
```
For more information how to compose `match_dict` see our [wiki](https://github.com/Qordobacode/replaCy/wiki/match_dict.json-format):
# Citing
If you use replaCy in your research, please cite with the following BibText
```bibtext
@misc{havens2019replacy,
title = {SpaCy match and replace, maintaining conjugation},
author = {Sam Havens, Aneta Stal, and Manhal Daaboul},
url = {https://github.com/Qordobacode/replaCy},
year = {2019}
}
%package help
Summary: Development documents and examples for replacy
Provides: python3-replacy-doc
%description help
# replaCy: match & replace with spaCy
We found that in multiple projects we had duplicate code for using spaCy’s blazing fast matcher to do the same thing: Match-Replace-Grammaticalize. So we wrote replaCy!
- Match - spaCy’s matcher is great, and lets you match on text, shape, POS, dependency parse, and other features. We extended this with “match hooks”, predicates that get used in the callback function to further refine a match.
- Replace - Not built into spaCy’s matcher syntax, but easily added. You often want to replace a matched word with some other term.
- Grammaticalize - If you match on ”LEMMA”: “dance”, and replace with suggestions: ["sing"], but the actual match is danced, you need to conjugate “sing” appropriately. This is the “killer feature” of replaCy
[](https://spacy.io)
[](https://pypi.org/project/replacy/)
[](https://github.com/ambv/black)
## Requirements
- `spacy >= 2.0` (not installed by default, but replaCy needs to be instantiated with an `nlp` object)
## Installation
`pip install replacy`
## Quick start
```python
from replacy import ReplaceMatcher
from replacy.db import load_json
import spacy
match_dict = load_json('/path/to/your/match/dict.json')
# load nlp spacy model of your choice
nlp = spacy.load("en_core_web_sm")
rmatcher = ReplaceMatcher(nlp, match_dict=match_dict)
# get inflected suggestions
# look up the first suggestion
span = rmatcher("She extracts revenge.")[0]
span._.suggestions
# >>> ['exacts']
```
## Input
ReplaceMatcher accepts both text and spaCy doc.
```python
# text is ok
span = r_matcher("She extracts revenge.")[0]
# doc is ok too
doc = nlp("She extracts revenge.")
span = r_matcher(doc)[0]
```
## match_dict.json format
Here is a minimal `match_dict.json`:
```json
{
"extract-revenge": {
"patterns": [
{
"LEMMA": "extract",
"TEMPLATE_ID": 1
}
],
"suggestions": [
[
{
"TEXT": "exact",
"FROM_TEMPLATE_ID": 1
}
]
],
"match_hook": [
{
"name": "succeeded_by_phrase",
"args": "revenge",
"match_if_predicate_is": true
}
],
"test": {
"positive": [
"And at the same time extract revenge on those he so despises?",
"Watch as Tampa Bay extracts revenge against his former Los Angeles Rams team."
],
"negative": ["Mother flavours her custards with lemon extract."]
}
}
}
```
For more information how to compose `match_dict` see our [wiki](https://github.com/Qordobacode/replaCy/wiki/match_dict.json-format):
# Citing
If you use replaCy in your research, please cite with the following BibText
```bibtext
@misc{havens2019replacy,
title = {SpaCy match and replace, maintaining conjugation},
author = {Sam Havens, Aneta Stal, and Manhal Daaboul},
url = {https://github.com/Qordobacode/replaCy},
year = {2019}
}
%prep
%autosetup -n replacy-3.7.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-replacy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 3.7.2-1
- Package Spec generated