%global _empty_manifest_terminate_build 0
Name:		python-ome-zarr
Version:	0.7.1
Release:	1
Summary:	Implementation of images in Zarr files.
License:	BSD License
URL:		https://github.com/ome/ome-zarr-py
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/50/22/2cbd5cb5d00f484e19c2239625169c2e9772b90dfe0b1eb394cbda750492/ome-zarr-0.7.1.tar.gz
BuildArch:	noarch

Requires:	python3-aiohttp
Requires:	python3-dask
Requires:	python3-distributed
Requires:	python3-fsspec[s3]
Requires:	python3-numpy
Requires:	python3-requests
Requires:	python3-scikit-image
Requires:	python3-toolz
Requires:	python3-zarr
Requires:	python3-dataclasses
Requires:	python3-tifffile

%description


%package -n python3-ome-zarr
Summary:	Implementation of images in Zarr files.
Provides:	python-ome-zarr
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ome-zarr


%package help
Summary:	Development documents and examples for ome-zarr
Provides:	python3-ome-zarr-doc
%description help


%prep
%autosetup -n ome-zarr-0.7.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ome-zarr -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.1-1
- Package Spec generated