%global _empty_manifest_terminate_build 0
Name:		python-pyramid_rpc
Version:	0.8
Release:	1
Summary:	RPC support for the Pyramid web framework
License:	BSD-derived (http://www.repoze.org/LICENSE.txt)
URL:		http://docs.pylonsproject.org/projects/pyramid_rpc/en/latest/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/2d/6a/cd63ce9e4ee09b59061f889a6b4fe5981fe1e64e536127d3ad3abe9cc829/pyramid_rpc-0.8.tar.gz
BuildArch:	noarch

Requires:	python3-pyramid
Requires:	python3-venusian
Requires:	python3-pyamf
Requires:	python3-Sphinx
Requires:	python3-pylons-sphinx-themes
Requires:	python3-WebTest
Requires:	python3-coverage
Requires:	python3-nose
Requires:	python3-pyramid
Requires:	python3-venusian

%description
``pyramid_rpc`` is a package of RPC related add-on's to make it easier to
create RPC services.
    from pyramid.config import Configurator
    from pyramid_rpc.jsonrpc import jsonrpc_method
    @jsonrpc_method(endpoint='api')
    def say_hello(request, name):
        return 'hello, %s!' % name
    def main(global_conf, **settings):
        config = Configurator(settings=settings)
        config.include('pyramid_rpc.jsonrpc')
        config.add_jsonrpc_endpoint('api', '/api')
        config.scan(__name__)
        return config.make_wsgi_app()
    if __name__ == '__main__':
        from wsgiref.simple_server import make_server
        app = main({})
        server = make_server('', 8080, app)
        server.serve_forever()

%package -n python3-pyramid_rpc
Summary:	RPC support for the Pyramid web framework
Provides:	python-pyramid_rpc
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pyramid_rpc
``pyramid_rpc`` is a package of RPC related add-on's to make it easier to
create RPC services.
    from pyramid.config import Configurator
    from pyramid_rpc.jsonrpc import jsonrpc_method
    @jsonrpc_method(endpoint='api')
    def say_hello(request, name):
        return 'hello, %s!' % name
    def main(global_conf, **settings):
        config = Configurator(settings=settings)
        config.include('pyramid_rpc.jsonrpc')
        config.add_jsonrpc_endpoint('api', '/api')
        config.scan(__name__)
        return config.make_wsgi_app()
    if __name__ == '__main__':
        from wsgiref.simple_server import make_server
        app = main({})
        server = make_server('', 8080, app)
        server.serve_forever()

%package help
Summary:	Development documents and examples for pyramid_rpc
Provides:	python3-pyramid_rpc-doc
%description help
``pyramid_rpc`` is a package of RPC related add-on's to make it easier to
create RPC services.
    from pyramid.config import Configurator
    from pyramid_rpc.jsonrpc import jsonrpc_method
    @jsonrpc_method(endpoint='api')
    def say_hello(request, name):
        return 'hello, %s!' % name
    def main(global_conf, **settings):
        config = Configurator(settings=settings)
        config.include('pyramid_rpc.jsonrpc')
        config.add_jsonrpc_endpoint('api', '/api')
        config.scan(__name__)
        return config.make_wsgi_app()
    if __name__ == '__main__':
        from wsgiref.simple_server import make_server
        app = main({})
        server = make_server('', 8080, app)
        server.serve_forever()

%prep
%autosetup -n pyramid_rpc-0.8

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pyramid_rpc -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8-1
- Package Spec generated