%global _empty_manifest_terminate_build 0
Name:		python-tokenizer-tools
Version:	0.46.1
Release:	1
Summary:	Tools for tokenizer develope and evaluation
License:	MIT license
URL:		https://github.com/howlandersonn/tokenizer_tools
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a1/ec/56971a0b4adb6286713ab6dc85792d87dafd544e58367e678f6baaf49f2f/tokenizer_tools-0.46.1.tar.gz
BuildArch:	noarch

Requires:	python3-Click
Requires:	python3-scikit-learn
Requires:	python3-scipy
Requires:	python3-pandas
Requires:	python3-fuzzywuzzy
Requires:	python3-plotly
Requires:	python3-mistletoe
Requires:	python3-tqdm
Requires:	python3-flask
Requires:	python3-elasticsearch-dsl
Requires:	python3-pyahocorasick

%description
本软件提供了一种语料存储的磁盘文件格式(暂定名为 conllx)和内存对象格式(暂定名为 offset)。

%package -n python3-tokenizer-tools
Summary:	Tools for tokenizer develope and evaluation
Provides:	python-tokenizer-tools
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-tokenizer-tools
本软件提供了一种语料存储的磁盘文件格式(暂定名为 conllx)和内存对象格式(暂定名为 offset)。

%package help
Summary:	Development documents and examples for tokenizer-tools
Provides:	python3-tokenizer-tools-doc
%description help
本软件提供了一种语料存储的磁盘文件格式(暂定名为 conllx)和内存对象格式(暂定名为 offset)。

%prep
%autosetup -n tokenizer-tools-0.46.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-tokenizer-tools -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.46.1-1
- Package Spec generated