%global _empty_manifest_terminate_build 0
Name:		python-SQLAlchemy-bulk-lazy-loader
Version:	0.10.0
Release:	1
Summary:	A Bulk Lazy Loader for Sqlalchemy that solves the n + 1 loading problem
License:	MIT
URL:		https://github.com/operator/sqlalchemy_bulk_lazy_loader
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/31/ec/3fca804b19c52c52fd1cf13012087f15e080d795ea41176cc10844e1e952/SQLAlchemy-bulk-lazy-loader-0.10.0.tar.gz
BuildArch:	noarch


%description
A custom lazy loader for SQLAlchemy relations which ensures relations are always loaded efficiently. This loader automatically solves the `n+1 query problem <http://use-the-index-luke.com/sql/join/nested-loops-join-n1-problem>`_ without needing to manually add ``joinedload`` or ``subqueryload`` statements to all your queries.

%package -n python3-SQLAlchemy-bulk-lazy-loader
Summary:	A Bulk Lazy Loader for Sqlalchemy that solves the n + 1 loading problem
Provides:	python-SQLAlchemy-bulk-lazy-loader
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-SQLAlchemy-bulk-lazy-loader
A custom lazy loader for SQLAlchemy relations which ensures relations are always loaded efficiently. This loader automatically solves the `n+1 query problem <http://use-the-index-luke.com/sql/join/nested-loops-join-n1-problem>`_ without needing to manually add ``joinedload`` or ``subqueryload`` statements to all your queries.

%package help
Summary:	Development documents and examples for SQLAlchemy-bulk-lazy-loader
Provides:	python3-SQLAlchemy-bulk-lazy-loader-doc
%description help
A custom lazy loader for SQLAlchemy relations which ensures relations are always loaded efficiently. This loader automatically solves the `n+1 query problem <http://use-the-index-luke.com/sql/join/nested-loops-join-n1-problem>`_ without needing to manually add ``joinedload`` or ``subqueryload`` statements to all your queries.

%prep
%autosetup -n SQLAlchemy-bulk-lazy-loader-0.10.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-SQLAlchemy-bulk-lazy-loader -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.10.0-1
- Package Spec generated