%global _empty_manifest_terminate_build 0
Name:		python-aimaster
Version:	2.4.8
Release:	1
Summary:	Artificial Neural Network learning tools
License:	MIT
URL:		https://github.com/kasinathps/aimaster
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/27/5d/a04e45f4bb45aaf91e3d1c0d6bbd3e3add821d869c7e7ac44b26d1eb2fe7/aimaster-2.4.8.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-matplotlib

%description
Artificial Neural Network learning and experimentation tools with live visualization.  
(NOTE: Donot use pipe visualization with very large networks 😅.)  
This module needs `numpy` and `scipy` installed.
And `matplotlib` for visualization.
Feel free to experiment with aimaster.  
## Installation
Use `pip install aimaster` or `pip3 install aimaster` to install package from PyPI.  

%package -n python3-aimaster
Summary:	Artificial Neural Network learning tools
Provides:	python-aimaster
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-aimaster
Artificial Neural Network learning and experimentation tools with live visualization.  
(NOTE: Donot use pipe visualization with very large networks 😅.)  
This module needs `numpy` and `scipy` installed.
And `matplotlib` for visualization.
Feel free to experiment with aimaster.  
## Installation
Use `pip install aimaster` or `pip3 install aimaster` to install package from PyPI.  

%package help
Summary:	Development documents and examples for aimaster
Provides:	python3-aimaster-doc
%description help
Artificial Neural Network learning and experimentation tools with live visualization.  
(NOTE: Donot use pipe visualization with very large networks 😅.)  
This module needs `numpy` and `scipy` installed.
And `matplotlib` for visualization.
Feel free to experiment with aimaster.  
## Installation
Use `pip install aimaster` or `pip3 install aimaster` to install package from PyPI.  

%prep
%autosetup -n aimaster-2.4.8

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-aimaster -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 2.4.8-1
- Package Spec generated