%global _empty_manifest_terminate_build 0
Name:		python-TechfinDataPipeline
Version:	0.0.26
Release:	1
Summary:	please add a summary manually as the author left a blank one
License:	MIT
URL:		https://totvstfs.visualstudio.com/Techfin/_git/techfin-ds-golden-data-pipeline
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/00/1a/cd5ce5993f648aeff81eaf3bbe76773a63bb7e7e4ab154614cae7ace1dc9/TechfinDataPipeline-0.0.26.tar.gz
BuildArch:	noarch

Requires:	python3-pycarol[dataframe]

%description
# Techfin Golden Records Parser Pipeline
# Introduction 
This project is dedicated to TOTVS developers that works with Anticipation or Financial Cockpit projects.  
With this package you will be able to:
- Download the data from Carol platform
- Merge the data
- Clean the unneeded informations
- Get the last status from each installment considering all the history of payments events
- Parsing the NFe XML

# Getting Started
As first step you need to configure a .env file with Carol's authentication information.  
After this you can simply call: default_techfin_data_parser(connector_name) this function will return two pandas dataframes with receivables and payments already treated.



%package -n python3-TechfinDataPipeline
Summary:	please add a summary manually as the author left a blank one
Provides:	python-TechfinDataPipeline
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-TechfinDataPipeline
# Techfin Golden Records Parser Pipeline
# Introduction 
This project is dedicated to TOTVS developers that works with Anticipation or Financial Cockpit projects.  
With this package you will be able to:
- Download the data from Carol platform
- Merge the data
- Clean the unneeded informations
- Get the last status from each installment considering all the history of payments events
- Parsing the NFe XML

# Getting Started
As first step you need to configure a .env file with Carol's authentication information.  
After this you can simply call: default_techfin_data_parser(connector_name) this function will return two pandas dataframes with receivables and payments already treated.



%package help
Summary:	Development documents and examples for TechfinDataPipeline
Provides:	python3-TechfinDataPipeline-doc
%description help
# Techfin Golden Records Parser Pipeline
# Introduction 
This project is dedicated to TOTVS developers that works with Anticipation or Financial Cockpit projects.  
With this package you will be able to:
- Download the data from Carol platform
- Merge the data
- Clean the unneeded informations
- Get the last status from each installment considering all the history of payments events
- Parsing the NFe XML

# Getting Started
As first step you need to configure a .env file with Carol's authentication information.  
After this you can simply call: default_techfin_data_parser(connector_name) this function will return two pandas dataframes with receivables and payments already treated.



%prep
%autosetup -n TechfinDataPipeline-0.0.26

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-TechfinDataPipeline -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.26-1
- Package Spec generated