%global _empty_manifest_terminate_build 0
Name: python-django-easy-maps
Version: 1.1.3
Release: 1
Summary: This app makes it easy to display a map for a given address
License: MIT License
URL: https://github.com/bashu/django-easy-maps
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ad/fd/cf55555141e72eb4edc71d572ea13fa88bb72c57d83f772b7721c9f2ebc5/django-easy-maps-1.1.3.tar.gz
BuildArch: noarch
Requires: python3-django-classy-tags
Requires: python3-django-appconf
Requires: python3-geopy
Requires: python3-tox
Requires: python3-mock
Requires: python3-django
Requires: python3-pytest-django
Requires: python3-pytest
Requires: python3-pytest-django
Requires: python3-pytest-cov
Requires: python3-pytest
Requires: python3-mock
%description
This app makes it easy to display a map for any given address in
django_ templates. No manual geocoding, html/js copy-pasting or Django
model changes are needed.
Authored by `Mikhail Korobov `_, and some great
`contributors `_.
%package -n python3-django-easy-maps
Summary: This app makes it easy to display a map for a given address
Provides: python-django-easy-maps
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-easy-maps
This app makes it easy to display a map for any given address in
django_ templates. No manual geocoding, html/js copy-pasting or Django
model changes are needed.
Authored by `Mikhail Korobov `_, and some great
`contributors `_.
%package help
Summary: Development documents and examples for django-easy-maps
Provides: python3-django-easy-maps-doc
%description help
This app makes it easy to display a map for any given address in
django_ templates. No manual geocoding, html/js copy-pasting or Django
model changes are needed.
Authored by `Mikhail Korobov `_, and some great
`contributors `_.
%prep
%autosetup -n django-easy-maps-1.1.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-easy-maps -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.1.3-1
- Package Spec generated