%global _empty_manifest_terminate_build 0
Name: python-carculator-truck
Version: 0.3.9
Release: 1
Summary: Prospective environmental and economic life cycle assessmentof medium and heavy goods vehicles
License: BSD 3-Clause License Copyright (c) 2020, Paul Scherrer Institut Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: * Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. * Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. * Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
URL: https://github.com/romainsacchi/carculator_truck
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/16/12/cbe0ddf9a1212dab86f2484803a7c66a24de5cd0d875bfbf3f6713bfaf1d/carculator_truck-0.3.9.tar.gz
BuildArch: noarch
Requires: python3-carculator-utils
Requires: python3-prettytable
%description
# ``carculator_truck``
Prospective environmental and economic life cycle assessment of medium and heavy duty vehicles.
A fully parameterized Python model developed by the [Technology Assessment group](https://www.psi.ch/en/ta) of the
[Paul Scherrer Institut](https://www.psi.ch/en) to perform life cycle assessments (LCA) of medium and heavy duty trucks.
Based on the Life Cycle Assessment tool for passenger vehicles [carculator](https://github.com/romainsacchi/carculator).
See [the documentation](https://carculator_truck.readthedocs.io/en/latest/index.html) for more detail, validation, etc.
The model has been introduced and detailed in a publication to the journal Environmental Science and Technology.
[1] Sacchi R, Bauer C, Cox BL. Does Size Matter? The Influence of Size, Load Factor, Range Autonomy, and Application Type on the Life Cycle Assessment of Current and Future Medium and Heavy-Duty Vehicles.
Environ Sci Technol 2021. [https://doi.org/10.1021/acs.est.0c07773](https://doi.org/10.1021/acs.est.0c07773).
## How to install?
For the latest version, using conda::
conda install -c romainsacchi carculator_truck
or for a stable release, from Pypi::
pip install carculator_truck
## What does it do?
carculator_truck allows to model vehicles across:
- different conventional and alternative powertrains: diesel, compressed natural gas, hybrid-diesel, plugin hybrid, electric, fuel cell
- different gross weight cateogries: 3.5t, 7.5t, 18t, 26t, 32t, 40t and 60t
- different fuel pathways: conventional fuels, bio-based fuels (biodiesel, biomethane), synthetic fuels
(Fischer-Tropsch-based synthetic diesel, synhtetic methane)
- different years: from 2000 to 2050. Technological progress at the vehicle level but also in the rest of the world energy
system (e.g., power generation) is accounted for, using energy scenario-specific IAM-coupled ecoinvent databases produced by
premise.
- Inventories can be imported into Brightway2 and
SimaPro 9.x..
The energy model of carculator_truck considers the vehicle aerodynamics, the road gradient and other factors.
It also considers varying efficiencies of the transmission and engine at various load points for each second
of the driving cycle.
The energy model and the calculated tank-to-wheel energy consumption is validated against the simulation software
VECTO.
Benefits of hybrid powertrains are fully conidered: the possibility to recuperate braking energy as well as efficiency gains from engine
downsizing is accounted for.
Global warming potential impacts per ton-km for a 40-t truck, across different powertrain technologies,
using an urban driving cycle.
## How to use it?
See the notebook with [examples](https://github.com/romainsacchi/carculator_truck/blob/master/examples/Examples.ipynb).
## Support
Do not hesitate to contact the development team at [carculator@psi.ch](mailto:carculator@psi.ch).
## Maintainers
* [Romain Sacchi](https://github.com/romainsacchi)
* [Chris Mutel](https://github.com/cmutel/)
## Contributing
See [contributing](https://github.com/romainsacchi/carculator_truck/blob/master/CONTRIBUTING.md).
## License
[BSD-3-Clause](https://github.com/romainsacchi/carculator_truck/blob/master/LICENSE). Copyright 2020 Paul Scherrer Institut.
%package -n python3-carculator-truck
Summary: Prospective environmental and economic life cycle assessmentof medium and heavy goods vehicles
Provides: python-carculator-truck
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-carculator-truck
# ``carculator_truck``
Prospective environmental and economic life cycle assessment of medium and heavy duty vehicles.
A fully parameterized Python model developed by the [Technology Assessment group](https://www.psi.ch/en/ta) of the
[Paul Scherrer Institut](https://www.psi.ch/en) to perform life cycle assessments (LCA) of medium and heavy duty trucks.
Based on the Life Cycle Assessment tool for passenger vehicles [carculator](https://github.com/romainsacchi/carculator).
See [the documentation](https://carculator_truck.readthedocs.io/en/latest/index.html) for more detail, validation, etc.
The model has been introduced and detailed in a publication to the journal Environmental Science and Technology.
[1] Sacchi R, Bauer C, Cox BL. Does Size Matter? The Influence of Size, Load Factor, Range Autonomy, and Application Type on the Life Cycle Assessment of Current and Future Medium and Heavy-Duty Vehicles.
Environ Sci Technol 2021. [https://doi.org/10.1021/acs.est.0c07773](https://doi.org/10.1021/acs.est.0c07773).
## How to install?
For the latest version, using conda::
conda install -c romainsacchi carculator_truck
or for a stable release, from Pypi::
pip install carculator_truck
## What does it do?
carculator_truck allows to model vehicles across:
- different conventional and alternative powertrains: diesel, compressed natural gas, hybrid-diesel, plugin hybrid, electric, fuel cell
- different gross weight cateogries: 3.5t, 7.5t, 18t, 26t, 32t, 40t and 60t
- different fuel pathways: conventional fuels, bio-based fuels (biodiesel, biomethane), synthetic fuels
(Fischer-Tropsch-based synthetic diesel, synhtetic methane)
- different years: from 2000 to 2050. Technological progress at the vehicle level but also in the rest of the world energy
system (e.g., power generation) is accounted for, using energy scenario-specific IAM-coupled ecoinvent databases produced by
premise.
- Inventories can be imported into Brightway2 and
SimaPro 9.x..
The energy model of carculator_truck considers the vehicle aerodynamics, the road gradient and other factors.
It also considers varying efficiencies of the transmission and engine at various load points for each second
of the driving cycle.
The energy model and the calculated tank-to-wheel energy consumption is validated against the simulation software
VECTO.
Benefits of hybrid powertrains are fully conidered: the possibility to recuperate braking energy as well as efficiency gains from engine
downsizing is accounted for.
Global warming potential impacts per ton-km for a 40-t truck, across different powertrain technologies,
using an urban driving cycle.
## How to use it?
See the notebook with [examples](https://github.com/romainsacchi/carculator_truck/blob/master/examples/Examples.ipynb).
## Support
Do not hesitate to contact the development team at [carculator@psi.ch](mailto:carculator@psi.ch).
## Maintainers
* [Romain Sacchi](https://github.com/romainsacchi)
* [Chris Mutel](https://github.com/cmutel/)
## Contributing
See [contributing](https://github.com/romainsacchi/carculator_truck/blob/master/CONTRIBUTING.md).
## License
[BSD-3-Clause](https://github.com/romainsacchi/carculator_truck/blob/master/LICENSE). Copyright 2020 Paul Scherrer Institut.
%package help
Summary: Development documents and examples for carculator-truck
Provides: python3-carculator-truck-doc
%description help
# ``carculator_truck``
Prospective environmental and economic life cycle assessment of medium and heavy duty vehicles.
A fully parameterized Python model developed by the [Technology Assessment group](https://www.psi.ch/en/ta) of the
[Paul Scherrer Institut](https://www.psi.ch/en) to perform life cycle assessments (LCA) of medium and heavy duty trucks.
Based on the Life Cycle Assessment tool for passenger vehicles [carculator](https://github.com/romainsacchi/carculator).
See [the documentation](https://carculator_truck.readthedocs.io/en/latest/index.html) for more detail, validation, etc.
The model has been introduced and detailed in a publication to the journal Environmental Science and Technology.
[1] Sacchi R, Bauer C, Cox BL. Does Size Matter? The Influence of Size, Load Factor, Range Autonomy, and Application Type on the Life Cycle Assessment of Current and Future Medium and Heavy-Duty Vehicles.
Environ Sci Technol 2021. [https://doi.org/10.1021/acs.est.0c07773](https://doi.org/10.1021/acs.est.0c07773).
## How to install?
For the latest version, using conda::
conda install -c romainsacchi carculator_truck
or for a stable release, from Pypi::
pip install carculator_truck
## What does it do?
carculator_truck allows to model vehicles across:
- different conventional and alternative powertrains: diesel, compressed natural gas, hybrid-diesel, plugin hybrid, electric, fuel cell
- different gross weight cateogries: 3.5t, 7.5t, 18t, 26t, 32t, 40t and 60t
- different fuel pathways: conventional fuels, bio-based fuels (biodiesel, biomethane), synthetic fuels
(Fischer-Tropsch-based synthetic diesel, synhtetic methane)
- different years: from 2000 to 2050. Technological progress at the vehicle level but also in the rest of the world energy
system (e.g., power generation) is accounted for, using energy scenario-specific IAM-coupled ecoinvent databases produced by
premise.
- Inventories can be imported into Brightway2 and
SimaPro 9.x..
The energy model of carculator_truck considers the vehicle aerodynamics, the road gradient and other factors.
It also considers varying efficiencies of the transmission and engine at various load points for each second
of the driving cycle.
The energy model and the calculated tank-to-wheel energy consumption is validated against the simulation software
VECTO.
Benefits of hybrid powertrains are fully conidered: the possibility to recuperate braking energy as well as efficiency gains from engine
downsizing is accounted for.
Global warming potential impacts per ton-km for a 40-t truck, across different powertrain technologies,
using an urban driving cycle.
## How to use it?
See the notebook with [examples](https://github.com/romainsacchi/carculator_truck/blob/master/examples/Examples.ipynb).
## Support
Do not hesitate to contact the development team at [carculator@psi.ch](mailto:carculator@psi.ch).
## Maintainers
* [Romain Sacchi](https://github.com/romainsacchi)
* [Chris Mutel](https://github.com/cmutel/)
## Contributing
See [contributing](https://github.com/romainsacchi/carculator_truck/blob/master/CONTRIBUTING.md).
## License
[BSD-3-Clause](https://github.com/romainsacchi/carculator_truck/blob/master/LICENSE). Copyright 2020 Paul Scherrer Institut.
%prep
%autosetup -n carculator-truck-0.3.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-carculator-truck -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.3.9-1
- Package Spec generated