%global _empty_manifest_terminate_build 0
Name: python-gs
Version: 1.1.1
Release: 1
Summary: A minimalistic Google Storage client
License: MIT License
URL: https://github.com/kislyuk/gs
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/eb/57/7edce9823698cc7ca0bd4db6d2a736ff58495db46f8411649fa3c6762316/gs-1.1.1.tar.gz
BuildArch: noarch
Requires: python3-tweak
Requires: python3-pyjwt
Requires: python3-requests
Requires: python3-click
Requires: python3-cryptography
Requires: python3-dateutil
Requires: python3-crc32c
%description
*gs* is a command line interface (CLI) and Python library that provides a set of essential commands for
`Google Cloud Storage `_. It is modeled after the AWS CLI's ``aws s3`` command. Its
features are:
* Python 3 compatibility
* A minimalistic set of dependencies
* A tiny footprint
* Intuitive convention-driven configuration of API credentials without browser login prompts
* Checksum validation to ensure end-to-end data integrity in uploads and downloads
* Progress bars for long-running upload and download operations
* Resumable uploads and downloads
* Multithreaded directory sync and batch delete, capable of handling large numbers of objects
* An attractive paging and table layout interface
* A JSON object metadata output mode for feeding data to other utilities
Installation
~~~~~~~~~~~~
pip install gs
Synopsis
~~~~~~~~
Usage:
``gs [OPTIONS] COMMAND [ARGS]...``
Options:
--version Show the version and exit.
--help Show this message and exit.
Commands:
+------------------+--------------------------------------------------+
| ``gs configure`` | Set gs config options, including the API key. |
+------------------+--------------------------------------------------+
| ``gs ls`` | List buckets or objects in a bucket/prefix. |
+------------------+--------------------------------------------------+
| ``gs cp`` | Copy files to, from, or between buckets. |
+------------------+--------------------------------------------------+
| ``gs mv`` | Move files to, from, or between buckets. |
+------------------+--------------------------------------------------+
| ``gs mb`` | Create a new Google Storage bucket. |
+------------------+--------------------------------------------------+
| ``gs rb`` | Permanently delete an empty bucket. |
+------------------+--------------------------------------------------+
| ``gs rm`` | Delete objects (files) from buckets. |
+------------------+--------------------------------------------------+
| ``gs sync`` | Sync a directory of files with bucket/prefix. |
+------------------+--------------------------------------------------+
| ``gs api`` | Use httpie to perform a raw HTTP API request. |
+------------------+--------------------------------------------------+
| ``gs presign`` | Get a pre-signed URL for accessing an object. |
+------------------+--------------------------------------------------+
Run ``gs configure`` to configure Google service account access credentials that will be used by the
``gs`` command. You can create a new service account key at https://console.cloud.google.com/iam-admin/serviceaccounts.
Credentials
~~~~~~~~~~~
Before making API calls, *gs* ingests API credentials in the following order of priority:
- First, *gs* checks if a ``GOOGLE_APPLICATION_CREDENTIALS`` environment variable is set. If so, it attempts to load and use
credentials from the service account credentials filename referenced by the variable.
- If that varible is not set, *gs* attempts to load service account credentials previously configured with ``gs configure``
(stored in ``~/.config/gs/config.json``).
- If that fails, *gs* attempts to load a service account API token from
`Google instance metadata `_.
- If that fails, *gs* prints a warning and attempts to make API requests
`anonymously `_.
Using the Python library interface
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
from gs import GSClient
client = GSClient()
object_meta = client.get("b/my-bucket/o/my-object")
with client.get("b/my-bucket/o/my-object", params=dict(alt="media"), stream=True) as res:
object_bytes = res.raw.read()
presigned_url = client.get_presigned_url("my-bucket", "my-object", expires_at=time.time()+3600)
%package -n python3-gs
Summary: A minimalistic Google Storage client
Provides: python-gs
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-gs
*gs* is a command line interface (CLI) and Python library that provides a set of essential commands for
`Google Cloud Storage `_. It is modeled after the AWS CLI's ``aws s3`` command. Its
features are:
* Python 3 compatibility
* A minimalistic set of dependencies
* A tiny footprint
* Intuitive convention-driven configuration of API credentials without browser login prompts
* Checksum validation to ensure end-to-end data integrity in uploads and downloads
* Progress bars for long-running upload and download operations
* Resumable uploads and downloads
* Multithreaded directory sync and batch delete, capable of handling large numbers of objects
* An attractive paging and table layout interface
* A JSON object metadata output mode for feeding data to other utilities
Installation
~~~~~~~~~~~~
pip install gs
Synopsis
~~~~~~~~
Usage:
``gs [OPTIONS] COMMAND [ARGS]...``
Options:
--version Show the version and exit.
--help Show this message and exit.
Commands:
+------------------+--------------------------------------------------+
| ``gs configure`` | Set gs config options, including the API key. |
+------------------+--------------------------------------------------+
| ``gs ls`` | List buckets or objects in a bucket/prefix. |
+------------------+--------------------------------------------------+
| ``gs cp`` | Copy files to, from, or between buckets. |
+------------------+--------------------------------------------------+
| ``gs mv`` | Move files to, from, or between buckets. |
+------------------+--------------------------------------------------+
| ``gs mb`` | Create a new Google Storage bucket. |
+------------------+--------------------------------------------------+
| ``gs rb`` | Permanently delete an empty bucket. |
+------------------+--------------------------------------------------+
| ``gs rm`` | Delete objects (files) from buckets. |
+------------------+--------------------------------------------------+
| ``gs sync`` | Sync a directory of files with bucket/prefix. |
+------------------+--------------------------------------------------+
| ``gs api`` | Use httpie to perform a raw HTTP API request. |
+------------------+--------------------------------------------------+
| ``gs presign`` | Get a pre-signed URL for accessing an object. |
+------------------+--------------------------------------------------+
Run ``gs configure`` to configure Google service account access credentials that will be used by the
``gs`` command. You can create a new service account key at https://console.cloud.google.com/iam-admin/serviceaccounts.
Credentials
~~~~~~~~~~~
Before making API calls, *gs* ingests API credentials in the following order of priority:
- First, *gs* checks if a ``GOOGLE_APPLICATION_CREDENTIALS`` environment variable is set. If so, it attempts to load and use
credentials from the service account credentials filename referenced by the variable.
- If that varible is not set, *gs* attempts to load service account credentials previously configured with ``gs configure``
(stored in ``~/.config/gs/config.json``).
- If that fails, *gs* attempts to load a service account API token from
`Google instance metadata `_.
- If that fails, *gs* prints a warning and attempts to make API requests
`anonymously `_.
Using the Python library interface
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
from gs import GSClient
client = GSClient()
object_meta = client.get("b/my-bucket/o/my-object")
with client.get("b/my-bucket/o/my-object", params=dict(alt="media"), stream=True) as res:
object_bytes = res.raw.read()
presigned_url = client.get_presigned_url("my-bucket", "my-object", expires_at=time.time()+3600)
%package help
Summary: Development documents and examples for gs
Provides: python3-gs-doc
%description help
*gs* is a command line interface (CLI) and Python library that provides a set of essential commands for
`Google Cloud Storage `_. It is modeled after the AWS CLI's ``aws s3`` command. Its
features are:
* Python 3 compatibility
* A minimalistic set of dependencies
* A tiny footprint
* Intuitive convention-driven configuration of API credentials without browser login prompts
* Checksum validation to ensure end-to-end data integrity in uploads and downloads
* Progress bars for long-running upload and download operations
* Resumable uploads and downloads
* Multithreaded directory sync and batch delete, capable of handling large numbers of objects
* An attractive paging and table layout interface
* A JSON object metadata output mode for feeding data to other utilities
Installation
~~~~~~~~~~~~
pip install gs
Synopsis
~~~~~~~~
Usage:
``gs [OPTIONS] COMMAND [ARGS]...``
Options:
--version Show the version and exit.
--help Show this message and exit.
Commands:
+------------------+--------------------------------------------------+
| ``gs configure`` | Set gs config options, including the API key. |
+------------------+--------------------------------------------------+
| ``gs ls`` | List buckets or objects in a bucket/prefix. |
+------------------+--------------------------------------------------+
| ``gs cp`` | Copy files to, from, or between buckets. |
+------------------+--------------------------------------------------+
| ``gs mv`` | Move files to, from, or between buckets. |
+------------------+--------------------------------------------------+
| ``gs mb`` | Create a new Google Storage bucket. |
+------------------+--------------------------------------------------+
| ``gs rb`` | Permanently delete an empty bucket. |
+------------------+--------------------------------------------------+
| ``gs rm`` | Delete objects (files) from buckets. |
+------------------+--------------------------------------------------+
| ``gs sync`` | Sync a directory of files with bucket/prefix. |
+------------------+--------------------------------------------------+
| ``gs api`` | Use httpie to perform a raw HTTP API request. |
+------------------+--------------------------------------------------+
| ``gs presign`` | Get a pre-signed URL for accessing an object. |
+------------------+--------------------------------------------------+
Run ``gs configure`` to configure Google service account access credentials that will be used by the
``gs`` command. You can create a new service account key at https://console.cloud.google.com/iam-admin/serviceaccounts.
Credentials
~~~~~~~~~~~
Before making API calls, *gs* ingests API credentials in the following order of priority:
- First, *gs* checks if a ``GOOGLE_APPLICATION_CREDENTIALS`` environment variable is set. If so, it attempts to load and use
credentials from the service account credentials filename referenced by the variable.
- If that varible is not set, *gs* attempts to load service account credentials previously configured with ``gs configure``
(stored in ``~/.config/gs/config.json``).
- If that fails, *gs* attempts to load a service account API token from
`Google instance metadata `_.
- If that fails, *gs* prints a warning and attempts to make API requests
`anonymously `_.
Using the Python library interface
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
from gs import GSClient
client = GSClient()
object_meta = client.get("b/my-bucket/o/my-object")
with client.get("b/my-bucket/o/my-object", params=dict(alt="media"), stream=True) as res:
object_bytes = res.raw.read()
presigned_url = client.get_presigned_url("my-bucket", "my-object", expires_at=time.time()+3600)
%prep
%autosetup -n gs-1.1.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-gs -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.1.1-1
- Package Spec generated