%global _empty_manifest_terminate_build 0
Name: python-jupyterlab-tabnine
Version: 0.0.24
Release: 1
Summary: JupyterLab client for Tabnine
License: BSD-3-Clause
URL: https://github.com/codota/tabnine-jupyterlab
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/07/37/34e025190be9e06a390725b9172e231f2eb7c06c11edb402d14840c6b20a/jupyterlab_tabnine-0.0.24.tar.gz
BuildArch: noarch
%description
### Speed Up Your Development
Get quick concise code suggestions you can count on for easy in-flow approval and integration. You’ll never need to memorize syntax, worry about typos, or hunt for snippets again.
### Stay in Flow
Tabnine serves up suggestions for code completions right in your IDE, with no distractions and no downtime.
### Code Discovery
Tabnine's AI scans and learns from the best open-source coding practices from across the globe, freeing you to focus on problems that haven't already been solved.
### Ace Your Code Review
%package -n python3-jupyterlab-tabnine
Summary: JupyterLab client for Tabnine
Provides: python-jupyterlab-tabnine
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-jupyterlab-tabnine
### Speed Up Your Development
Get quick concise code suggestions you can count on for easy in-flow approval and integration. You’ll never need to memorize syntax, worry about typos, or hunt for snippets again.
### Stay in Flow
Tabnine serves up suggestions for code completions right in your IDE, with no distractions and no downtime.
### Code Discovery
Tabnine's AI scans and learns from the best open-source coding practices from across the globe, freeing you to focus on problems that haven't already been solved.
### Ace Your Code Review
%package help
Summary: Development documents and examples for jupyterlab-tabnine
Provides: python3-jupyterlab-tabnine-doc
%description help
### Speed Up Your Development
Get quick concise code suggestions you can count on for easy in-flow approval and integration. You’ll never need to memorize syntax, worry about typos, or hunt for snippets again.
### Stay in Flow
Tabnine serves up suggestions for code completions right in your IDE, with no distractions and no downtime.
### Code Discovery
Tabnine's AI scans and learns from the best open-source coding practices from across the globe, freeing you to focus on problems that haven't already been solved.
### Ace Your Code Review
%prep
%autosetup -n jupyterlab-tabnine-0.0.24
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-jupyterlab-tabnine -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.0.24-1
- Package Spec generated