%global _empty_manifest_terminate_build 0
Name:		python-pupynere
Version:	1.0.15
Release:	1
Summary:	NetCDF file reader and writer.
License:	MIT
URL:		http://bitbucket.org/robertodealmeida/pupynere/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c7/f4/bf96a5e45fb4d8b75d4c585826af3027e7dafef96ae401e8454777530579/pupynere-1.0.15.tar.gz
BuildArch:	noarch


%description
Pupynere is a Python module for reading and writing NetCDF files,
using the same API as Scientific.IO.NetCDF and pynetcdf. It depends only
on Numpy, so you don't need to have the NetCDF library installed.

Changelog:

1.0.15
    Added fix for empty attributes.

1.0.14
    Added support for Unicode attributes.

1.0.13
    Fixed bug when reading character variables without mmap.

1.0.12
  Fixed bug.

1.0.11
  Fixed bug.

1.0.10
  Fixed bug when packing integer attributes in 64-bit systems.

1.0.9
  Should work with Python 2.3.
  Accepts file objects instead of only filenames.

1.0.8
  Allow writing version 2 files (Large Files).

1.0.7
  Removed reads from asserts to allow PYTHONOPTIMIZE.

1.0.6
  Allows zero-length record variables.

1.0.5
  Added the option to open files without using mmap, since mmap can't
  handle huge files on Windows.

1.0.4
  Fixed packing of dimensions when writing a file. The order was being
  read from a dictionary (essentially unordered), instead of from the list
  with the proper order.

1.0.3
  Fixed bug so that it can write scalar variables.

1.0.2
  Fixed broken 1.0.1, ``var.shape`` was returning the current number
  of records in the first dimension, breaking the detection of record
  variables.

1.0.1
  Changed the code to read the variable shape from the underlying
  data object.

1.0.0
  Initial stable release. Handles record arrays properly (using a single
  mmap for all record variables) and writes files.

%package -n python3-pupynere
Summary:	NetCDF file reader and writer.
Provides:	python-pupynere
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pupynere
Pupynere is a Python module for reading and writing NetCDF files,
using the same API as Scientific.IO.NetCDF and pynetcdf. It depends only
on Numpy, so you don't need to have the NetCDF library installed.

Changelog:

1.0.15
    Added fix for empty attributes.

1.0.14
    Added support for Unicode attributes.

1.0.13
    Fixed bug when reading character variables without mmap.

1.0.12
  Fixed bug.

1.0.11
  Fixed bug.

1.0.10
  Fixed bug when packing integer attributes in 64-bit systems.

1.0.9
  Should work with Python 2.3.
  Accepts file objects instead of only filenames.

1.0.8
  Allow writing version 2 files (Large Files).

1.0.7
  Removed reads from asserts to allow PYTHONOPTIMIZE.

1.0.6
  Allows zero-length record variables.

1.0.5
  Added the option to open files without using mmap, since mmap can't
  handle huge files on Windows.

1.0.4
  Fixed packing of dimensions when writing a file. The order was being
  read from a dictionary (essentially unordered), instead of from the list
  with the proper order.

1.0.3
  Fixed bug so that it can write scalar variables.

1.0.2
  Fixed broken 1.0.1, ``var.shape`` was returning the current number
  of records in the first dimension, breaking the detection of record
  variables.

1.0.1
  Changed the code to read the variable shape from the underlying
  data object.

1.0.0
  Initial stable release. Handles record arrays properly (using a single
  mmap for all record variables) and writes files.

%package help
Summary:	Development documents and examples for pupynere
Provides:	python3-pupynere-doc
%description help
Pupynere is a Python module for reading and writing NetCDF files,
using the same API as Scientific.IO.NetCDF and pynetcdf. It depends only
on Numpy, so you don't need to have the NetCDF library installed.

Changelog:

1.0.15
    Added fix for empty attributes.

1.0.14
    Added support for Unicode attributes.

1.0.13
    Fixed bug when reading character variables without mmap.

1.0.12
  Fixed bug.

1.0.11
  Fixed bug.

1.0.10
  Fixed bug when packing integer attributes in 64-bit systems.

1.0.9
  Should work with Python 2.3.
  Accepts file objects instead of only filenames.

1.0.8
  Allow writing version 2 files (Large Files).

1.0.7
  Removed reads from asserts to allow PYTHONOPTIMIZE.

1.0.6
  Allows zero-length record variables.

1.0.5
  Added the option to open files without using mmap, since mmap can't
  handle huge files on Windows.

1.0.4
  Fixed packing of dimensions when writing a file. The order was being
  read from a dictionary (essentially unordered), instead of from the list
  with the proper order.

1.0.3
  Fixed bug so that it can write scalar variables.

1.0.2
  Fixed broken 1.0.1, ``var.shape`` was returning the current number
  of records in the first dimension, breaking the detection of record
  variables.

1.0.1
  Changed the code to read the variable shape from the underlying
  data object.

1.0.0
  Initial stable release. Handles record arrays properly (using a single
  mmap for all record variables) and writes files.

%prep
%autosetup -n pupynere-1.0.15

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pupynere -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.15-1
- Package Spec generated