%global _empty_manifest_terminate_build 0
Name: python-csdmpy
Version: 0.5
Release: 1
Summary: A python module for the core scientific dataset model.
License: BSD-3-Clause
URL: https://github.com/DeepanshS/csdmpy/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fb/0b/3fb267e9131aa261ffb25133397d0297ac278e577d709be4effd86520162/csdmpy-0.5.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-setuptools
Requires: python3-astropy
Requires: python3-requests
Requires: python3-numexpr
Requires: python3-matplotlib
%description
### Use cases
The data model is _versatile_ in allowing many **use cases for most spectroscopy,
diffraction, and imaging techniques**.
![](/docs/_static/csdm.png "")
### Data Model
The model supports multi-component datasets associated with continuous
physical quantities that are discretely sampled in a multi-dimensional space
associated with other carefully controlled quantities, for e.g., a mass as a
function of temperature, a current as a function of voltage and time, a signal
voltage as a function of magnetic field gradient strength, a color image with
a red, green, and blue (RGB) light intensity components as a function of two
independent spatial dimensions, or the six components of the symmetric
second-rank diffusion tensor MRI as a function of three independent spatial
dimensions. Additionally, the model supports multiple dependent variables
sharing the same _d_-dimensional coordinate space. For instance,
the simultaneous measurement of current and voltage as a function of time.
Another example would be the simultaneous acquisition of air temperature,
pressure, wind velocity, and
solar-flux as a function of Earth’s latitude and longitude coordinates. We
refer to these dependent variables as _correlated-datasets_.
**Example**
```py
"csdm": {
"version": "1.0",
# A list of Linear, Monotonic, or Labeled dimensions of the multi-dimensional space.
"dimensions": [{
"type": "linear",
"count": 1608,
"increment": "0.08333333333 yr",
"coordinates_offset": "1880.0416666667 yr",
}],
# A list of dependent variables sampling the multi-dimensional space.
"dependent_variables": [{
"type": "internal",
"unit": "mm",
"numeric_type": "float32",
"quantity_type": "scalar",
"component_labels": ["GMSL"],
"components": [
["-183.0, -171.125, ..., 59.6875, 58.5"]
]
}]
}
```
## Installing _csdmpy_ package
$ pip install csdmpy
## How to cite
Please cite the following when used in publication.
1. Srivastava D.J., Vosegaard T., Massiot D., Grandinetti P.J. (2020) Core Scientific Dataset Model: A lightweight and portable model and file format for multi-dimensional scientific data. [PLOS ONE 15(1): e0225953.](https://doi.org/10.1371/journal.pone.0225953)
## Check out the media coverage.
- [
Des chimistes élaborent un nouveau format pour le partage de données scientifiques](https://inc.cnrs.fr/fr/cnrsinfo/des-chimistes-elaborent-un-nouveau-format-pour-le-partage-de-donnees-scientifiques)
- [
Simplifying how scientists share data](https://www.technology.org/2020/01/03/simplifying-how-scientists-share-data/)
%package -n python3-csdmpy
Summary: A python module for the core scientific dataset model.
Provides: python-csdmpy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-csdmpy
### Use cases
The data model is _versatile_ in allowing many **use cases for most spectroscopy,
diffraction, and imaging techniques**.
![](/docs/_static/csdm.png "")
### Data Model
The model supports multi-component datasets associated with continuous
physical quantities that are discretely sampled in a multi-dimensional space
associated with other carefully controlled quantities, for e.g., a mass as a
function of temperature, a current as a function of voltage and time, a signal
voltage as a function of magnetic field gradient strength, a color image with
a red, green, and blue (RGB) light intensity components as a function of two
independent spatial dimensions, or the six components of the symmetric
second-rank diffusion tensor MRI as a function of three independent spatial
dimensions. Additionally, the model supports multiple dependent variables
sharing the same _d_-dimensional coordinate space. For instance,
the simultaneous measurement of current and voltage as a function of time.
Another example would be the simultaneous acquisition of air temperature,
pressure, wind velocity, and
solar-flux as a function of Earth’s latitude and longitude coordinates. We
refer to these dependent variables as _correlated-datasets_.
**Example**
```py
"csdm": {
"version": "1.0",
# A list of Linear, Monotonic, or Labeled dimensions of the multi-dimensional space.
"dimensions": [{
"type": "linear",
"count": 1608,
"increment": "0.08333333333 yr",
"coordinates_offset": "1880.0416666667 yr",
}],
# A list of dependent variables sampling the multi-dimensional space.
"dependent_variables": [{
"type": "internal",
"unit": "mm",
"numeric_type": "float32",
"quantity_type": "scalar",
"component_labels": ["GMSL"],
"components": [
["-183.0, -171.125, ..., 59.6875, 58.5"]
]
}]
}
```
## Installing _csdmpy_ package
$ pip install csdmpy
## How to cite
Please cite the following when used in publication.
1. Srivastava D.J., Vosegaard T., Massiot D., Grandinetti P.J. (2020) Core Scientific Dataset Model: A lightweight and portable model and file format for multi-dimensional scientific data. [PLOS ONE 15(1): e0225953.](https://doi.org/10.1371/journal.pone.0225953)
## Check out the media coverage.
- [
Des chimistes élaborent un nouveau format pour le partage de données scientifiques](https://inc.cnrs.fr/fr/cnrsinfo/des-chimistes-elaborent-un-nouveau-format-pour-le-partage-de-donnees-scientifiques)
- [
Simplifying how scientists share data](https://www.technology.org/2020/01/03/simplifying-how-scientists-share-data/)
%package help
Summary: Development documents and examples for csdmpy
Provides: python3-csdmpy-doc
%description help
### Use cases
The data model is _versatile_ in allowing many **use cases for most spectroscopy,
diffraction, and imaging techniques**.
![](/docs/_static/csdm.png "")
### Data Model
The model supports multi-component datasets associated with continuous
physical quantities that are discretely sampled in a multi-dimensional space
associated with other carefully controlled quantities, for e.g., a mass as a
function of temperature, a current as a function of voltage and time, a signal
voltage as a function of magnetic field gradient strength, a color image with
a red, green, and blue (RGB) light intensity components as a function of two
independent spatial dimensions, or the six components of the symmetric
second-rank diffusion tensor MRI as a function of three independent spatial
dimensions. Additionally, the model supports multiple dependent variables
sharing the same _d_-dimensional coordinate space. For instance,
the simultaneous measurement of current and voltage as a function of time.
Another example would be the simultaneous acquisition of air temperature,
pressure, wind velocity, and
solar-flux as a function of Earth’s latitude and longitude coordinates. We
refer to these dependent variables as _correlated-datasets_.
**Example**
```py
"csdm": {
"version": "1.0",
# A list of Linear, Monotonic, or Labeled dimensions of the multi-dimensional space.
"dimensions": [{
"type": "linear",
"count": 1608,
"increment": "0.08333333333 yr",
"coordinates_offset": "1880.0416666667 yr",
}],
# A list of dependent variables sampling the multi-dimensional space.
"dependent_variables": [{
"type": "internal",
"unit": "mm",
"numeric_type": "float32",
"quantity_type": "scalar",
"component_labels": ["GMSL"],
"components": [
["-183.0, -171.125, ..., 59.6875, 58.5"]
]
}]
}
```
## Installing _csdmpy_ package
$ pip install csdmpy
## How to cite
Please cite the following when used in publication.
1. Srivastava D.J., Vosegaard T., Massiot D., Grandinetti P.J. (2020) Core Scientific Dataset Model: A lightweight and portable model and file format for multi-dimensional scientific data. [PLOS ONE 15(1): e0225953.](https://doi.org/10.1371/journal.pone.0225953)
## Check out the media coverage.
- [
Des chimistes élaborent un nouveau format pour le partage de données scientifiques](https://inc.cnrs.fr/fr/cnrsinfo/des-chimistes-elaborent-un-nouveau-format-pour-le-partage-de-donnees-scientifiques)
- [
Simplifying how scientists share data](https://www.technology.org/2020/01/03/simplifying-how-scientists-share-data/)
%prep
%autosetup -n csdmpy-0.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-csdmpy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.5-1
- Package Spec generated