%global _empty_manifest_terminate_build 0
Name:		python-kraken-wsclient-py
Version:	0.0.9
Release:	1
Summary:	Sample Kraken WebSockets client
License:	MIT
URL:		http://github.com/krakenfx/kraken-wsclient-py
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/1b/78/b4a060af43031ba2f4a8bffcfc2dce827f5700be4a4466324b13bd341306/kraken-wsclient-py-0.0.9.tar.gz
BuildArch:	noarch


%description
# Kraken WebSockets Client in Python

Sample Kraken WebSockets client in Python.  This client was created for
demonstration purposes only.  It is neither maintained nor supported.

## Installation

    pip install kraken-wsclient-py

## Sample Usage

    from kraken_wsclient_py import kraken_wsclient_py as client

    def my_handler(message):
        # Here you can do stuff with the messages
        print(message)

    my_client = client.WssClient()
    my_client.start()

    # Sample public-data subscription:

    my_client.subscribe_public(
        subscription = {
            'name': 'trade'
        },
        pair = ['XBT/USD', 'XRP/USD'],
        callback = my_handler
    )

    # Sample private-data subscription:

    my_client.subscribe_private(
        subscription = {
            'name': 'openOrders',
            'token': '__WS_TOKEN_HERE__'
        },
        callback = my_handler
    )

    # Sample order-entry call:

    my_client.request(
        request = {
            'token': '__WS_TOKEN_HERE__',
            'event': 'addOrder',
            'type': 'buy',
            'ordertype': 'limit',
            'pair': 'XBT/USD',
            'price': '9000',
            'volume': '0.01',
            'userref': '666'
        },
        callback = my_handler
    )


## Compatibility

This code has been tested on Python 3.7.

## Contributing

Pull requests are not monitored and likely will be ignored.

%package -n python3-kraken-wsclient-py
Summary:	Sample Kraken WebSockets client
Provides:	python-kraken-wsclient-py
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-kraken-wsclient-py
# Kraken WebSockets Client in Python

Sample Kraken WebSockets client in Python.  This client was created for
demonstration purposes only.  It is neither maintained nor supported.

## Installation

    pip install kraken-wsclient-py

## Sample Usage

    from kraken_wsclient_py import kraken_wsclient_py as client

    def my_handler(message):
        # Here you can do stuff with the messages
        print(message)

    my_client = client.WssClient()
    my_client.start()

    # Sample public-data subscription:

    my_client.subscribe_public(
        subscription = {
            'name': 'trade'
        },
        pair = ['XBT/USD', 'XRP/USD'],
        callback = my_handler
    )

    # Sample private-data subscription:

    my_client.subscribe_private(
        subscription = {
            'name': 'openOrders',
            'token': '__WS_TOKEN_HERE__'
        },
        callback = my_handler
    )

    # Sample order-entry call:

    my_client.request(
        request = {
            'token': '__WS_TOKEN_HERE__',
            'event': 'addOrder',
            'type': 'buy',
            'ordertype': 'limit',
            'pair': 'XBT/USD',
            'price': '9000',
            'volume': '0.01',
            'userref': '666'
        },
        callback = my_handler
    )


## Compatibility

This code has been tested on Python 3.7.

## Contributing

Pull requests are not monitored and likely will be ignored.

%package help
Summary:	Development documents and examples for kraken-wsclient-py
Provides:	python3-kraken-wsclient-py-doc
%description help
# Kraken WebSockets Client in Python

Sample Kraken WebSockets client in Python.  This client was created for
demonstration purposes only.  It is neither maintained nor supported.

## Installation

    pip install kraken-wsclient-py

## Sample Usage

    from kraken_wsclient_py import kraken_wsclient_py as client

    def my_handler(message):
        # Here you can do stuff with the messages
        print(message)

    my_client = client.WssClient()
    my_client.start()

    # Sample public-data subscription:

    my_client.subscribe_public(
        subscription = {
            'name': 'trade'
        },
        pair = ['XBT/USD', 'XRP/USD'],
        callback = my_handler
    )

    # Sample private-data subscription:

    my_client.subscribe_private(
        subscription = {
            'name': 'openOrders',
            'token': '__WS_TOKEN_HERE__'
        },
        callback = my_handler
    )

    # Sample order-entry call:

    my_client.request(
        request = {
            'token': '__WS_TOKEN_HERE__',
            'event': 'addOrder',
            'type': 'buy',
            'ordertype': 'limit',
            'pair': 'XBT/USD',
            'price': '9000',
            'volume': '0.01',
            'userref': '666'
        },
        callback = my_handler
    )


## Compatibility

This code has been tested on Python 3.7.

## Contributing

Pull requests are not monitored and likely will be ignored.

%prep
%autosetup -n kraken-wsclient-py-0.0.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-kraken-wsclient-py -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.9-1
- Package Spec generated