%global _empty_manifest_terminate_build 0
Name:		python-punctuator
Version:	0.9.6
Release:	1
Summary:	Adds punctuation to a block of text.
License:	MIT
URL:		https://github.com/chrisspen/punctuator2
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/99/0f/180596123582315cb72c805c605b0ab20942b3035725fca0525729474a7d/punctuator-0.9.6.tar.gz
BuildArch:	noarch


%description
,COMMA           | 64.4 | 45.2 | 53.1
?QUESTIONMARK    | 67.5 | 58.7 | 62.8
.PERIOD          | 72.3 | 71.5 | 71.9
_Overall_        | _68.9_ | _58.1_ | _63.1_
## English Europarl v7
Training set size: 40M words. First stage only. Details in [./example](https://github.com/ottokart/punctuator2/tree/master/example).
You can try to compete with this model [here](http://bark.phon.ioc.ee/punctuator/game).

%package -n python3-punctuator
Summary:	Adds punctuation to a block of text.
Provides:	python-punctuator
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-punctuator
,COMMA           | 64.4 | 45.2 | 53.1
?QUESTIONMARK    | 67.5 | 58.7 | 62.8
.PERIOD          | 72.3 | 71.5 | 71.9
_Overall_        | _68.9_ | _58.1_ | _63.1_
## English Europarl v7
Training set size: 40M words. First stage only. Details in [./example](https://github.com/ottokart/punctuator2/tree/master/example).
You can try to compete with this model [here](http://bark.phon.ioc.ee/punctuator/game).

%package help
Summary:	Development documents and examples for punctuator
Provides:	python3-punctuator-doc
%description help
,COMMA           | 64.4 | 45.2 | 53.1
?QUESTIONMARK    | 67.5 | 58.7 | 62.8
.PERIOD          | 72.3 | 71.5 | 71.9
_Overall_        | _68.9_ | _58.1_ | _63.1_
## English Europarl v7
Training set size: 40M words. First stage only. Details in [./example](https://github.com/ottokart/punctuator2/tree/master/example).
You can try to compete with this model [here](http://bark.phon.ioc.ee/punctuator/game).

%prep
%autosetup -n punctuator-0.9.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-punctuator -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.6-1
- Package Spec generated