%global _empty_manifest_terminate_build 0 Name: python-scikit-hep-testdata Version: 0.4.31 Release: 1 Summary: Example HEP files for testing and demonstrating License: BSD-3-Clause URL: https://github.com/scikit-hep/scikit-hep-testdata Source0: https://mirrors.nju.edu.cn/pypi/web/packages/38/bf/635e06b9579df8b94ac79ac45fd6f9e7fecfedcd385605ea7e5915090d1b/scikit_hep_testdata-0.4.31.tar.gz BuildArch: noarch Requires: python3-pyyaml Requires: python3-requests Requires: python3-importlib-resources Requires: python3-pytest Requires: python3-pytest-cov %description # scikit-hep-testdata [![Scikit-HEP][sk-badge]](https://scikit-hep.org/) [![PyPI version](https://img.shields.io/pypi/v/scikit-hep-testdata.svg?longCache=true)](https://pypi.org/project/scikit-hep-testdata/) [![Conda latest release](https://img.shields.io/conda/vn/conda-forge/scikit-hep-testdata.svg)](https://github.com/conda-forge/scikit-hep-testdata-feedstock) [![Github Actions badge](https://github.com/scikit-hep/scikit-hep-testdata/workflows/CI/badge.svg)](https://github.com/scikit-hep/scikit-hep-testdata/actions) [![Code Coverage](https://codecov.io/gh/scikit-hep/scikit-hep-testdata/graph/badge.svg?branch=main)](https://codecov.io/gh/scikit-hep/scikit-hep-testdata?branch=main) [![pre-commit.ci status](https://results.pre-commit.ci/badge/github/scikit-hep/scikit-hep-testdata/main.svg)](https://results.pre-commit.ci/latest/github/scikit-hep/scikit-hep-testdata/main) [![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black) [sk-badge]: https://scikit-hep.org/assets/images/Scikit--HEP-Project-blue.svg A common package to provide example files (*e.g*. ROOT) for testing and developing packages against. The sample of files is representative of typical files found "in the wild". In addition to including some root files directly, this package adds some simple helper methods to get larger files from common open-access data repositories. ## Installing and usage To install: ```bash python -m pip install scikit-hep-testdata ``` Once installed, absolute file paths can be resolved using the helper methods: ``` python from skhep_testdata import data_path filename = data_path("some_file.root") ``` By default, if an unknown file is requested an exception is raised but this can be skipped by passing the above method `raise_missing=False`: ```python filename = data_path("unknown_file.root", raise_missing=False) ``` The files are not stored on PyPI, so if installed from SDist/wheel, the "local" files will not be present, but will be downloaded from GitHub and cached in the `~/.local/skhepdata` directory. If you make an editable install from the Git repo, or if you set `SKHEP_DATA=1` when building/installing from the Git repo, you will have the data files locally. You can see all "local" files with `skhep_testdata.known_files`, and you can download all files at once with `skhep_testdata.download_all()`, optionally selecting the download cache directory. ### Remote vs. Local files Some files, particularly large ones, for example, are not stored within this package and instead live on a remote server; we call these "remote files". To obtain these use the same `data_path` method as above, however this will trigger the code to download and configure the remote file. This might be slow the first time round but will subsequently be as fast as for a local file. WARNING: the local file caching system has not yet been applied to remote files. ### Command-line invocation You can also interact with this package from the command-line: ```bash # Print a path (download if needed) python -m skhep_testdata cms_hep_2012_tutorial/data.root # Show all "local" files python -m skhep_testdata --list # Download all files to an existing directory python -m skhep_testdata --all --dir local ``` You can also use `pipx run scikit-hep-testdata` to access the above CLI without installing. ## Adding new files We're on the look out for new, interesting files! - *Large files*: If the file is particularly large, for example > 25 MB, it might be worth adding to an external open access data repository and adding a configuration here so that the internal helper methods can pull this down. - *Experiment data policies*: Please make sure you have permissions to add the file to this collection, and that any private or sensitive data has been appropriately masked, salted, or scrambled. ## List of files The following lists describe the files known by this package. ### Files stored in this package - [Listed here](src/skhep_testdata/data) ### Known remote files - [CMS HEP public tutorial from 2012](http://opendata.cern.ch/record/50) ## Contributors We hereby acknowledge the contributors that made this project possible ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
benkrikler
benkrikler

💻 📖
Jim Pivarski
Jim Pivarski

🚧 🔣 📖
Henry Schreiner
Henry Schreiner

🚧 🔣 💻 📖
Eduardo Rodrigues
Eduardo Rodrigues

🚧 🔣 💻
Matthew Feickert
Matthew Feickert

🔣 💻
Pratyush Das
Pratyush Das

🔣 💻
Jerry Ling
Jerry Ling

🔣 💻
Jonas Eschle
Jonas Eschle

💻
Giordon Stark
Giordon Stark

🔣 💻
Dmitry Kalinkin
Dmitry Kalinkin

🔣
Michele Peresano
Michele Peresano

🔣
Luis Antonio Obis Aparicio
Luis Antonio Obis Aparicio

🔣
Oksana Shadura
Oksana Shadura

🔣
Nicholas Smith
Nicholas Smith

🔣
Beojan Stanislaus
Beojan Stanislaus

🔣
Lukas
Lukas

🔣
Johannes Schumann
Johannes Schumann

🔣
Elliott Kauffman
Elliott Kauffman

🔣
Tom Eichlersmith
Tom Eichlersmith

🔣
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. ## Acknowledgements - Many of the files collected directly within this package were collated originally by Jim Pivarski for [uproot](https://github.com/scikit-hep/uproot) ## Running the tests This package uses `pytest` to run the unit tests. Install with `pip install scikit-hep-testdata[test]` or `pip install -e .[test]` (dev) to get the testing requirements. then run: ```bash pytest ``` %package -n python3-scikit-hep-testdata Summary: Example HEP files for testing and demonstrating Provides: python-scikit-hep-testdata BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-scikit-hep-testdata # scikit-hep-testdata [![Scikit-HEP][sk-badge]](https://scikit-hep.org/) [![PyPI version](https://img.shields.io/pypi/v/scikit-hep-testdata.svg?longCache=true)](https://pypi.org/project/scikit-hep-testdata/) [![Conda latest release](https://img.shields.io/conda/vn/conda-forge/scikit-hep-testdata.svg)](https://github.com/conda-forge/scikit-hep-testdata-feedstock) [![Github Actions badge](https://github.com/scikit-hep/scikit-hep-testdata/workflows/CI/badge.svg)](https://github.com/scikit-hep/scikit-hep-testdata/actions) [![Code Coverage](https://codecov.io/gh/scikit-hep/scikit-hep-testdata/graph/badge.svg?branch=main)](https://codecov.io/gh/scikit-hep/scikit-hep-testdata?branch=main) [![pre-commit.ci status](https://results.pre-commit.ci/badge/github/scikit-hep/scikit-hep-testdata/main.svg)](https://results.pre-commit.ci/latest/github/scikit-hep/scikit-hep-testdata/main) [![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black) [sk-badge]: https://scikit-hep.org/assets/images/Scikit--HEP-Project-blue.svg A common package to provide example files (*e.g*. ROOT) for testing and developing packages against. The sample of files is representative of typical files found "in the wild". In addition to including some root files directly, this package adds some simple helper methods to get larger files from common open-access data repositories. ## Installing and usage To install: ```bash python -m pip install scikit-hep-testdata ``` Once installed, absolute file paths can be resolved using the helper methods: ``` python from skhep_testdata import data_path filename = data_path("some_file.root") ``` By default, if an unknown file is requested an exception is raised but this can be skipped by passing the above method `raise_missing=False`: ```python filename = data_path("unknown_file.root", raise_missing=False) ``` The files are not stored on PyPI, so if installed from SDist/wheel, the "local" files will not be present, but will be downloaded from GitHub and cached in the `~/.local/skhepdata` directory. If you make an editable install from the Git repo, or if you set `SKHEP_DATA=1` when building/installing from the Git repo, you will have the data files locally. You can see all "local" files with `skhep_testdata.known_files`, and you can download all files at once with `skhep_testdata.download_all()`, optionally selecting the download cache directory. ### Remote vs. Local files Some files, particularly large ones, for example, are not stored within this package and instead live on a remote server; we call these "remote files". To obtain these use the same `data_path` method as above, however this will trigger the code to download and configure the remote file. This might be slow the first time round but will subsequently be as fast as for a local file. WARNING: the local file caching system has not yet been applied to remote files. ### Command-line invocation You can also interact with this package from the command-line: ```bash # Print a path (download if needed) python -m skhep_testdata cms_hep_2012_tutorial/data.root # Show all "local" files python -m skhep_testdata --list # Download all files to an existing directory python -m skhep_testdata --all --dir local ``` You can also use `pipx run scikit-hep-testdata` to access the above CLI without installing. ## Adding new files We're on the look out for new, interesting files! - *Large files*: If the file is particularly large, for example > 25 MB, it might be worth adding to an external open access data repository and adding a configuration here so that the internal helper methods can pull this down. - *Experiment data policies*: Please make sure you have permissions to add the file to this collection, and that any private or sensitive data has been appropriately masked, salted, or scrambled. ## List of files The following lists describe the files known by this package. ### Files stored in this package - [Listed here](src/skhep_testdata/data) ### Known remote files - [CMS HEP public tutorial from 2012](http://opendata.cern.ch/record/50) ## Contributors We hereby acknowledge the contributors that made this project possible ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
benkrikler
benkrikler

💻 📖
Jim Pivarski
Jim Pivarski

🚧 🔣 📖
Henry Schreiner
Henry Schreiner

🚧 🔣 💻 📖
Eduardo Rodrigues
Eduardo Rodrigues

🚧 🔣 💻
Matthew Feickert
Matthew Feickert

🔣 💻
Pratyush Das
Pratyush Das

🔣 💻
Jerry Ling
Jerry Ling

🔣 💻
Jonas Eschle
Jonas Eschle

💻
Giordon Stark
Giordon Stark

🔣 💻
Dmitry Kalinkin
Dmitry Kalinkin

🔣
Michele Peresano
Michele Peresano

🔣
Luis Antonio Obis Aparicio
Luis Antonio Obis Aparicio

🔣
Oksana Shadura
Oksana Shadura

🔣
Nicholas Smith
Nicholas Smith

🔣
Beojan Stanislaus
Beojan Stanislaus

🔣
Lukas
Lukas

🔣
Johannes Schumann
Johannes Schumann

🔣
Elliott Kauffman
Elliott Kauffman

🔣
Tom Eichlersmith
Tom Eichlersmith

🔣
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. ## Acknowledgements - Many of the files collected directly within this package were collated originally by Jim Pivarski for [uproot](https://github.com/scikit-hep/uproot) ## Running the tests This package uses `pytest` to run the unit tests. Install with `pip install scikit-hep-testdata[test]` or `pip install -e .[test]` (dev) to get the testing requirements. then run: ```bash pytest ``` %package help Summary: Development documents and examples for scikit-hep-testdata Provides: python3-scikit-hep-testdata-doc %description help # scikit-hep-testdata [![Scikit-HEP][sk-badge]](https://scikit-hep.org/) [![PyPI version](https://img.shields.io/pypi/v/scikit-hep-testdata.svg?longCache=true)](https://pypi.org/project/scikit-hep-testdata/) [![Conda latest release](https://img.shields.io/conda/vn/conda-forge/scikit-hep-testdata.svg)](https://github.com/conda-forge/scikit-hep-testdata-feedstock) [![Github Actions badge](https://github.com/scikit-hep/scikit-hep-testdata/workflows/CI/badge.svg)](https://github.com/scikit-hep/scikit-hep-testdata/actions) [![Code Coverage](https://codecov.io/gh/scikit-hep/scikit-hep-testdata/graph/badge.svg?branch=main)](https://codecov.io/gh/scikit-hep/scikit-hep-testdata?branch=main) [![pre-commit.ci status](https://results.pre-commit.ci/badge/github/scikit-hep/scikit-hep-testdata/main.svg)](https://results.pre-commit.ci/latest/github/scikit-hep/scikit-hep-testdata/main) [![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black) [sk-badge]: https://scikit-hep.org/assets/images/Scikit--HEP-Project-blue.svg A common package to provide example files (*e.g*. ROOT) for testing and developing packages against. The sample of files is representative of typical files found "in the wild". In addition to including some root files directly, this package adds some simple helper methods to get larger files from common open-access data repositories. ## Installing and usage To install: ```bash python -m pip install scikit-hep-testdata ``` Once installed, absolute file paths can be resolved using the helper methods: ``` python from skhep_testdata import data_path filename = data_path("some_file.root") ``` By default, if an unknown file is requested an exception is raised but this can be skipped by passing the above method `raise_missing=False`: ```python filename = data_path("unknown_file.root", raise_missing=False) ``` The files are not stored on PyPI, so if installed from SDist/wheel, the "local" files will not be present, but will be downloaded from GitHub and cached in the `~/.local/skhepdata` directory. If you make an editable install from the Git repo, or if you set `SKHEP_DATA=1` when building/installing from the Git repo, you will have the data files locally. You can see all "local" files with `skhep_testdata.known_files`, and you can download all files at once with `skhep_testdata.download_all()`, optionally selecting the download cache directory. ### Remote vs. Local files Some files, particularly large ones, for example, are not stored within this package and instead live on a remote server; we call these "remote files". To obtain these use the same `data_path` method as above, however this will trigger the code to download and configure the remote file. This might be slow the first time round but will subsequently be as fast as for a local file. WARNING: the local file caching system has not yet been applied to remote files. ### Command-line invocation You can also interact with this package from the command-line: ```bash # Print a path (download if needed) python -m skhep_testdata cms_hep_2012_tutorial/data.root # Show all "local" files python -m skhep_testdata --list # Download all files to an existing directory python -m skhep_testdata --all --dir local ``` You can also use `pipx run scikit-hep-testdata` to access the above CLI without installing. ## Adding new files We're on the look out for new, interesting files! - *Large files*: If the file is particularly large, for example > 25 MB, it might be worth adding to an external open access data repository and adding a configuration here so that the internal helper methods can pull this down. - *Experiment data policies*: Please make sure you have permissions to add the file to this collection, and that any private or sensitive data has been appropriately masked, salted, or scrambled. ## List of files The following lists describe the files known by this package. ### Files stored in this package - [Listed here](src/skhep_testdata/data) ### Known remote files - [CMS HEP public tutorial from 2012](http://opendata.cern.ch/record/50) ## Contributors We hereby acknowledge the contributors that made this project possible ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
benkrikler
benkrikler

💻 📖
Jim Pivarski
Jim Pivarski

🚧 🔣 📖
Henry Schreiner
Henry Schreiner

🚧 🔣 💻 📖
Eduardo Rodrigues
Eduardo Rodrigues

🚧 🔣 💻
Matthew Feickert
Matthew Feickert

🔣 💻
Pratyush Das
Pratyush Das

🔣 💻
Jerry Ling
Jerry Ling

🔣 💻
Jonas Eschle
Jonas Eschle

💻
Giordon Stark
Giordon Stark

🔣 💻
Dmitry Kalinkin
Dmitry Kalinkin

🔣
Michele Peresano
Michele Peresano

🔣
Luis Antonio Obis Aparicio
Luis Antonio Obis Aparicio

🔣
Oksana Shadura
Oksana Shadura

🔣
Nicholas Smith
Nicholas Smith

🔣
Beojan Stanislaus
Beojan Stanislaus

🔣
Lukas
Lukas

🔣
Johannes Schumann
Johannes Schumann

🔣
Elliott Kauffman
Elliott Kauffman

🔣
Tom Eichlersmith
Tom Eichlersmith

🔣
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. ## Acknowledgements - Many of the files collected directly within this package were collated originally by Jim Pivarski for [uproot](https://github.com/scikit-hep/uproot) ## Running the tests This package uses `pytest` to run the unit tests. Install with `pip install scikit-hep-testdata[test]` or `pip install -e .[test]` (dev) to get the testing requirements. then run: ```bash pytest ``` %prep %autosetup -n scikit-hep-testdata-0.4.31 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-scikit-hep-testdata -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Wed May 31 2023 Python_Bot - 0.4.31-1 - Package Spec generated