%global _empty_manifest_terminate_build 0
Name:		python-bandcamp-downloader
Version:	0.0.13
Release:	1
Summary:	bandcamp-dl downloads albums and tracks from Bandcamp for you
License:	Unlicense
URL:		https://github.com/iheanyi/bandcamp-dl
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/cb/6f/08d0e2b1819327e375ebf67af0689727b2d49db7c0d11d4829552ea01ae4/bandcamp-downloader-0.0.13.tar.gz
BuildArch:	noarch

Requires:	python3-beautifulsoup4
Requires:	python3-lxml
Requires:	python3-demjson3
Requires:	python3-docopt
Requires:	python3-mutagen
Requires:	python3-requests
Requires:	python3-unicode-slugify
Requires:	python3-mock
Requires:	python3-chardet
Requires:	python3-requests-cache
Requires:	python3-pytest

%description
download audio from BandCamp.com

%package -n python3-bandcamp-downloader
Summary:	bandcamp-dl downloads albums and tracks from Bandcamp for you
Provides:	python-bandcamp-downloader
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-bandcamp-downloader
download audio from BandCamp.com

%package help
Summary:	Development documents and examples for bandcamp-downloader
Provides:	python3-bandcamp-downloader-doc
%description help
download audio from BandCamp.com

%prep
%autosetup -n bandcamp-downloader-0.0.13

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-bandcamp-downloader -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.13-1
- Package Spec generated