%global _empty_manifest_terminate_build 0
Name: python-nose-launchable
Version: 0.5.0
Release: 1
Summary: A nose plugin to interact with Launchable API
License: Apache Software License
URL: https://github.com/launchableinc/nose-launchable
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/20/ac/393ce3523fd432986ebbcbfc760bb2009576b440fcb592cd99313830f127/nose-launchable-0.5.0.tar.gz
BuildArch: noarch
Requires: python3-launchable
Requires: python3-boto3
Requires: python3-requests
Requires: python3-nose
Requires: python3-nose3
%description
A nose plugin to interact with
`Launchable `__ API.
%package -n python3-nose-launchable
Summary: A nose plugin to interact with Launchable API
Provides: python-nose-launchable
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-nose-launchable
A nose plugin to interact with
`Launchable `__ API.
%package help
Summary: Development documents and examples for nose-launchable
Provides: python3-nose-launchable-doc
%description help
A nose plugin to interact with
`Launchable `__ API.
%prep
%autosetup -n nose-launchable-0.5.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-nose-launchable -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.5.0-1
- Package Spec generated