%global _empty_manifest_terminate_build 0
Name: python-scprep
Version: 1.2.2
Release: 1
Summary: scprep
License: GNU General Public License Version 3
URL: https://github.com/KrishnaswamyLab/scprep
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e6/47/cf0a6ec65dba7545128dd8f90e4449c5f14b277d2b05ef83fa28bad52603/scprep-1.2.2.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-scikit-learn
Requires: python3-decorator
Requires: python3-pandas
Requires: python3-packaging
Requires: python3-sphinx
Requires: python3-sphinxcontrib-napoleon
Requires: python3-ipykernel
Requires: python3-nbsphinx
Requires: python3-autodocsumm
Requires: python3-fcsparser
Requires: python3-tables
Requires: python3-h5py
Requires: python3-anndata
Requires: python3-anndata2ri
Requires: python3-nose
Requires: python3-nose2
Requires: python3-coverage
Requires: python3-coveralls
Requires: python3-parameterized
Requires: python3-requests
Requires: python3-packaging
Requires: python3-mock
Requires: python3-h5py
Requires: python3-matplotlib
Requires: python3-rpy2
Requires: python3-black
Requires: python3-fcsparser
Requires: python3-tables
Requires: python3-anndata
Requires: python3-anndata2ri
%description
preprocessing is available on `pip`. Install by running the following in a terminal::
pip install --user scprep
Alternatively, scprep can be installed using `Conda `_ (most easily obtained via the `Miniconda Python distribution `_)::
conda install -c bioconda scprep
%package -n python3-scprep
Summary: scprep
Provides: python-scprep
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-scprep
preprocessing is available on `pip`. Install by running the following in a terminal::
pip install --user scprep
Alternatively, scprep can be installed using `Conda `_ (most easily obtained via the `Miniconda Python distribution `_)::
conda install -c bioconda scprep
%package help
Summary: Development documents and examples for scprep
Provides: python3-scprep-doc
%description help
preprocessing is available on `pip`. Install by running the following in a terminal::
pip install --user scprep
Alternatively, scprep can be installed using `Conda `_ (most easily obtained via the `Miniconda Python distribution `_)::
conda install -c bioconda scprep
%prep
%autosetup -n scprep-1.2.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-scprep -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.2.2-1
- Package Spec generated