%global _empty_manifest_terminate_build 0
Name: python-codecarbon
Version: 2.2.3
Release: 1
Summary: please add a summary manually as the author left a blank one
License: MIT License
URL: https://pypi.org/project/codecarbon/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c5/2d/f83998583c02ae4c653801642f49bd90f29ece54ced4cfec6d576a937983/codecarbon-2.2.3.tar.gz
BuildArch: noarch
Requires: python3-arrow
Requires: python3-pandas
Requires: python3-pynvml
Requires: python3-requests
Requires: python3-psutil
Requires: python3-py-cpuinfo
Requires: python3-fuzzywuzzy
Requires: python3-click
Requires: python3-dash
Requires: python3-plotly
Requires: python3-dash-bootstrap-components
Requires: python3-dash
Requires: python3-dash-bootstrap-components
Requires: python3-fire
%description

Estimate and track carbon emissions from your computer, quantify and analyze their impact.
[**Documentation**](https://mlco2.github.io/codecarbon)
[](https://anaconda.org/conda-forge/codecarbon)
[](https://pypi.org/project/codecarbon/)
[](https://zenodo.org/badge/latestdoi/263364731)
- [About CodeCarbon π‘](#about-codecarbon-)
- [Quickstart π](#quickstart-)
- [Installation π§](#installation-)
- [Start to estimate your impact π](#start-to-estimate-your-impact-)
- [Monitoring your whole machine](#monitoring-your-machine-)
- [In your python code](#in-your-python-code-)
- [Visualize](#visualize-)
- [Contributing π€](#contributing-)
- [Contact π](#contact-)
# About CodeCarbon π‘
**CodeCarbon** started with a quite simple question:
**What is the carbon emission impact of my computer program? :shrug:**
We found some global data like "computing currently represents roughly 0.5% of the worldβs energy consumption" but nothing on our individual/organisation level impact.
At **CodeCarbon**, we believe, along with Niels Bohr, that "Nothing exists until it is measured". So we found a way to estimate how much CO2 we produce while running our code.
*How?*
We created a Python package that estimates your hardware electricity power consumption (GPU + CPU + RAM) and we apply to it the carbon intensity of the region where the computing is done.

We explain more about this calculation in the [**Methodology**](https://mlco2.github.io/codecarbon/methodology.html#) section of the documentation.
Our hope is that this package will be used widely for estimating the carbon footprint of computing, and for establishing best practices with regards to the disclosure and reduction of this footprint.
**So ready to "change the world one run at a time"? Let's start with a very quick set up.**
# Quickstart π
## Installation π§
**From PyPI repository**
```python
pip install codecarbon
```
**From Conda repository**
```python
conda install -c conda-forge codecarbon
```
To see more installation options please refer to the documentation : [**Installation**](https://mlco2.github.io/codecarbon/installation.html#)
## Start to estimate your impact π
To get an experiment_id enter:
```python
! codecarbon init
```
You can now store it in a **.codecarbon.config** at the root of your project
```python
[codecarbon]
log_level = DEBUG
save_to_api = True
experiment_id = 2bcbcbb8-850d-4692-af0d-76f6f36d79b2 #the experiment_id you get with init
```
Now you have 2 main options:
### Monitoring your machine π»
In your command prompt use:
```codecarbon monitor```
The package will track your emissions independently from your code.
### In your Python code π
```python
from codecarbon import track_emissions
@track_emissions()
def your_function_to_track():
# your code
```
The package will track the emissions generated by the execution of your function.
There is other ways to use **codecarbon** package, please refer to the documentation to learn more about it: [**Usage**](https://mlco2.github.io/codecarbon/usage.html#)
## Visualize π
You can now visualize your experiment emissions on the [dashboard](https://dashboard.codecarbon.io/).

*Note that for now, all emissions data send to codecarbon API are public.*
> Hope you enjoy your first steps monitoring your carbon computing impact!
> Thanks to the incredible codecarbon community πͺπΌ a lot more options are available using *codecarbon* including:
> - offline mode
> - cloud mode
> - comet integration...
>
> Please explore the [**Documentation**](https://mlco2.github.io/codecarbon) to learn about it
> If ever what your are looking for is not yet implemented, let us know through the *issues* and even better become one of our π¦ΈπΌββοΈπ¦ΈπΌββοΈ contributors! more info ππΌ
# Contributing π€
We are hoping that the open-source community will help us edit the code and make it better!
You are welcome to open issues, even suggest solutions and better still contribute the fix/improvement! We can guide you if you're not sure where to start but want to help us out π₯
In order to contribute a change to our code base, please submit a pull request (PR) via GitHub and someone from our team will go over it and accept it.
Check out our [contribution guidelines :arrow_upper_right:](https://github.com/mlco2/codecarbon/blob/master/CONTRIBUTING.md)
Contact [@vict0rsch](https://github.com/vict0rsch) to be added to our slack workspace if you want to contribute regularly!
# Contact π
Maintainers are [@vict0rsch](https://github.com/vict0rsch) [@benoit-cty](https://github.com/benoit-cty) and [@SaboniAmine](https://github.com/saboniamine). Codecarbon is developed by volunteers from [**Mila**](http://mila.quebec) and the [**DataForGoodFR**](https://twitter.com/dataforgood_fr) community alongside donated professional time of engineers at [**Comet.ml**](https://comet.ml) and [**BCG GAMMA**](https://www.bcg.com/en-nl/beyond-consulting/bcg-gamma/default).
%package -n python3-codecarbon
Summary: please add a summary manually as the author left a blank one
Provides: python-codecarbon
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-codecarbon

Estimate and track carbon emissions from your computer, quantify and analyze their impact.
[**Documentation**](https://mlco2.github.io/codecarbon)
[](https://anaconda.org/conda-forge/codecarbon)
[](https://pypi.org/project/codecarbon/)
[](https://zenodo.org/badge/latestdoi/263364731)
- [About CodeCarbon π‘](#about-codecarbon-)
- [Quickstart π](#quickstart-)
- [Installation π§](#installation-)
- [Start to estimate your impact π](#start-to-estimate-your-impact-)
- [Monitoring your whole machine](#monitoring-your-machine-)
- [In your python code](#in-your-python-code-)
- [Visualize](#visualize-)
- [Contributing π€](#contributing-)
- [Contact π](#contact-)
# About CodeCarbon π‘
**CodeCarbon** started with a quite simple question:
**What is the carbon emission impact of my computer program? :shrug:**
We found some global data like "computing currently represents roughly 0.5% of the worldβs energy consumption" but nothing on our individual/organisation level impact.
At **CodeCarbon**, we believe, along with Niels Bohr, that "Nothing exists until it is measured". So we found a way to estimate how much CO2 we produce while running our code.
*How?*
We created a Python package that estimates your hardware electricity power consumption (GPU + CPU + RAM) and we apply to it the carbon intensity of the region where the computing is done.

We explain more about this calculation in the [**Methodology**](https://mlco2.github.io/codecarbon/methodology.html#) section of the documentation.
Our hope is that this package will be used widely for estimating the carbon footprint of computing, and for establishing best practices with regards to the disclosure and reduction of this footprint.
**So ready to "change the world one run at a time"? Let's start with a very quick set up.**
# Quickstart π
## Installation π§
**From PyPI repository**
```python
pip install codecarbon
```
**From Conda repository**
```python
conda install -c conda-forge codecarbon
```
To see more installation options please refer to the documentation : [**Installation**](https://mlco2.github.io/codecarbon/installation.html#)
## Start to estimate your impact π
To get an experiment_id enter:
```python
! codecarbon init
```
You can now store it in a **.codecarbon.config** at the root of your project
```python
[codecarbon]
log_level = DEBUG
save_to_api = True
experiment_id = 2bcbcbb8-850d-4692-af0d-76f6f36d79b2 #the experiment_id you get with init
```
Now you have 2 main options:
### Monitoring your machine π»
In your command prompt use:
```codecarbon monitor```
The package will track your emissions independently from your code.
### In your Python code π
```python
from codecarbon import track_emissions
@track_emissions()
def your_function_to_track():
# your code
```
The package will track the emissions generated by the execution of your function.
There is other ways to use **codecarbon** package, please refer to the documentation to learn more about it: [**Usage**](https://mlco2.github.io/codecarbon/usage.html#)
## Visualize π
You can now visualize your experiment emissions on the [dashboard](https://dashboard.codecarbon.io/).

*Note that for now, all emissions data send to codecarbon API are public.*
> Hope you enjoy your first steps monitoring your carbon computing impact!
> Thanks to the incredible codecarbon community πͺπΌ a lot more options are available using *codecarbon* including:
> - offline mode
> - cloud mode
> - comet integration...
>
> Please explore the [**Documentation**](https://mlco2.github.io/codecarbon) to learn about it
> If ever what your are looking for is not yet implemented, let us know through the *issues* and even better become one of our π¦ΈπΌββοΈπ¦ΈπΌββοΈ contributors! more info ππΌ
# Contributing π€
We are hoping that the open-source community will help us edit the code and make it better!
You are welcome to open issues, even suggest solutions and better still contribute the fix/improvement! We can guide you if you're not sure where to start but want to help us out π₯
In order to contribute a change to our code base, please submit a pull request (PR) via GitHub and someone from our team will go over it and accept it.
Check out our [contribution guidelines :arrow_upper_right:](https://github.com/mlco2/codecarbon/blob/master/CONTRIBUTING.md)
Contact [@vict0rsch](https://github.com/vict0rsch) to be added to our slack workspace if you want to contribute regularly!
# Contact π
Maintainers are [@vict0rsch](https://github.com/vict0rsch) [@benoit-cty](https://github.com/benoit-cty) and [@SaboniAmine](https://github.com/saboniamine). Codecarbon is developed by volunteers from [**Mila**](http://mila.quebec) and the [**DataForGoodFR**](https://twitter.com/dataforgood_fr) community alongside donated professional time of engineers at [**Comet.ml**](https://comet.ml) and [**BCG GAMMA**](https://www.bcg.com/en-nl/beyond-consulting/bcg-gamma/default).
%package help
Summary: Development documents and examples for codecarbon
Provides: python3-codecarbon-doc
%description help

Estimate and track carbon emissions from your computer, quantify and analyze their impact.
[**Documentation**](https://mlco2.github.io/codecarbon)
[](https://anaconda.org/conda-forge/codecarbon)
[](https://pypi.org/project/codecarbon/)
[](https://zenodo.org/badge/latestdoi/263364731)
- [About CodeCarbon π‘](#about-codecarbon-)
- [Quickstart π](#quickstart-)
- [Installation π§](#installation-)
- [Start to estimate your impact π](#start-to-estimate-your-impact-)
- [Monitoring your whole machine](#monitoring-your-machine-)
- [In your python code](#in-your-python-code-)
- [Visualize](#visualize-)
- [Contributing π€](#contributing-)
- [Contact π](#contact-)
# About CodeCarbon π‘
**CodeCarbon** started with a quite simple question:
**What is the carbon emission impact of my computer program? :shrug:**
We found some global data like "computing currently represents roughly 0.5% of the worldβs energy consumption" but nothing on our individual/organisation level impact.
At **CodeCarbon**, we believe, along with Niels Bohr, that "Nothing exists until it is measured". So we found a way to estimate how much CO2 we produce while running our code.
*How?*
We created a Python package that estimates your hardware electricity power consumption (GPU + CPU + RAM) and we apply to it the carbon intensity of the region where the computing is done.

We explain more about this calculation in the [**Methodology**](https://mlco2.github.io/codecarbon/methodology.html#) section of the documentation.
Our hope is that this package will be used widely for estimating the carbon footprint of computing, and for establishing best practices with regards to the disclosure and reduction of this footprint.
**So ready to "change the world one run at a time"? Let's start with a very quick set up.**
# Quickstart π
## Installation π§
**From PyPI repository**
```python
pip install codecarbon
```
**From Conda repository**
```python
conda install -c conda-forge codecarbon
```
To see more installation options please refer to the documentation : [**Installation**](https://mlco2.github.io/codecarbon/installation.html#)
## Start to estimate your impact π
To get an experiment_id enter:
```python
! codecarbon init
```
You can now store it in a **.codecarbon.config** at the root of your project
```python
[codecarbon]
log_level = DEBUG
save_to_api = True
experiment_id = 2bcbcbb8-850d-4692-af0d-76f6f36d79b2 #the experiment_id you get with init
```
Now you have 2 main options:
### Monitoring your machine π»
In your command prompt use:
```codecarbon monitor```
The package will track your emissions independently from your code.
### In your Python code π
```python
from codecarbon import track_emissions
@track_emissions()
def your_function_to_track():
# your code
```
The package will track the emissions generated by the execution of your function.
There is other ways to use **codecarbon** package, please refer to the documentation to learn more about it: [**Usage**](https://mlco2.github.io/codecarbon/usage.html#)
## Visualize π
You can now visualize your experiment emissions on the [dashboard](https://dashboard.codecarbon.io/).

*Note that for now, all emissions data send to codecarbon API are public.*
> Hope you enjoy your first steps monitoring your carbon computing impact!
> Thanks to the incredible codecarbon community πͺπΌ a lot more options are available using *codecarbon* including:
> - offline mode
> - cloud mode
> - comet integration...
>
> Please explore the [**Documentation**](https://mlco2.github.io/codecarbon) to learn about it
> If ever what your are looking for is not yet implemented, let us know through the *issues* and even better become one of our π¦ΈπΌββοΈπ¦ΈπΌββοΈ contributors! more info ππΌ
# Contributing π€
We are hoping that the open-source community will help us edit the code and make it better!
You are welcome to open issues, even suggest solutions and better still contribute the fix/improvement! We can guide you if you're not sure where to start but want to help us out π₯
In order to contribute a change to our code base, please submit a pull request (PR) via GitHub and someone from our team will go over it and accept it.
Check out our [contribution guidelines :arrow_upper_right:](https://github.com/mlco2/codecarbon/blob/master/CONTRIBUTING.md)
Contact [@vict0rsch](https://github.com/vict0rsch) to be added to our slack workspace if you want to contribute regularly!
# Contact π
Maintainers are [@vict0rsch](https://github.com/vict0rsch) [@benoit-cty](https://github.com/benoit-cty) and [@SaboniAmine](https://github.com/saboniamine). Codecarbon is developed by volunteers from [**Mila**](http://mila.quebec) and the [**DataForGoodFR**](https://twitter.com/dataforgood_fr) community alongside donated professional time of engineers at [**Comet.ml**](https://comet.ml) and [**BCG GAMMA**](https://www.bcg.com/en-nl/beyond-consulting/bcg-gamma/default).
%prep
%autosetup -n codecarbon-2.2.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-codecarbon -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.2.3-1
- Package Spec generated