%global _empty_manifest_terminate_build 0
Name: python-junior-ssl
Version: 0.5.0
Release: 1
Summary: Junior SSL - An omniwheel soccer setup
License: Free for non-commercial use
URL: https://github.com/rhoban/junior-ssl/
Source0: https://mirrors.aliyun.com/pypi/web/packages/39/e0/82755850a8b0596f7000dae31e6885c68e8ad7e11b6d9a8a5399156fa428/junior-ssl-0.5.0.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-zmq
Requires: python3-flask
Requires: python3-flask-cors
Requires: python3-opencv-contrib-python-headless
Requires: python3-opencv-python-headless
Requires: python3-pyserial
Requires: python3-waitress
%description
# Junior SSL (Omniwheel soccer setup)
![Robots](/docs/imgs/cover.jpg)
## Presentation
[YouTube demonstration video](https://www.youtube.com/watch?v=4NFXbaom7YQ)
The goal of this project is to provide an open-source material to build and operate a setup featuring
omniwheel robots and a soccer field monitoring them with a camera.
With this setup, it is possible for two teams to code a program and play against each other.
## Documentation
**This is a WORK IN PROGRESS, you can't (yet) build the whole setup by following instructions from
this repository, if any question, do not hesitate to open an issue**
* [Robots](/docs/robots.md)
* [Coordinates, field and markers](/docs/coordinates-markers.md)
* [Game Controller and Python API](/docs/programming.md)
## License
This work is licensed under a Creative Commons Attribution-NonCommercial 2.0 Generic License.
%package -n python3-junior-ssl
Summary: Junior SSL - An omniwheel soccer setup
Provides: python-junior-ssl
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-junior-ssl
# Junior SSL (Omniwheel soccer setup)
![Robots](/docs/imgs/cover.jpg)
## Presentation
[YouTube demonstration video](https://www.youtube.com/watch?v=4NFXbaom7YQ)
The goal of this project is to provide an open-source material to build and operate a setup featuring
omniwheel robots and a soccer field monitoring them with a camera.
With this setup, it is possible for two teams to code a program and play against each other.
## Documentation
**This is a WORK IN PROGRESS, you can't (yet) build the whole setup by following instructions from
this repository, if any question, do not hesitate to open an issue**
* [Robots](/docs/robots.md)
* [Coordinates, field and markers](/docs/coordinates-markers.md)
* [Game Controller and Python API](/docs/programming.md)
## License
This work is licensed under a Creative Commons Attribution-NonCommercial 2.0 Generic License.
%package help
Summary: Development documents and examples for junior-ssl
Provides: python3-junior-ssl-doc
%description help
# Junior SSL (Omniwheel soccer setup)
![Robots](/docs/imgs/cover.jpg)
## Presentation
[YouTube demonstration video](https://www.youtube.com/watch?v=4NFXbaom7YQ)
The goal of this project is to provide an open-source material to build and operate a setup featuring
omniwheel robots and a soccer field monitoring them with a camera.
With this setup, it is possible for two teams to code a program and play against each other.
## Documentation
**This is a WORK IN PROGRESS, you can't (yet) build the whole setup by following instructions from
this repository, if any question, do not hesitate to open an issue**
* [Robots](/docs/robots.md)
* [Coordinates, field and markers](/docs/coordinates-markers.md)
* [Game Controller and Python API](/docs/programming.md)
## License
This work is licensed under a Creative Commons Attribution-NonCommercial 2.0 Generic License.
%prep
%autosetup -n junior-ssl-0.5.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-junior-ssl -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.5.0-1
- Package Spec generated