%global _empty_manifest_terminate_build 0
Name:		python-py-nextbusnext
Version:	0.1.5
Release:	1
Summary:	Minimalistic Python client for the NextBus public API for real-time transit arrival data
License:	MIT License
URL:		https://github.com/vividboarder/py_nextbus
Source0:	https://mirrors.aliyun.com/pypi/web/packages/69/da/e281cc2e658521c87cb3258b569d2f3094808dc59810c5c9bdf412ebf6b1/py_nextbusnext-0.1.5.tar.gz
BuildArch:	noarch


%description
Install with pip:
`pip install py-nextbusnext`

%package -n python3-py-nextbusnext
Summary:	Minimalistic Python client for the NextBus public API for real-time transit arrival data
Provides:	python-py-nextbusnext
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-py-nextbusnext
Install with pip:
`pip install py-nextbusnext`

%package help
Summary:	Development documents and examples for py-nextbusnext
Provides:	python3-py-nextbusnext-doc
%description help
Install with pip:
`pip install py-nextbusnext`

%prep
%autosetup -n py_nextbusnext-0.1.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-py-nextbusnext -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.5-1
- Package Spec generated