%global _empty_manifest_terminate_build 0
Name:		python-pyaltherma
Version:	0.0.21
Release:	1
Summary:	Python scripts for controlling Daikin Altherma heat pump using BRP069A62 LAN adapter.
License:	MIT
URL:		https://github.com/tadasdanielius/pyaltherma
Source0:	https://mirrors.aliyun.com/pypi/web/packages/f5/22/b9c49ae7ca04deec59e5cd53108c5aff50ac8d5819c68c1990b393849cd4/pyaltherma-0.0.21.tar.gz
BuildArch:	noarch

Requires:	python3-aiohttp

%description
# pyaltherma
Python library to control Daikin Altherma heat pump
Tested only with BRP069A62

# Usage

```python3
async with aiohttp.ClientSession() as session:
    conn = DaikinWSConnection(session, 'IP_ADDRESS')
    device = AlthermaController(conn)
    await device.discover_units()
    tank = device.hot_water_tank
    climate = device.climate_control
    print(f'Tank / Target temperature: {await tank.tank_temperature} / {await tank.target_temperature}')
    print(f"Indoor/outdoor temperature: {await climate.indoor_temperature}/{await climate.outdoor_temperature}")
    await climate.turn_off()
    await climate.turn_on()
    await conn.close()
```
see example.py for more details.

# Status
Currently, the implementation is in early stage. At the moment it does not support schedules.


%package -n python3-pyaltherma
Summary:	Python scripts for controlling Daikin Altherma heat pump using BRP069A62 LAN adapter.
Provides:	python-pyaltherma
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pyaltherma
# pyaltherma
Python library to control Daikin Altherma heat pump
Tested only with BRP069A62

# Usage

```python3
async with aiohttp.ClientSession() as session:
    conn = DaikinWSConnection(session, 'IP_ADDRESS')
    device = AlthermaController(conn)
    await device.discover_units()
    tank = device.hot_water_tank
    climate = device.climate_control
    print(f'Tank / Target temperature: {await tank.tank_temperature} / {await tank.target_temperature}')
    print(f"Indoor/outdoor temperature: {await climate.indoor_temperature}/{await climate.outdoor_temperature}")
    await climate.turn_off()
    await climate.turn_on()
    await conn.close()
```
see example.py for more details.

# Status
Currently, the implementation is in early stage. At the moment it does not support schedules.


%package help
Summary:	Development documents and examples for pyaltherma
Provides:	python3-pyaltherma-doc
%description help
# pyaltherma
Python library to control Daikin Altherma heat pump
Tested only with BRP069A62

# Usage

```python3
async with aiohttp.ClientSession() as session:
    conn = DaikinWSConnection(session, 'IP_ADDRESS')
    device = AlthermaController(conn)
    await device.discover_units()
    tank = device.hot_water_tank
    climate = device.climate_control
    print(f'Tank / Target temperature: {await tank.tank_temperature} / {await tank.target_temperature}')
    print(f"Indoor/outdoor temperature: {await climate.indoor_temperature}/{await climate.outdoor_temperature}")
    await climate.turn_off()
    await climate.turn_on()
    await conn.close()
```
see example.py for more details.

# Status
Currently, the implementation is in early stage. At the moment it does not support schedules.


%prep
%autosetup -n pyaltherma-0.0.21

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pyaltherma -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.21-1
- Package Spec generated