%global _empty_manifest_terminate_build 0
Name: python-TopDownHockey-Scraper
Version: 2.1.14
Release: 1
Summary: The TopDownHockey Scraper
License: MIT
URL: https://github.com/TopDownHockey/TopDownHockey_Scraper
Source0: https://mirrors.aliyun.com/pypi/web/packages/98/71/c0c1c2770a8b036bfc0d3bb595aafdd8cca921e76c7ab114bcbad18e79c9/TopDownHockey_Scraper-2.1.14.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-bs4
Requires: python3-datetime
Requires: python3-seaborn
Requires: python3-matplotlib
Requires: python3-xmltodict
Requires: python3-lxml
Requires: python3-natsort
%description
This is a package built for scraping two data sources:
1. The NHL's Play-by-Play Reports, which come in the form of HTML/API reports from the NHL and XML reports from ESPN.
2. Elite Prospects, an extremely valuable website which makes hockey data for thousands of leagues available to the public.
This package is strictly built for end users who wish to scrape data for personal use. If you are interested in using Elite Prospects data for professional purposes, I recommend you look into the Elite Prospects API.
While using the scraper, please be mindful of EliteProspects servers.
%package -n python3-TopDownHockey-Scraper
Summary: The TopDownHockey Scraper
Provides: python-TopDownHockey-Scraper
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-TopDownHockey-Scraper
This is a package built for scraping two data sources:
1. The NHL's Play-by-Play Reports, which come in the form of HTML/API reports from the NHL and XML reports from ESPN.
2. Elite Prospects, an extremely valuable website which makes hockey data for thousands of leagues available to the public.
This package is strictly built for end users who wish to scrape data for personal use. If you are interested in using Elite Prospects data for professional purposes, I recommend you look into the Elite Prospects API.
While using the scraper, please be mindful of EliteProspects servers.
%package help
Summary: Development documents and examples for TopDownHockey-Scraper
Provides: python3-TopDownHockey-Scraper-doc
%description help
This is a package built for scraping two data sources:
1. The NHL's Play-by-Play Reports, which come in the form of HTML/API reports from the NHL and XML reports from ESPN.
2. Elite Prospects, an extremely valuable website which makes hockey data for thousands of leagues available to the public.
This package is strictly built for end users who wish to scrape data for personal use. If you are interested in using Elite Prospects data for professional purposes, I recommend you look into the Elite Prospects API.
While using the scraper, please be mindful of EliteProspects servers.
%prep
%autosetup -n TopDownHockey_Scraper-2.1.14
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-TopDownHockey-Scraper -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.1.14-1
- Package Spec generated