%global _empty_manifest_terminate_build 0
Name: python-pokemons
Version: 1.0.3
Release: 1
Summary: Get Awesome Random pokemon names!
License: MIT License
URL: https://yoginth.gitlab.io
Source0: https://mirrors.aliyun.com/pypi/web/packages/5a/3a/81ad1e61a8108bd01db3d9777a8a95c45520cf5c6a57fafcffa6e0276273/pokemons-1.0.3.tar.gz
BuildArch: noarch
%description
## Pokémon Name Generator
> Get Awesome Random pokemon names!
## Screenshot
## Inspired by
- [Sindresorhus's pokemon](https://github.com/sindresorhus/pokemon)
## Install
```
$ pip install pokemons
```
## Usage
```python
import pokemons as names
print (names.gen())
#=> Nidoran♂
print (names.genarr(3))
#=> ['Noivern', 'Misdreavus', 'Cryogonal']
```
## Get Help
There are few ways to get help:
1. Please [post questions on Stack Overflow](https://stackoverflow.com/questions/ask). You can open issues with questions, as long you add a link to your Stack Overflow question.
2. For bug reports and feature requests, open issues.
3. For direct and quick help, you can [email me](mailto://yoginth@zoho.com).
## How to contribute
Have an idea? Found a bug? See [how to contribute][contributing].
Thanks!
## License
[MIT][license]
[LICENSE]: https://yoginth.mit-license.org/
[contributing]: /CONTRIBUTING.md
%package -n python3-pokemons
Summary: Get Awesome Random pokemon names!
Provides: python-pokemons
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pokemons
## Pokémon Name Generator
> Get Awesome Random pokemon names!
## Screenshot
## Inspired by
- [Sindresorhus's pokemon](https://github.com/sindresorhus/pokemon)
## Install
```
$ pip install pokemons
```
## Usage
```python
import pokemons as names
print (names.gen())
#=> Nidoran♂
print (names.genarr(3))
#=> ['Noivern', 'Misdreavus', 'Cryogonal']
```
## Get Help
There are few ways to get help:
1. Please [post questions on Stack Overflow](https://stackoverflow.com/questions/ask). You can open issues with questions, as long you add a link to your Stack Overflow question.
2. For bug reports and feature requests, open issues.
3. For direct and quick help, you can [email me](mailto://yoginth@zoho.com).
## How to contribute
Have an idea? Found a bug? See [how to contribute][contributing].
Thanks!
## License
[MIT][license]
[LICENSE]: https://yoginth.mit-license.org/
[contributing]: /CONTRIBUTING.md
%package help
Summary: Development documents and examples for pokemons
Provides: python3-pokemons-doc
%description help
## Pokémon Name Generator
> Get Awesome Random pokemon names!
## Screenshot
## Inspired by
- [Sindresorhus's pokemon](https://github.com/sindresorhus/pokemon)
## Install
```
$ pip install pokemons
```
## Usage
```python
import pokemons as names
print (names.gen())
#=> Nidoran♂
print (names.genarr(3))
#=> ['Noivern', 'Misdreavus', 'Cryogonal']
```
## Get Help
There are few ways to get help:
1. Please [post questions on Stack Overflow](https://stackoverflow.com/questions/ask). You can open issues with questions, as long you add a link to your Stack Overflow question.
2. For bug reports and feature requests, open issues.
3. For direct and quick help, you can [email me](mailto://yoginth@zoho.com).
## How to contribute
Have an idea? Found a bug? See [how to contribute][contributing].
Thanks!
## License
[MIT][license]
[LICENSE]: https://yoginth.mit-license.org/
[contributing]: /CONTRIBUTING.md
%prep
%autosetup -n pokemons-1.0.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pokemons -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.0.3-1
- Package Spec generated