%global _empty_manifest_terminate_build 0
Name:		python-pencompy
Version:	0.0.4
Release:	1
Summary:	Pencom relay controller over Ethernet
License:	MIT License
URL:		https://github.com/dubnom/pencompy
Source0:	https://mirrors.aliyun.com/pypi/web/packages/aa/5e/b451f0789a783e3c75bab07df8383ada0d576a075b404059f69314cfe0f0/pencompy-0.0.4.tar.gz
BuildArch:	noarch


%description
# Pencom Package

Package to control Pencom serial relay boards through an Ethernet adaptor
using Python.

# Example:

    from time import sleep
    from pencompy import pencompy

    hub = pencompy( 'host.test.com', 4008 )

    # Turn the first relay on
    hub.set( 0, 0, True )

    # Pause for a second
    sleep(1.)

    # Turn the first relay off
    hub.set( 0, 0, False )

    # Close the interface
    hub.close()




%package -n python3-pencompy
Summary:	Pencom relay controller over Ethernet
Provides:	python-pencompy
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pencompy
# Pencom Package

Package to control Pencom serial relay boards through an Ethernet adaptor
using Python.

# Example:

    from time import sleep
    from pencompy import pencompy

    hub = pencompy( 'host.test.com', 4008 )

    # Turn the first relay on
    hub.set( 0, 0, True )

    # Pause for a second
    sleep(1.)

    # Turn the first relay off
    hub.set( 0, 0, False )

    # Close the interface
    hub.close()




%package help
Summary:	Development documents and examples for pencompy
Provides:	python3-pencompy-doc
%description help
# Pencom Package

Package to control Pencom serial relay boards through an Ethernet adaptor
using Python.

# Example:

    from time import sleep
    from pencompy import pencompy

    hub = pencompy( 'host.test.com', 4008 )

    # Turn the first relay on
    hub.set( 0, 0, True )

    # Pause for a second
    sleep(1.)

    # Turn the first relay off
    hub.set( 0, 0, False )

    # Close the interface
    hub.close()




%prep
%autosetup -n pencompy-0.0.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pencompy -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.4-1
- Package Spec generated