%global _empty_manifest_terminate_build 0
Name: python-satoshi
Version: 0.1.4
Release: 1
Summary: Manipulate satoshi-related prices in Python 3, simple and sweet.
License: MIT
URL: https://github.com/quan-digital/satoshi/
Source0: https://mirrors.aliyun.com/pypi/web/packages/0d/85/b5ea79e1d4da6bb2194ff1fb102971f0c3460ba71af1edc9b91ad4d7def0/satoshi-0.1.4.tar.gz
BuildArch: noarch
Requires: python3-requests
%description
# > satoshi
Manipulate satoshi-related prices in Python 3, simple and sweet π΅ βΏπ¬
#### Why complicate?
The idea behind this project is to provide Python programmers with a simple, light and intuitive package to manipulate satoshis.
This can be extremely useful on future/perpetual markets and crypto exchanges that don't automatically associate XBT balances to an USD value. With > satoshi you can use a single function to convert your satoshis to any fiat currency :)
No need to handle more requests and currency mangling in your code, simply use > satoshi and, therefore, [CryptoCompare's](https://www.cryptocompare.com) open API.
#### Installation
```bash
pip install satoshi
```
#### Usage
```python
include satoshi
satoshi.to_fiat(984223) # satoshi to usd
satoshi.to_fiat(18923, 'BRL') # satoshi to reais
```
Feel free to run example.py for a demo.
#### Notes
Project idealized while listening to [this](https://open.spotify.com/track/3X4dJnyoxhFbNw1bX8qas0?si=M4xhiD7vQyerQnMLxfuyfQ) song.
Feel free to become a collaborator.
%package -n python3-satoshi
Summary: Manipulate satoshi-related prices in Python 3, simple and sweet.
Provides: python-satoshi
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-satoshi
# > satoshi
Manipulate satoshi-related prices in Python 3, simple and sweet π΅ βΏπ¬
#### Why complicate?
The idea behind this project is to provide Python programmers with a simple, light and intuitive package to manipulate satoshis.
This can be extremely useful on future/perpetual markets and crypto exchanges that don't automatically associate XBT balances to an USD value. With > satoshi you can use a single function to convert your satoshis to any fiat currency :)
No need to handle more requests and currency mangling in your code, simply use > satoshi and, therefore, [CryptoCompare's](https://www.cryptocompare.com) open API.
#### Installation
```bash
pip install satoshi
```
#### Usage
```python
include satoshi
satoshi.to_fiat(984223) # satoshi to usd
satoshi.to_fiat(18923, 'BRL') # satoshi to reais
```
Feel free to run example.py for a demo.
#### Notes
Project idealized while listening to [this](https://open.spotify.com/track/3X4dJnyoxhFbNw1bX8qas0?si=M4xhiD7vQyerQnMLxfuyfQ) song.
Feel free to become a collaborator.
%package help
Summary: Development documents and examples for satoshi
Provides: python3-satoshi-doc
%description help
# > satoshi
Manipulate satoshi-related prices in Python 3, simple and sweet π΅ βΏπ¬
#### Why complicate?
The idea behind this project is to provide Python programmers with a simple, light and intuitive package to manipulate satoshis.
This can be extremely useful on future/perpetual markets and crypto exchanges that don't automatically associate XBT balances to an USD value. With > satoshi you can use a single function to convert your satoshis to any fiat currency :)
No need to handle more requests and currency mangling in your code, simply use > satoshi and, therefore, [CryptoCompare's](https://www.cryptocompare.com) open API.
#### Installation
```bash
pip install satoshi
```
#### Usage
```python
include satoshi
satoshi.to_fiat(984223) # satoshi to usd
satoshi.to_fiat(18923, 'BRL') # satoshi to reais
```
Feel free to run example.py for a demo.
#### Notes
Project idealized while listening to [this](https://open.spotify.com/track/3X4dJnyoxhFbNw1bX8qas0?si=M4xhiD7vQyerQnMLxfuyfQ) song.
Feel free to become a collaborator.
%prep
%autosetup -n satoshi-0.1.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-satoshi -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.1.4-1
- Package Spec generated