%global _empty_manifest_terminate_build 0
Name:		python-radio-beam
Version:	0.3.4
Release:	1
Summary:	Operations for radio astronomy beams with astropy
License:	BSD
URL:		http://radio_beam.readthedocs.org
Source0:	https://mirrors.aliyun.com/pypi/web/packages/cc/a4/60534f915d7329006967c826e7b4829a0bcef88803e66bdc69832f0b43db/radio-beam-0.3.4.tar.gz
BuildArch:	noarch

Requires:	python3-matplotlib
Requires:	python3-pytest-astropy
Requires:	python3-pytest-cov
Requires:	python3-matplotlib
Requires:	python3-astropy
Requires:	python3-numpy
Requires:	python3-six
Requires:	python3-scipy
Requires:	python3-scipy
Requires:	python3-matplotlib
Requires:	python3-sphinx-astropy

%description
Radio Beam is a simple toolkit for reading beam information from FITS headers
and manipulating beams.  Some example applications include:
 * Convolution and deconvolution
 * Unit conversion (Jy to/from K)
 * Handle sets of beams for spectral cubes with varying resolution between channels
 * Find the smallest common beam from a set of beams
 * Add the beam shape to a matplotlib plot
See the [documentation](https://radio-beam.readthedocs.io/en/latest/) for more information.
[![Build Status](https://travis-ci.org/radio-astro-tools/radio_beam.svg?branch=master)](https://travis-ci.org/radio-astro-tools/radio_beam)

%package -n python3-radio-beam
Summary:	Operations for radio astronomy beams with astropy
Provides:	python-radio-beam
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-radio-beam
Radio Beam is a simple toolkit for reading beam information from FITS headers
and manipulating beams.  Some example applications include:
 * Convolution and deconvolution
 * Unit conversion (Jy to/from K)
 * Handle sets of beams for spectral cubes with varying resolution between channels
 * Find the smallest common beam from a set of beams
 * Add the beam shape to a matplotlib plot
See the [documentation](https://radio-beam.readthedocs.io/en/latest/) for more information.
[![Build Status](https://travis-ci.org/radio-astro-tools/radio_beam.svg?branch=master)](https://travis-ci.org/radio-astro-tools/radio_beam)

%package help
Summary:	Development documents and examples for radio-beam
Provides:	python3-radio-beam-doc
%description help
Radio Beam is a simple toolkit for reading beam information from FITS headers
and manipulating beams.  Some example applications include:
 * Convolution and deconvolution
 * Unit conversion (Jy to/from K)
 * Handle sets of beams for spectral cubes with varying resolution between channels
 * Find the smallest common beam from a set of beams
 * Add the beam shape to a matplotlib plot
See the [documentation](https://radio-beam.readthedocs.io/en/latest/) for more information.
[![Build Status](https://travis-ci.org/radio-astro-tools/radio_beam.svg?branch=master)](https://travis-ci.org/radio-astro-tools/radio_beam)

%prep
%autosetup -n radio-beam-0.3.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-radio-beam -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.4-1
- Package Spec generated