%global _empty_manifest_terminate_build 0 Name: python-pybit Version: 5.3.0 Release: 1 Summary: Python3 Bybit HTTP/WebSocket API Connector License: MIT License URL: https://github.com/bybit-exchange/pybit Source0: https://mirrors.aliyun.com/pypi/web/packages/53/f7/eda77ebe0b2fcaf71c2b4fa6f64713fb90d84b83ce105e2079ef4a8d968b/pybit-5.3.0.tar.gz BuildArch: noarch %description # pybit [![All Contributors](https://img.shields.io/badge/all_contributors-2-orange.svg?style=flat-square)](#contributors-) [![Build Status](https://img.shields.io/pypi/pyversions/pybit)](https://www.python.org/downloads/) [![Build Status](https://img.shields.io/pypi/v/pybit)](https://pypi.org/project/pybit/) ![contributions welcome](https://img.shields.io/badge/contributions-welcome-brightgreen.svg?style=flat) Official Python3 API connector for Bybit's HTTP and WebSockets APIs. ## Table of Contents - [About](#about) - [Development](#development) - [Installation](#installation) - [Usage](#usage) - [Contact](#contact) - [Contributors](#contributors) - [Donations](#donations) ## About Put simply, `pybit` (Python + Bybit) is the official lightweight one-stop-shop module for the Bybit HTTP and WebSocket APIs. Originally created by [Verata Veritatis](https://github.com/verata-veritatis), it's now maintained by Bybit employees – however, you're still welcome to contribute! It was designed with the following vision in mind: > I was personally never a fan of auto-generated connectors that used a mosh-pit of various modules you didn't want (sorry, `bravado`) and wanted to build my own Python3-dedicated connector with very little external resources. The goal of the connector is to provide traders and developers with an easy-to-use high-performing module that has an active issue and discussion board leading to consistent improvements. ## Development `pybit` is being actively developed, and new Bybit API changes should arrive on `pybit` very quickly. `pybit` uses `requests` and `websocket-client` for its methods, alongside other built-in modules. Anyone is welcome to branch/fork the repository and add their own upgrades. If you think you've made substantial improvements to the module, submit a pull request and we'll gladly take a look. ## Installation `pybit` requires Python 3.9.1 or higher. The module can be installed manually or via [PyPI](https://pypi.org/project/pybit/) with `pip`: ``` pip install pybit ``` ## Usage You can retrieve a specific market like so: ```python from pybit.unified_trading import HTTP ``` Create an HTTP session and connect via WebSocket for Inverse on mainnet: ```python session = HTTP( testnet=False, api_key="...", api_secret="...", ) ``` Information can be sent to, or retrieved from, the Bybit APIs: ```python # Get the orderbook of the USDT Perpetual, BTCUSDT session.get_orderbook(category="linear", symbol="BTCUSDT") # Create five long USDC Options orders. # (Currently, only USDC Options support sending orders in bulk.) payload = {"category": "option"} orders = [{ "symbol": "BTC-30JUN23-20000-C", "side": "Buy", "orderType": "Limit", "qty": "0.1", "price": i, } for i in [15000, 15500, 16000, 16500, 16600]] payload["request"] = orders # Submit the orders in bulk. session.place_batch_order(payload) ``` Check out the example python files or the list of endpoints below for more information on available endpoints and methods. Usage examples on the `HTTP` methods can be found in the [examples folder](https://github.com/bybit-exchange/pybit/tree/master/examples). ## Contact You can reach out for support on the [BybitAPI Telegram](https://t.me/BybitAPI) group chat. ## Contributors Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):

dextertd

💻 📖

ervuks

💻 📖

verata-veritatis

💻 📖

APF20

💻

Cameron Harder-Hutton

💻

Tom Rumpf

💻

OnJohn

💻

Todd Conley

🤔
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %package -n python3-pybit Summary: Python3 Bybit HTTP/WebSocket API Connector Provides: python-pybit BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-pybit # pybit [![All Contributors](https://img.shields.io/badge/all_contributors-2-orange.svg?style=flat-square)](#contributors-) [![Build Status](https://img.shields.io/pypi/pyversions/pybit)](https://www.python.org/downloads/) [![Build Status](https://img.shields.io/pypi/v/pybit)](https://pypi.org/project/pybit/) ![contributions welcome](https://img.shields.io/badge/contributions-welcome-brightgreen.svg?style=flat) Official Python3 API connector for Bybit's HTTP and WebSockets APIs. ## Table of Contents - [About](#about) - [Development](#development) - [Installation](#installation) - [Usage](#usage) - [Contact](#contact) - [Contributors](#contributors) - [Donations](#donations) ## About Put simply, `pybit` (Python + Bybit) is the official lightweight one-stop-shop module for the Bybit HTTP and WebSocket APIs. Originally created by [Verata Veritatis](https://github.com/verata-veritatis), it's now maintained by Bybit employees – however, you're still welcome to contribute! It was designed with the following vision in mind: > I was personally never a fan of auto-generated connectors that used a mosh-pit of various modules you didn't want (sorry, `bravado`) and wanted to build my own Python3-dedicated connector with very little external resources. The goal of the connector is to provide traders and developers with an easy-to-use high-performing module that has an active issue and discussion board leading to consistent improvements. ## Development `pybit` is being actively developed, and new Bybit API changes should arrive on `pybit` very quickly. `pybit` uses `requests` and `websocket-client` for its methods, alongside other built-in modules. Anyone is welcome to branch/fork the repository and add their own upgrades. If you think you've made substantial improvements to the module, submit a pull request and we'll gladly take a look. ## Installation `pybit` requires Python 3.9.1 or higher. The module can be installed manually or via [PyPI](https://pypi.org/project/pybit/) with `pip`: ``` pip install pybit ``` ## Usage You can retrieve a specific market like so: ```python from pybit.unified_trading import HTTP ``` Create an HTTP session and connect via WebSocket for Inverse on mainnet: ```python session = HTTP( testnet=False, api_key="...", api_secret="...", ) ``` Information can be sent to, or retrieved from, the Bybit APIs: ```python # Get the orderbook of the USDT Perpetual, BTCUSDT session.get_orderbook(category="linear", symbol="BTCUSDT") # Create five long USDC Options orders. # (Currently, only USDC Options support sending orders in bulk.) payload = {"category": "option"} orders = [{ "symbol": "BTC-30JUN23-20000-C", "side": "Buy", "orderType": "Limit", "qty": "0.1", "price": i, } for i in [15000, 15500, 16000, 16500, 16600]] payload["request"] = orders # Submit the orders in bulk. session.place_batch_order(payload) ``` Check out the example python files or the list of endpoints below for more information on available endpoints and methods. Usage examples on the `HTTP` methods can be found in the [examples folder](https://github.com/bybit-exchange/pybit/tree/master/examples). ## Contact You can reach out for support on the [BybitAPI Telegram](https://t.me/BybitAPI) group chat. ## Contributors Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):

dextertd

💻 📖

ervuks

💻 📖

verata-veritatis

💻 📖

APF20

💻

Cameron Harder-Hutton

💻

Tom Rumpf

💻

OnJohn

💻

Todd Conley

🤔
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %package help Summary: Development documents and examples for pybit Provides: python3-pybit-doc %description help # pybit [![All Contributors](https://img.shields.io/badge/all_contributors-2-orange.svg?style=flat-square)](#contributors-) [![Build Status](https://img.shields.io/pypi/pyversions/pybit)](https://www.python.org/downloads/) [![Build Status](https://img.shields.io/pypi/v/pybit)](https://pypi.org/project/pybit/) ![contributions welcome](https://img.shields.io/badge/contributions-welcome-brightgreen.svg?style=flat) Official Python3 API connector for Bybit's HTTP and WebSockets APIs. ## Table of Contents - [About](#about) - [Development](#development) - [Installation](#installation) - [Usage](#usage) - [Contact](#contact) - [Contributors](#contributors) - [Donations](#donations) ## About Put simply, `pybit` (Python + Bybit) is the official lightweight one-stop-shop module for the Bybit HTTP and WebSocket APIs. Originally created by [Verata Veritatis](https://github.com/verata-veritatis), it's now maintained by Bybit employees – however, you're still welcome to contribute! It was designed with the following vision in mind: > I was personally never a fan of auto-generated connectors that used a mosh-pit of various modules you didn't want (sorry, `bravado`) and wanted to build my own Python3-dedicated connector with very little external resources. The goal of the connector is to provide traders and developers with an easy-to-use high-performing module that has an active issue and discussion board leading to consistent improvements. ## Development `pybit` is being actively developed, and new Bybit API changes should arrive on `pybit` very quickly. `pybit` uses `requests` and `websocket-client` for its methods, alongside other built-in modules. Anyone is welcome to branch/fork the repository and add their own upgrades. If you think you've made substantial improvements to the module, submit a pull request and we'll gladly take a look. ## Installation `pybit` requires Python 3.9.1 or higher. The module can be installed manually or via [PyPI](https://pypi.org/project/pybit/) with `pip`: ``` pip install pybit ``` ## Usage You can retrieve a specific market like so: ```python from pybit.unified_trading import HTTP ``` Create an HTTP session and connect via WebSocket for Inverse on mainnet: ```python session = HTTP( testnet=False, api_key="...", api_secret="...", ) ``` Information can be sent to, or retrieved from, the Bybit APIs: ```python # Get the orderbook of the USDT Perpetual, BTCUSDT session.get_orderbook(category="linear", symbol="BTCUSDT") # Create five long USDC Options orders. # (Currently, only USDC Options support sending orders in bulk.) payload = {"category": "option"} orders = [{ "symbol": "BTC-30JUN23-20000-C", "side": "Buy", "orderType": "Limit", "qty": "0.1", "price": i, } for i in [15000, 15500, 16000, 16500, 16600]] payload["request"] = orders # Submit the orders in bulk. session.place_batch_order(payload) ``` Check out the example python files or the list of endpoints below for more information on available endpoints and methods. Usage examples on the `HTTP` methods can be found in the [examples folder](https://github.com/bybit-exchange/pybit/tree/master/examples). ## Contact You can reach out for support on the [BybitAPI Telegram](https://t.me/BybitAPI) group chat. ## Contributors Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):

dextertd

💻 📖

ervuks

💻 📖

verata-veritatis

💻 📖

APF20

💻

Cameron Harder-Hutton

💻

Tom Rumpf

💻

OnJohn

💻

Todd Conley

🤔
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %prep %autosetup -n pybit-5.3.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-pybit -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Thu Jun 08 2023 Python_Bot - 5.3.0-1 - Package Spec generated