%global _empty_manifest_terminate_build 0
Name:		python-WebLamp
Version:	0.3.0
Release:	1
Summary:	A socket webserver made in python!
License:	MIT License
URL:		https://github.com/coverosu/lamp
Source0:	https://mirrors.aliyun.com/pypi/web/packages/44/09/a1684e1b9a941f285f1ccab71df8fcbbb82909ffc954e20e65d2aa22dd1d/WebLamp-0.3.0.tar.gz
BuildArch:	noarch


%description
# Lamp

An asynchronous webserver made with sockets in python!

Examples of using Lamp:

```py
from Weblamp import Domain, Lamp, Connection

server = Lamp()
domain = Domain(('your.domain.com', '127.0.0.1:5000')) 

@domain.add_route(path = '/', method = ['GET'])
async def home(con: Connection) -> tuple:
  return (200, b'Hello World!')

server.add_domain(domain)
server.run(
  bind = ('127.0.0.1', 5000)
)
```

1 unique thing about this webserver is you can use a regex in your route and domain!

```py
import re

from Weblamp import Domain, Lamp, Connection

server = Lamp()
domain = Domain(('your.domain.com', '127.0.0.1:5000')) 

@domain.add_route(path = re.compile(r'^/u/(?P<userid>[0-9]*)$'), method = ['GET'])
async def home(con: Connection) -> tuple:
    userid = conn.args['userid'] # this came from the regex that was provided

    return (200, userid.encode())

server.add_domain(domain)
server.run(
  bind = ('127.0.0.1', 5000)
)
```




%package -n python3-WebLamp
Summary:	A socket webserver made in python!
Provides:	python-WebLamp
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-WebLamp
# Lamp

An asynchronous webserver made with sockets in python!

Examples of using Lamp:

```py
from Weblamp import Domain, Lamp, Connection

server = Lamp()
domain = Domain(('your.domain.com', '127.0.0.1:5000')) 

@domain.add_route(path = '/', method = ['GET'])
async def home(con: Connection) -> tuple:
  return (200, b'Hello World!')

server.add_domain(domain)
server.run(
  bind = ('127.0.0.1', 5000)
)
```

1 unique thing about this webserver is you can use a regex in your route and domain!

```py
import re

from Weblamp import Domain, Lamp, Connection

server = Lamp()
domain = Domain(('your.domain.com', '127.0.0.1:5000')) 

@domain.add_route(path = re.compile(r'^/u/(?P<userid>[0-9]*)$'), method = ['GET'])
async def home(con: Connection) -> tuple:
    userid = conn.args['userid'] # this came from the regex that was provided

    return (200, userid.encode())

server.add_domain(domain)
server.run(
  bind = ('127.0.0.1', 5000)
)
```




%package help
Summary:	Development documents and examples for WebLamp
Provides:	python3-WebLamp-doc
%description help
# Lamp

An asynchronous webserver made with sockets in python!

Examples of using Lamp:

```py
from Weblamp import Domain, Lamp, Connection

server = Lamp()
domain = Domain(('your.domain.com', '127.0.0.1:5000')) 

@domain.add_route(path = '/', method = ['GET'])
async def home(con: Connection) -> tuple:
  return (200, b'Hello World!')

server.add_domain(domain)
server.run(
  bind = ('127.0.0.1', 5000)
)
```

1 unique thing about this webserver is you can use a regex in your route and domain!

```py
import re

from Weblamp import Domain, Lamp, Connection

server = Lamp()
domain = Domain(('your.domain.com', '127.0.0.1:5000')) 

@domain.add_route(path = re.compile(r'^/u/(?P<userid>[0-9]*)$'), method = ['GET'])
async def home(con: Connection) -> tuple:
    userid = conn.args['userid'] # this came from the regex that was provided

    return (200, userid.encode())

server.add_domain(domain)
server.run(
  bind = ('127.0.0.1', 5000)
)
```




%prep
%autosetup -n WebLamp-0.3.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-WebLamp -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0-1
- Package Spec generated