%global _empty_manifest_terminate_build 0
Name:		python-lucifer-ml
Version:	0.0.79
Release:	1
Summary:	Automated ML by d4rk-lucif3r
License:	MIT
URL:		https://github.com/d4rk-lucif3r/LuciferML
Source0:	https://mirrors.aliyun.com/pypi/web/packages/22/01/7b5203793d9cc5e1c962ab0a8fcab0394ca35e59d7558cd97f35815952cc/lucifer-ml-0.0.79.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-pandas
Requires:	python3-scipy
Requires:	python3-seaborn
Requires:	python3-matplotlib
Requires:	python3-scikit-learn
Requires:	python3-imblearn
Requires:	python3-xgboost
Requires:	python3-tensorflow
Requires:	python3-catboost
Requires:	python3-lightgbm
Requires:	python3-optuna
Requires:	python3-shap
Requires:	python3-colorama

%description
## [To-Do's](https://github.com/d4rk-lucif3r/LuciferML/issues/10)

%package -n python3-lucifer-ml
Summary:	Automated ML by d4rk-lucif3r
Provides:	python-lucifer-ml
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-lucifer-ml
## [To-Do's](https://github.com/d4rk-lucif3r/LuciferML/issues/10)

%package help
Summary:	Development documents and examples for lucifer-ml
Provides:	python3-lucifer-ml-doc
%description help
## [To-Do's](https://github.com/d4rk-lucif3r/LuciferML/issues/10)

%prep
%autosetup -n lucifer-ml-0.0.79

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-lucifer-ml -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.79-1
- Package Spec generated