%global _empty_manifest_terminate_build 0
Name: python-VividHues
Version: 5.9.2
Release: 1
Summary: VividHues: Super light Python string formatter!
License: AGPL-3.0
URL: https://github.com/KennyOliver/VividHues
Source0: https://mirrors.aliyun.com/pypi/web/packages/88/06/cecfcd2f0d7eac68f2ce0ba126bf6f94d03424f1447137fbe0eab7477e42/VividHues-5.9.2.tar.gz
BuildArch: noarch
%description
## :hammer_and_wrench: Official Installation
### :zap: _Instant Installer + Updater_
:point_right:
:point_left:
#### :page_with_curl: Instant Installer — Instructions
##### **Once you've downloaded `install_vividhues.sh`...**
###### Run the command `bash install_vividhues.sh` in your shell/CLI. (Or... double click the `install_vividhues.sh` file)
> :memo: **Note!**
>
> This requires Bash to be installed on your OS.
> Git Bash or WSL are two of many to pick from!
#### :cyclone: Replit Installation
👉 Replit instructions in here! 👈
1. Upload the installer script to your project's file system
2. Run `bash install_vividhues.sh` in the _**shell**_
#### :shell: Manual Shell Installation
👉 Manual instructions in here! 👈
##### Pop this command in your CLI/shell/terminal to install VividHues.
```bash
$ pip install VividHues
```
> #### :bulb: Tip
> ###### Use this command to update
> ```bash
> pip install --upgrade VividHues
> ```
## :ship: Importing
##### Stick this wherever you need VividHues!
```py
from VividHues import Clr
```
%package -n python3-VividHues
Summary: VividHues: Super light Python string formatter!
Provides: python-VividHues
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-VividHues
## :hammer_and_wrench: Official Installation
### :zap: _Instant Installer + Updater_
:point_right:
:point_left:
#### :page_with_curl: Instant Installer — Instructions
##### **Once you've downloaded `install_vividhues.sh`...**
###### Run the command `bash install_vividhues.sh` in your shell/CLI. (Or... double click the `install_vividhues.sh` file)
> :memo: **Note!**
>
> This requires Bash to be installed on your OS.
> Git Bash or WSL are two of many to pick from!
#### :cyclone: Replit Installation
👉 Replit instructions in here! 👈
1. Upload the installer script to your project's file system
2. Run `bash install_vividhues.sh` in the _**shell**_
#### :shell: Manual Shell Installation
👉 Manual instructions in here! 👈
##### Pop this command in your CLI/shell/terminal to install VividHues.
```bash
$ pip install VividHues
```
> #### :bulb: Tip
> ###### Use this command to update
> ```bash
> pip install --upgrade VividHues
> ```
## :ship: Importing
##### Stick this wherever you need VividHues!
```py
from VividHues import Clr
```
%package help
Summary: Development documents and examples for VividHues
Provides: python3-VividHues-doc
%description help
## :hammer_and_wrench: Official Installation
### :zap: _Instant Installer + Updater_
:point_right:
:point_left:
#### :page_with_curl: Instant Installer — Instructions
##### **Once you've downloaded `install_vividhues.sh`...**
###### Run the command `bash install_vividhues.sh` in your shell/CLI. (Or... double click the `install_vividhues.sh` file)
> :memo: **Note!**
>
> This requires Bash to be installed on your OS.
> Git Bash or WSL are two of many to pick from!
#### :cyclone: Replit Installation
👉 Replit instructions in here! 👈
1. Upload the installer script to your project's file system
2. Run `bash install_vividhues.sh` in the _**shell**_
#### :shell: Manual Shell Installation
👉 Manual instructions in here! 👈
##### Pop this command in your CLI/shell/terminal to install VividHues.
```bash
$ pip install VividHues
```
> #### :bulb: Tip
> ###### Use this command to update
> ```bash
> pip install --upgrade VividHues
> ```
## :ship: Importing
##### Stick this wherever you need VividHues!
```py
from VividHues import Clr
```
%prep
%autosetup -n VividHues-5.9.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-VividHues -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 5.9.2-1
- Package Spec generated