%global _empty_manifest_terminate_build 0
Name:		python-xray-rpc
Version:	1.5.2
Release:	1
Summary:	gRPC files generated from Xray source code.
License:	MIT
URL:		https://github.com/laoshan-tech/xray-rpc
Source0:	https://mirrors.aliyun.com/pypi/web/packages/4f/53/c21917448021b0a462b0fff41ea83707caa6fd50206a874b1b06fc78309e/xray-rpc-1.5.2.tar.gz
BuildArch:	noarch

Requires:	python3-grpcio
Requires:	python3-grpcio-tools
Requires:	python3-httpx

%description
# xray-rpc

![GitHub Workflow Status](https://img.shields.io/github/workflow/status/laoshan-tech/xray-rpc/Upload%20Python%20Package?style=flat-square)
![GitHub](https://img.shields.io/github/license/laoshan-tech/xray-rpc?style=flat-square)
![GitHub repo size](https://img.shields.io/github/repo-size/laoshan-tech/xray-rpc?style=flat-square)
![PyPI](https://img.shields.io/pypi/v/xray-rpc?color=blue&style=flat-square)
[![Telegram](https://img.shields.io/badge/news-telegram-26A5E4?style=flat-square&logo=telegram)](https://t.me/laoshan_tech)
[![Telegram](https://img.shields.io/badge/chat-telegram-26A5E4?style=flat-square&logo=telegram)](https://t.me/laoshan_tech_discuss)

通过 Xray 源码 proto 文件自动生成的 gRPC 代码,版本号对应 Xray 相对应。

## 安装

通过 pip 安装。

```shell
pip install xray-rpc
```

## 使用

参考 [xray-node](https://github.com/laoshan-tech/xray-node/blob/master/xray_node/core/xray.py) 中的用法。

%package -n python3-xray-rpc
Summary:	gRPC files generated from Xray source code.
Provides:	python-xray-rpc
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-xray-rpc
# xray-rpc

![GitHub Workflow Status](https://img.shields.io/github/workflow/status/laoshan-tech/xray-rpc/Upload%20Python%20Package?style=flat-square)
![GitHub](https://img.shields.io/github/license/laoshan-tech/xray-rpc?style=flat-square)
![GitHub repo size](https://img.shields.io/github/repo-size/laoshan-tech/xray-rpc?style=flat-square)
![PyPI](https://img.shields.io/pypi/v/xray-rpc?color=blue&style=flat-square)
[![Telegram](https://img.shields.io/badge/news-telegram-26A5E4?style=flat-square&logo=telegram)](https://t.me/laoshan_tech)
[![Telegram](https://img.shields.io/badge/chat-telegram-26A5E4?style=flat-square&logo=telegram)](https://t.me/laoshan_tech_discuss)

通过 Xray 源码 proto 文件自动生成的 gRPC 代码,版本号对应 Xray 相对应。

## 安装

通过 pip 安装。

```shell
pip install xray-rpc
```

## 使用

参考 [xray-node](https://github.com/laoshan-tech/xray-node/blob/master/xray_node/core/xray.py) 中的用法。

%package help
Summary:	Development documents and examples for xray-rpc
Provides:	python3-xray-rpc-doc
%description help
# xray-rpc

![GitHub Workflow Status](https://img.shields.io/github/workflow/status/laoshan-tech/xray-rpc/Upload%20Python%20Package?style=flat-square)
![GitHub](https://img.shields.io/github/license/laoshan-tech/xray-rpc?style=flat-square)
![GitHub repo size](https://img.shields.io/github/repo-size/laoshan-tech/xray-rpc?style=flat-square)
![PyPI](https://img.shields.io/pypi/v/xray-rpc?color=blue&style=flat-square)
[![Telegram](https://img.shields.io/badge/news-telegram-26A5E4?style=flat-square&logo=telegram)](https://t.me/laoshan_tech)
[![Telegram](https://img.shields.io/badge/chat-telegram-26A5E4?style=flat-square&logo=telegram)](https://t.me/laoshan_tech_discuss)

通过 Xray 源码 proto 文件自动生成的 gRPC 代码,版本号对应 Xray 相对应。

## 安装

通过 pip 安装。

```shell
pip install xray-rpc
```

## 使用

参考 [xray-node](https://github.com/laoshan-tech/xray-node/blob/master/xray_node/core/xray.py) 中的用法。

%prep
%autosetup -n xray-rpc-1.5.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-xray-rpc -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.5.2-1
- Package Spec generated